No sound hp dv4 intel hda

So I’m pretty new to linux and installed openSUSE 11.1 running KDE 4.1 today. I have everything but the sound working. I’ve followed these two posts here of similar problems that oldcpu has helped with:

No sound in opensuse 11.1 - openSUSE Forums
No sound on Dell Studio 1737 - openSUSE Forums

I’ve also been following the sound trouble shooting page. I have an hp dv4-1222nr laptop. Here is my output to the commands that were requested in the above posts. If anyone can help me, that would be awesome. Thanks in advance.

/usr/sbin/alsa-info.sh
http://www.alsa-project.org/db/?f=4ea11bfbf7b69936ee0d35ac84dd4c65c259eb9a

rpm -qa | grep alsa
alsa-driver-kmp-default-1.0.19.20090429_2.6.27.21_0.1-1.1
alsa-utils-1.0.19-5.1
alsa-firmware-1.0.19-4.1
alsa-plugins-1.0.19-3.4
alsa-1.0.18-8.7
alsa-plugins-pulse-1.0.19-3.4
alsa-tools-1.0.19-4.3
alsa-oss-1.0.17-2.2

rpm -qa | grep pulse
pulseaudio-module-zeroconf-0.9.12-9.6
libpulsecore4-0.9.12-9.6
libpulse-browse0-0.9.12-9.6
pulseaudio-utils-0.9.12-9.6
pulseaudio-module-x11-0.9.12-9.6
pulseaudio-module-bluetooth-0.9.12-9.6
pulseaudio-module-lirc-0.9.12-9.6
libpulse0-0.9.12-9.6
libxine1-pulse-1.1.15-20.8
pulseaudio-0.9.12-9.6
pulseaudio-esound-compat-0.9.12-9.6
alsa-plugins-pulse-1.0.19-3.4
libpulse-mainloop-glib0-0.9.12-9.6
pulseaudio-module-jack-0.9.12-9.6

rpm -q libasound2
libasound2-1.0.18-8.7

uname -a
Linux linux-pnxe 2.6.27.21-0.1-default #1 SMP 2009-03-31 14:50:44 +0200 i686 athlon i386 GNU/Linux

cat /etc/modprobe.d/sound
options snd-hda-intel model=hp-m4,hp-m4
options snd slots=snd-hda-intel,snd-hda-intel

5Dex.oB+Yu+RuhF7:SBx00 Azalia (Intel HDA)

alias snd-card-0 snd-hda-intel

l4dC.vfAxXUx5zd4:RS780 Azalia controller

alias snd-card-1 snd-hda-intel

WELL DONE ! in getting as far as you got … you are so very close to getting this to work.

Thanks for that. I see a 32-bit openSUSE-11.1 with a 2.6.27.21 kernel with an update to 1.0.19 of alsa and also your PC has a IDT 92HD71B7X hardware audio codec.

I note the syntax you are employing in the /etc/modprobe.d/sound file could be wrong (I’ve never read of that syntax successfully used). Lets look at the /etc/modprobe.d/sound file :

I believe you have the hp-m4 model applied incorrectly. Simply use: “options snd-hda-intel model=hp-m4” for that first line, save the change, reboot and test.

Reference your installed alsa apps, they look ok. The versions numbers you quoted were initially a surprise to me, but I see the openSUSE/alsa dev has changed (probably about a week ago) how he packages these rpms, and from what I can see, you have it correct.

So make the change to your /etc/modprobe.d/sound file, reboot, and test your audio. Note as well, the other options for the IDT 92HD71B7X are:

STAC92HD71B*
============
  ref		Reference board
  dell-m4-1	Dell desktops
  dell-m4-2	Dell desktops
  dell-m4-3	Dell desktops
  hp-m4		HP dv laptops

and if the “hp-m4” does not work, you need to try the others, restarting the alsa sound driver each time you try another.

For testing your sound, please continue to use the sound test from the audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE - how to test your sound where hopefully one of those will work.

Once you have basic sound established, let us know. There is more configuration needed (which fortunately is easy, although the explanation will be long) that we can help you with to configure your multimedia apps so that you hear sound from the many proprietary audio formats that are circulating today.

Thank you so much. The sound is working. What else do I need to do now?

Congratulations! And well done on sorting this so quickly. Me thinks you have a knack for this …

Anyway, if you can excuse my somewhat excessive pontification, I provided my recommendation in this post (toward the later part of the post, in terms of setting up your Software Package manager and some software to install): openSUSE Forums - View Single Post - setting up your multimedia

Thank you so much for your help.