No sound from the built-in speakers

Hi all,

I have a fujitsu-amilio laptop and I installed openSUSE11.1 last week.
At first there was no sound at all, but with the help of the audio troubleshooting guide from here in this forum I’ve managed to get sound from the headphones jack, but I still haven’t get any sound from the original built-in speakers.

Thanks for any help

Hi !

I have an old Fujitsu Siemens laptop (7400M) running openSUSE-10.3, but its likely MUCH older than yours. I wrote the audiotroubleshooting guide, and I’m glad to read it helped a little bit (even if not complete). Perhaps we can help with the speakers, but I need some more information as your laptop is likely different from mine (plus you are running the newer openSUSE on your laptop). …

So can you provide more very detailed information so a good recommendation can be given? In the case of openSUSE-11.1, you can do that, with your PC connected to the internet, by opening a gnome-terminal or a kde konsole and type “su” (no quotes and enter root password to get root permissions) and then type with root permissions twice:/usr/sbin/alsa-info.shthe first time it will offer to update the diagnostic script (please update), and the second time that will run the diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL here. Just the URL.

Also, please to provide additional information, copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

I know thats a lot of information to ask for, but in truth, since I probably do not have the exact same hardware and since I don’t have direct access to your PC, thats the only way I can get the information needed to hopefully come up with a good recommendation.

Hi oldcpu,

Thanks for your time and help;).

Every help is highly appreciated.

So here is the alsa script URL:
alsaproject.org

rpm -qa | grep alsa

alsa-utils-1.0.18-6.4
alsa-plugins-1.0.18-6.12
alsa-1.0.18-8.7
alsa-firmware-1.0.17-1.42
alsa-plugins-pulse-1.0.18-6.12
alsa-oss-1.0.17-1.37

rpm -qa | grep pulse

pulseaudio-module-zeroconf-0.9.12-9.6
libpulsecore4-0.9.12-9.6
libpulse-browse0-0.9.12-9.6
pulseaudio-utils-0.9.12-9.6
pulseaudio-module-x11-0.9.12-9.6
pulseaudio-module-bluetooth-0.9.12-9.6
pulseaudio-module-lirc-0.9.12-9.6
libpulse0-0.9.12-9.6
libxine1-pulse-1.1.15-20.8
pulseaudio-0.9.12-9.6
pulseaudio-esound-compat-0.9.12-9.6
libpulse-mainloop-glib0-0.9.12-9.6
alsa-plugins-pulse-1.0.18-6.12
vlc-aout-pulse-0.9.8a-15.1
pulseaudio-module-jack-0.9.12-9.6

rpm -q libasound2

libasound2-1.0.18-8.7

uname -a

Linux linux-ibal 2.6.27.19-3.2-pae #1 SMP 2009-02-25 15:40:44 +0100 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

Thanks in advance;)

OK, thanks for that. I think you meant to have a “dash” between the “alsa” and the “project” (which I edited in the above quote).

From the script and the other output, I can see your PC has a 32-bit openSUSE-11.1 with the latest 2.6.27.19-3.2-pae, running the installations’ default alsa mix of 1.0.17 and 1.0.18.

I note your PC has a Motorola Si3054 hardware audio codec with an ALC880. … more on that later.

Checking your mixer, I note you have both your master and PC volume controls UP to 100%, which is good for testing (you can back them off once sound is established). But some other settings puzzle me (I’ve copied and pasted selected items below):

  • !!Amixer output
  • !!-------------
  • !!-------Mixer controls for card 0 [Intel]
  • Simple mixer control ‘Surround’,0
  • Front Left: Playback 0 0%
    ] -64.00dB] on]
  • Front Right: Playback 0 0%
    ] -64.00dB] on]
  • Simple mixer control ‘Center’,0
  • Mono: Playback 0 0%
    ] -64.00dB] on]
  • Simple mixer control ‘LFE’,0
  • Mono: Playback 0 0%
    ] -64.00dB] on]
  • Simple mixer control ‘Side’,0
  • Front Left: Playback 0 0%
    ] -64.00dB] on]
  • Front Right: Playback 0 0%
    ] -64.00dB] on]
  • Simple mixer control ‘Line’,0
  • Front Left: Playback 0 0%
    ] -35.00dB] on]
  • Front Right: Playback 0 0%
    ] -35.00dB] on]
  • Simple mixer control ‘IEC958’,0
  • Mono: Playback [off] Capture [off]
  • Simple mixer control ‘IEC958 Default PCM’,0
  • Mono: Playback [on]

I don’t have your hardware, so I can only look at the configuration, and ask “why”. For example, your PC has many switches ON but have the volume control at 0%. I suspect these should be OFF, or if ON, then move up the volume control. For example, why does your PC have surround sound ON with its volume at 0%? I note your PC has digital audio (IEC958) OFF but the PCM volume control is ON. Is that not inconsistent?

Still, I suspect those have nothing to do with your audio problem, although you could try to fix them and see if that helps.

What I suspect is necessary, is you try one of two things:
a. try to update your alsa and see if that will help, or
b. try a custom model configuration to your /etc/modprobe.d/sound file and see if that will help.

I did a search on the alsa web sites for updates to the Si3054 and I obtained this hit Search results - AlsaProject and to the ALC880 and obtained this hit: Search results - AlsaProject where in both cases 1.0.17 of alsa should have the latest fixes, and you have 1.0.17 of alsa.

But I do note you have the latest 2.6.27.19 kernel, with an alsa that was built for the older 2.6.27.7 kernel, so lets update alsa first (which is relatively easy) in case improvements to the 1.0.19 auto probe (built for the newer kernel) has more success in recognizing your PC’s audio hardware. My reference for updating will be this URL: Alsa-update - openSUSE

You can update by opening a terminal or a konsole, and type “su” (no quotes - enter root password when prompted) and then with your PC connected to the internet, copy and paste the following six zypper commands, one at a time, in sequence, and execute them one at a time, in the terminal you now have opened with root permissions:

zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.1/ multimedia
zypper install alsa alsa-oss alsa-plugins alsa-plugins-pulse alsa-utils alsa-tools alsa-firmware libasound2
zypper rr multimedia
zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1_Update/ multimedia
zypper install alsa-driver-kmp-pae
zypper rr multimedia

then restart your PC and test your sound. Be certain to check your mixer.

If that does not work, please post here and advise, and I will propose an iterative troubleshooting strategy to tune your /etc/modprobe.d/sound file.

Hi oldcpu,

Thanks for your help it works.

After updating I had to play a little bit with the slider in the mixer.

It was a little bit confusing because the front left, the surround and also the pcm slider have effect on the built in speakers volume, so if any of these tree are down, there is no sound from the speakers.

But now I know it.

Anyway once again thanks for your help - highly appreciated.

Interesting …

…AND … CONGRATULATIONS on sorting the sound.

I’ve looked at many different users’ mixer configurations, and I still find it confusing . :open_mouth:

I’m glad to read you were able to work your way through this, and come up with a mixer configuration that works.