No sound from speakers

I’m running openSUSE 11.1, KDE 3.5.10. I used to get system sounds (like startup etc) and I could get sounds from Amarok when I played .mp3 files.

However, yesterday my Amarok crashed and I could not get any sound from Amarok (I was using gstreamer/auaup engine, didn’t have any other engine). But I could still hear the system sounds like shutdown, startup etc.

So I was playing around with KMix and alsamixer settings. I don’t have root access on the computer so I can’t change any configuration files or anything. Just changed the volume controls etc. But now I can’t get any system sounds.

I ran speaker-test and no sound there either. All my mixer volume controls are on max but I can’t remember exactly what I changed on KMix. I’m thinking I messed up the switches some how.

Can anyone help? This is my office computer and I don’t have any root access.

You need to look at your mixer.

You can share your PC’s audio configuration with others, by running the script:


and select the SHARE/UPLOAD option. That will give you a URL and you can post the URL here.

But you really should chat with your system administrator/support staff who have the administrator permissions.

Thanks for the reply. Please find the link below. Unfortunately, sorting out sound on individual systems is not high on my system admin’s priority list.

I don’t see anything obviously wrong in your mixer. Are you certain your speakers wiring is correct (assuming a desktop).

I do note your PC is a 64-bit openSUSE-11.1 with the basic 1.0.17/1.0.18 version of alsa that comes with 11.1. It has the basic (not updated) kernel on hardware with the IDT 92HD71B7X hardware codec. Thats an easy to break codec with 11.1 of alsa, although I see no evidence to suggest an update has broken it. Its possible a kernel update (which you do not have) will break it.

Its possible another application has seized the sound device and is not letting go of it. You can check to see what application is using the sound device by typing:

lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

… there is an example in this URL as to how that can be used to glean useful information:
sound stop working after updating on asus k50in - openSUSE Forums

Please do not post the output here. I am going away for 2 weeks and do not have the time to look at it.

Cheers. It’s actually a laptop and I’m pretty sure the speakers are fine cos it used to work before.

From what I typed it seems that only KMix is using the sound card. Perhaps I’ll disturb the sys admin a bit more.

I have now connected a USB Headset that has it’s own soundcard and now I only can hear the system sounds.

I have tried the speaker-test and it works well but I can’t play the sound on youtube or Amarok for example.

The other thing is in Amarok the only engine that I can select is GStreamer/Yauap engine.

Am I missing some codes?

I have not used KDE3 for a while, so I forget some things about it … in KDE4 one often has to specify the device priority in both YaST > Hardware > Sound and also in the KDE4 > configure desktop.

I think maybe just YaST in KDE3 ? Take a look at step 9 here: SDB:AudioTroubleshooting - openSUSE

Reference Amarok, please ensure you add Packman as a repository in your software package manager, and remove videolan as a repository. And then install Packman packaged libxine1 and amarok-xine (I think that is what it is called). I think for KDE3 there may also be a packman packaged amarok, and if so, install that replacing the Novell one. You can tell packman packaged apps by the ‘pm’ in the version number.

Typically rpms from videolan repository break audio from packman packaged apps, and hence aside from libdvdcss2, I recommend you only use packman packaged apps for your multimedia. This includes libffmpeg0 which picks up in dependencies a bunch of codecs. Also w32codec-all.

note I’m currently on business, with only minutes of internet access. And I am about to go on vacation with no internet access (its too expensive on the cruise ship). So it may be a couple of weeks before I come back to this thread.