No sound from speakers or headphone port.

I’ve set up both of my cards (or at-least tried);

Lynx Point High Definition Audio Controller
Haswell High Definition Audio Controller

and I have had no luck getting audio from my speakers or audio ports. When I go to YaST>Sound and test the audio on the cards I only get the trumpet sound from the card that is set as (1). I know that (0) is my first car and that (1) is my second, so why do I get sound in YaST from the second one? Also when I set the second ohene as the primary card and I retry the test I only, again, get sound from the card set as my second one (1). Can anyone help me?

p.s: I’m a noob

Is this KDE or Gnome, as it may make a difference, especially since KDE has a settings area that defines specifics for the audio

I have two sound devices also but just stick with the one, on-board system.

Uhm,…XFCE?

To help better understand your sound configuration, and also understand better any possible misconfiguration, could you please run the following diagnostic script ? With your PC connected to the Internet, open a konsole/xterm and in that konsole/xterm as a regular user send the following command:


/usr/sbin/alsa-info.sh

and don’t update if asked, and select the SHARE/UPLOAD option when prompted. Let the script run to completion. In the konsole/xterm it will provide you a web-address/URL where it has uplaoded the configuration information. Please provide that web-address/URL so we can inspect your PC’s audio configuration.

Possibly armed with that information, we may be able to better provide you with an appropriate recommendation to address your audio problem.
.

Ok I did it. Here is the link it provided

http://www.alsa-project.org/db/?f=ba30245183baae171ff1063bb975c9420cba84f8

Anything else I can assist with?

I am trying to match what I read above with what I see in the script output

I note a laptop running openSUSE-13.2 (64-bit version) with two sound devices, where card/device-0 is the laptop’s HDMI (Intel Haswell HDMI) and card/device-1 is the laptop’s digital/analog audio (Realtek ALC892)

You probably do not have HDMI setup , which is likely why you get no sound from card-0.

Probably the reason you only get sound from card-1, when you try to change the digital/analog audio to card-0 is yast fails to do so properly. This is because both the HDMI and the ALC892 are both using the alsa Intel kernel module (alsa driver for audio) and Yast does not have the ‘code’ to setup a way to differentiate.

Now that that this has been explained, are you happy with this setup, or do you need to be given a way to force the ALC892 to be card-0 ? There is a way to do so, but its complex and I would need to give you a specifc hard code edit to the /etc/modprobe.d/50-sound.conf file in order to make such a force work.

I note you do not have pulse audio running, hence you can not use puavucontrol to force audio to your desired device.

But as noted, I can provide you an edit if your speaker sound is not working for your nominal applications.

Apologies - my replies will be slow, as I am on vacation and only check the forum once every day or two.

In case you need this edit (because sound is not working in your applications) to help me come up with the correct edit, could you please copy here the content of the file /etc/modprobe.d/50-sound.conf ?

You can see the content of that file by typing:


cat /etc/modprobe.d/50-sound.conf

I also noted this in your script output:


!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!-------------------------------------------------------

00:03.0 0403:** 8086:0c0c** (rev 06)
	Subsystem: 1558:6557
--
00:1b.0 0403: **8086:8c20** (rev 05)
	Subsystem: 1558:6557

Further to the above, likely, I will ask you to place the following at the start of that /etc/modprobe.d/50-sound.conf file (before the other lines). I am guessing that pid=08c20 is your ALC892 and the pid=0c0c is the HDMI


options snd_hda_intel index=0 vid=8086 pid=8c20 
options snd_hda_intel index=1 vid=8086 pid=0c0c

Then after making the edit, do a reboot and see if that succeeds in reversing the cards order.

I honestly don’t know which one would be better. I’m guessing the Realtek ALC card would be better?

P.S: I’m also busy with work so I’ll have slow replies.

options snd slots=snd-hda-intel,snd-hda-intel

3hqH.ePW4OJM81O1:Haswell HD Audio Controller

alias snd-card-1 snd-hda-intel

u1Nb.R9o2zE_xLv2:Lynx Point High Definition Audio Controller

alias snd-card-0 snd-hda-intel

This is what shows up when I type the code in.

How exactly do I edit the file? Sorry, I’m such a noob :frowning:

Use any text editor. In Linux there are dozens LOL.

I think either nano or joe is installed by default for the command line vi is always available and then ther is kate and kwriter in KDE also nice but needs to be installed is midnight commander (mc).

In this case you need to be root to edit the file so become root in a console

su -

note the dash

type the root password note the characters do not eco any thing just type the password

then
nano /etc/modprobe.d/50-sound.conf

if that does not work you can either install nano or try

joe /etc/modprobe.d/50-sound.conf

either is a nice simple text editor with obvious help
type exit to stop being root or just close the console

In addition to gogalthorp’s instruction rather than adding the two lines I suggested you could try replacing the entire content of the 50-sound.conf file with the two lines I provided.

Yes the Realtek is most likely better, as the HDMI is intended to drive audio on external devices (such as a TV ) if your laptop is connected to such.

Ditto. Replaced whole text with those two lines that you gave me before.

Nano wasn’t built in but joe was. I successfully edited the file and saved it. Thanks for the instructions.

Al-right, After I typed the two lines in I saved the file and restarted my laptop. When I pulled up yast>Hardware>Sound I saw that both cards were un-configured. So I decided to configure the Realtek card first in order to make it my first card and then I tried to test the sound of both cards and only got the “trumpets” on the second card (1). Then I went on youtube and souncloud to test the audio again, and nothing :frowning:

Do not use Yast in this case.

Just because Yast does not recognize the configuration does not mean the sound will not work. As soon as you went to Yast and saved a configuration it will likely remove the custom entry that I had you apply. Please reapply the change to the 50-sound.conf file, reboot and test your audio in an application or with an alsa test command WITHOUT using Yast.

It worked on youtube and soundcloud. I now have functioning speakers. The problem is that pulseaudio won’t connect to it, and I don’t have a volume setting on the bottom right of my desktop bar. I only control volume through my function keys and online video/music player settings.

Sound works! Good news.

OF course pulse will not connect. Pulse is not running on your system. I pointed that out in post # 6 above.

Wrt a volume control, you stated (?) you were using XFCE and that is an XFCE desktop issue and you need an XFCE desktop user to help you there!