No Sound from Sound Blaster Audigy Rev.2

Here is what I get when I run cat /proc/asound/cards

linux-9pbl:~ # cat /proc/asound/cards
0 [Audigy ]: Audigy - Audigy 1 [Unknown]
Audigy 1 [Unknown] (rev.3, serial:0x581102) at 0xdf80, irq 17

Any ideas on why it says unknown when it is known as a sb0090 in yast?

I have tried all of the guides, updated all of the packages, made sure nothing is muted, still with no sound.

Here is the link to my

Thanks to oldpcu for the time with everything any help would be appreciated!!!

oops I meant oldcpu

In note this in your mixer:
Simple mixer control ‘Audigy Analog/Digital Output Jack’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]Since you have updated alsa, try this in both OFF and ON settings, running the speaker tests you were given in the previous thread.

What is the output of:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

rpm -qa | grep alsa


rpm -qa | grep pulse


rpm -q libasound2

uname -a
Linux linux-9pbl #1 SMP 2009-07-01 15:37:09 +0200 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/sound

options snd slots=snd-emu10k1

nEtx.UA_FX7gr_M5:SB0090 Audigy Player/OEM

alias snd-card-0 snd-emu10k1

Ok, so try the daily snapshots next.
Alsa-update - openSUSE

I gave you the commands in the previous thread. It looks like you did not send them. Why? How can I help if you don’t follow all asked to check?

I’m off to bed now. I also have to go in to work tomorrow (sunday)

Be certain you check your mixer and try toggling any digital audio and jack setting commands when testing.

And use the speaker test from the troubleshooting guide when testing.

If you don’t do that, you are wasting your time.

I will and I really do appreciate your time.

I see you closed the other thread. Please forgive my ignorance, I didn’t know it was bad form to post twice as I am new to this.

Don’t forget to check your hardware on that PC … ie check the cables are connected to the appropriate jacks, … speakers plugged in, etc … If you have another operating system to test the hardware against, please do so to confirm the hardware is good.

I checked cables and all is well. I am dual booting xp home and sound works there.

One other thing that may be of note. When I run alsaconf it finds my audigy but it also finds this:

legacy Probe legacy ISA (non-PnP) chips

Does this mean anything? When I select it it says running this may make your system unstable so I didnt do it.

I don’t have your hardware so I do not know the effect.

Try it. If it does not work, then you can run it again and go back to the previous settings.

Did you try the daily snap shots yet?

I recall you asking about digital. Note IEC958 is digital.

I note in your mixer:

Simple mixer control ‘IEC958 Optical’,0
Front Left: Playback 0 [0%] -99999.99dB] Capture 0 [0%] -99999.99dB]
Front Right: Playback 0 [0%] -99999.99dB] Capture 0 [0%] -99999.99dB]
Simple mixer control ‘IEC958 Optical Raw’,0
Front Left: Playback [on]
Front Right: Playback **[on]**What happens if you switch IEC958 OFF ? Or alternatively, what happens if you move up its playback to 95% ?

Anyway, I do not have your hardware, but it does read strange to me to switch a control ON, and then put its settings to 0% playback.

I haven’t tried the snapshots yet because I dont know my kernal or smp version.

smp version ??? ehh …?? Please explain. I’m puzzled here about the price of tea in China. :slight_smile:

Your kernel version you can tell by typing:
uname -a

Here is an excerpt from the link you gave me for the snapshots:
Also it said the snapshots are for newer hardware my soundblaster is seven years old.


You should send 6 zypper commands to update your alsa (they are given below).

To send the zypper commands below, first open an xterm/konsole, and type “su” (no quotes) to obtain root permissions. Enter the root password when prompted. Then send the 6 zypper commands (in two groups of 3) given below that are specific to your openSUSE kernel version (and your SMP version). The three commands given in each case will:

* install a repository for alsa
* update your alsa
* remove the repository

ok, I’m bad. :slight_smile:

Thats a copy and paste error, dating back I think to openSUSE-10.2.

wiki updated.

Please check again. :slight_smile:

What about this?


Your audio has a problem that requires that you update your alsa version.


The cause is your hardware is too new for the version of alsa that comes with your openSUSE version

My hardware is old. Does this matter?

It should not. Sometimes old hardware requires special firmware and alsa-firmware handles that. And I see you have alsa-firmware installed.

Linux is usually pretty good when it comes to handling old hardware.