No sound from Microphone in OpenSuse 11.2

Hello

I have a problem recording sound with my Microphone in my current Opensuse 11.2(KDE) installation.

I tried installing Ubuntu on another partition, and it works there, so the hardware is not the problem.

I fiddled around with almost everything in kmix and alsamix, including the Mic Select, but nothing gets in arecord or krecord.

Here is my output from alsa-info.sh

Does it look right to you?

Make sure the channel is enabled and volume is not muted,

To the best of my knowledge I’ve done that :\

Do these mixer-settings look correct?

http://i47.tinypic.com/33vyqtk.png

http://i47.tinypic.com/bj5tfb.png

It looks OK
Maybe @oldcpu will have some ideas

No they do not look to be what I would apply.

Try switching on the mic boost.

Please can you also provide more information?

… what command are you using in arecord? For a test of mic functionality I recommend this web page for guidance Microphone - openSUSE and this command from a terminal for testing:

 arecord -vv -fdat foo.wav

Please provide the information recommended to be provided per our multimedia stickie: Welcome to multimedia sub-area - openSUSE Forums which is:

please post in this “multimedia” sub-forum, providing in your post the following information:

  • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
    SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script /usr/sbin/alsa-info.sh and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL. Just the URL. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.1 or earlier, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/sound #and post output here
  • for openSUSE-11.2 or later, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

The explanation to the checkbox above Mic Boost in kmix says “silent”, so I suppose that by not checking it, it is on?

I’ve tried both.

… what command are you using in arecord?

I was using arecord -d 10 filename.wav

But I don’t get anything in the file with arecord -vv -fdat foo.wav either.

Please provide the information recommended to be provided per our multimedia stickie:

Sorry, I didn’t spot that subforum.
The alsa-info output is in my first post. Here are the rest.

linux-71c0:/home/lars_pedersen # rpm -qa '*alsa*'
alsa-oss-1.0.17-25.2.i586
alsa-firmware-1.0.20-3.2.noarch
alsa-utils-1.0.21-3.1.i586
alsa-1.0.21-3.2.i586
linux-71c0:/home/lars_pedersen # rpm -qa '*pulse*'
libxine1-pulse-1.1.17-1.pm.31.3.i586
libpulse0-0.9.21-1.1.1.i586
linux-71c0:/home/lars_pedersen # rpm -q libasound2
libasound2-1.0.21-3.2.i586
lars_pedersen@linux-71c0:~> uname -a
Linux linux-71c0 2.6.31.12-0.1-default #1 SMP 2010-01-27 08:20:11 +0100 i686 athlon i386 GNU/Linux
lars_pedersen@linux-71c0:~> cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-intel8x0
# H0_h.e7_dZqa13l1:nForce3 250Gb AC'97 Audio Controller
alias snd-card-0 snd-intel8x0

Is this an internal or an external mic?

!!Amixer output
!!-------------
!!-------Mixer controls for card 0 [CK8S]
Mixer name : ‘Realtek ALC850 rev 0’
Simple mixer control ‘Line’,0
Front Left: Playback 24 [77%] [1.50dB] [on] Capture [off]
Front Right: Playback 24 [77%] [1.50dB] [on] Capture [off]
Simple mixer control ‘Capture’,0
Front Left: Capture 0 [0%] [0.00dB][off]
Front Right: Capture 0 [0%] [0.00dB] [off]
Simple mixer control ‘Mix’,0
Front Left: Capture [off]
Front Right: Capture [off]
Simple mixer control ‘Mix Mono’,0
Front Left: Capture [off]
Front Right: Capture [off]

IMHO you should have that capture ON.

Note you can add more channels to kmix to give more controls.

Problem solved. Thanks. :slight_smile:
Changing this one to 2ch solved it.

Simple mixer control 'Channel Mode',0
  Capabilities: enum
  Items: '2ch' '4ch' '6ch' '8ch'
  Item0: '6ch'

Congratulations on solving this and thank you for sharing your solution.