No Sound From HDMI with OpenSuse 12.3

Hi All,
I’m fairly new to the Linux world and so far really like OpenSuse. I have a monitor that use HDMI connection. I installed OpenSuse 12.3 in VirtualBox as a Guest on a Windows host and the sound works fine. But what I really like is to use OpenSuse more as a my main host, so I installed OpenSuse 12.3. I am not able to hear sounds coming from my monitor via HDMI. But I do hear the sound coming from my motherboard, but I rather have the sound coming from the HDMI cable. So it appears that there is a configuration or some sort of file not getting populated from my video HDMI card - I think. I’m not able to find a resolution. I did run a diagnostic and hope some one from the community can help me pinpoint the issue to resolve it. Here is the link to the output of the diagnostic. Any help is appreciated.

From that I note two sound devices are recognized:

!!Soundcards recognised by ALSA

 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfbff4000 irq 16
** 1 [NVidia         ]: HDA-Intel - HDA NVidia**
                      HDA NVidia at 0xfe87c000 irq 19

!!PCI Soundcards installed in the system

00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA)
**01:00.1 Audio device: NVIDIA Corporation GF106 High Definition Audio Controller (rev a1)**

Sound device-1 appears to be your HDMI device (associated with your nVidia card).

and I note your HDMI device is clearly recognized:

!!Aplay/Arecord output


**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: VT1708S Analog [VT1708S Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: VT1708S Digital [VT1708S Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 2: VT1708S HP [VT1708S HP]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]**
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]**
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]**
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]**
  Subdevices: 1/1
  Subdevice #0: subdevice #0

ie hw:1,3 ; hw:1,7 ; hw:1,8 and hw:1,9 are all HDMI devices.

I also note this in the dmesg:

    7.333218] ALSA hda_intel.c:2713 0000:01:00.1: Handle VGA-switcheroo audio client
    7.338932] ALSA hda_intel.c:1642 Enable delay in RIRB handling
    7.980796] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card1/input14
    7.980919] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card1/input15
    7.980977] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card1/input16
    7.981033] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card1/input17

I did not expect to see VGA-switcheroo audio client. … I’m not sure what that means … Does this PC have hybrid graphics ?

Please, can you advise what video driver you are using ? That ‘may’ be a factor in this audio problem. You may be able to provide that by sending the command:

/sbin/lspci -nnk | grep -A2 VGA

Having asked for that information, it may not be necessary as it is possible you can get this working using pulse audio volume control. Please install the application ‘pavucontrol’ and then use that application to try and tune the output of your PC’s audio to use the HDMI. Please look at my pulse audio blog/guide here:

… while I don’t have an HDMI example there (because I don’t have an HDMI setup) it is quite possible you will observe the HDMI options in your pavucontrol configuration menu. Note that of the 4 HDMI audio devices ( hw:1,3 ; hw:1,7 ; hw:1,8 and hw:1,9 ) typically only one of them will work, and you will need to determine which one is the functional one.

I forgot to mention …

WELCOME to openSUSE and welcome to our forum ! :slight_smile:

In addition the great and direct help by oldcpu, my I offer up some general help in the forum of a blog over the usage of PulseAudio. Have a look see here: PulseAudio and Selecting the Proper Sound Card Configuration - Blogs - openSUSE Forums

And may I also provide a welcome to you in the openSUSE forums! Just let us know if we can be of any help to you.

Thank You for using openSUSE,

oldcpu & jdmcdaniel3,
Thank you both for your suggestions. I used the Pulseaudio apps to configure and I tried all 4 HDMI Hardware that are listed and I still do not hear sounds coming from my HDMI. While doing this I was streaming internet radio and I do see the bar moving for the sound coming from the built-in sound card. Any other suggestions or logs I need to setup to look at this issue ? And thank you both for welcoming me to the OpenSuse community.

The ‘Pulseaudio apps’ you refer to - is that ‘pavucontrol’ ?

Please, can you type the following command in a konsole/terminal, and then copy and paste the output into your reply to this post:

/sbin/lspci -nnk | grep -A2 VGA

This should tell us a bit about your graphics setup and the graphic driver. Why ask about graphics when your problem is HDMI sound ? The answer is because in GNU/Linux it is because the graphic driver is integrally involved in HDMI sound, interfacing to the audio driver.

oldcpu & jdmcdaniel3,
I followed both of yours blogs and I finally got it working. Thanks to you both very much for the prompt reply. Now I get to play around with OpenSuse. Any virtualization programs you both recommend?

Happy to hear of your success. My suggestions for a VM is to use VirtualBox. I normally download and install VirtualBox Directly from Oracle. Have a look at the Article on the subject here:

Read the whole thing before you do anything else. For links on 4.2.18, look here:

And in the same message thread, I show examples of loading the VBOX files:

Read, read, and read some more before you then decide to install the application. When using a VM, you are sharing your memory, make sure you do not spread yourself too thin for the PC and the VM to work.

All questions about using a VM should be made here: Virtualization

Good Luck and thank you for using openSUSE,

I am having the same problem, can somebody please tell me HOW I get hdmi audio working!? I have read several different posts and none of them help me. And don’t tell me to got KDE’s control center > Multimedia. I have tried that several times and it DOES NOT WORK! I have tried deleting the pulse config files in my ‘home’ folder, and it DID NOTING! But analog audio works no problem, when I try to change to hdmi audio with KDE’s control center, I hear NOTING! My video card is supported, and I am using NVIDIA’s driver NOT the open source one. My info from various command-line commands is the same as the other posts about this same issue. And can any reply’s to this post be in plain simple English (step by step), my PC’s spec’s are as follows:

Quid Core Intel CPU
Intel motherboard/Intel onboard Sound (Analog)
NVIDIA Video card (with NVIDIA’s driver installed/mini hdmi port)
openSUSE 12.3 (with KDE 4)

PS. If the openSUSE developers are reading this; If you want people to use openSUSE, this should NOT be an issue anymore as, hdmi has been around for LONG ENOUGH, FIX IT!

Did you change the order in Yast?? Did you try using pavulcontrol to select output channels??

12.3 was released on Wednesday, March 13th 2013. It’s now 2015. Anyway the openSUSE developers have no control over the folks at nVidia.

My experience is the info from running the command line script is rarely the same. Please, can you in a konsole or xterm, as a regular user, send the command:


do not update if asked to update, … select the SHARE/UPLOAD option, and let the script run to completion. When the script is complete, it will put in the konsole/xterm a web address where your PC’s audio config has been uploaded. Please post here that web address/url. After looking at that we may have a recommendation.

So your new to this stuff – probably had one of those new-fangled keyboards and decimal money.
Paper tape and sellotape (aka scotch tape), bloody fingers from wire-wrap posts and solder burns; that was the future!

Can you please explain what you mean by ‘change the order in yast’? Do you mean in the yast ‘sound’ module and can you please be CLEAR!? And just to give some more info while I’m here:

Linux kernel ver: 3.7.10-1.16-desktop (x86_64)
NVIDIA driver ver: 319.32
Phonon ver: 4.6.0-7.4.1
Phonon GStreamer backend ver: 4.6.2
KDE ver: 4.10.5 “release 1”
ALSA ver: 1.0.26-7.5.1

PS. I do not have internet at home, so therefore I cannot upgrade the system. And is that what I need to do or do I need to move to a different distro!?

You can set which sound device is default in yast this changes the order in the list.

Without the output of the diagnostic script, it is VERY difficult to do anything more than speculate. Please, even with no internet, can you run the diagnostic script in a konsole or xterm as a regular user. This time save the output locally by using the “no-upload” argument:

/usr/sbin/ --no-upload

and note when the script runs it will say something like:

Your ALSA information is in

Copy the text file “alsa-info.txt.someletters” to a USB stick, take that USB stick to a computer that does have internet, and then open the file in that internet accessible computer, copy the text, and paste it to and click on ‘create’ on that site. It will give you a web address where that information is now located.

Then post here the URL where the information is located, so that we can then review it and attempt to assess some more detail on your computers audio setup.

I did try changing the order in yast and while it played the test sound though hdmi, it still will not play sound with kaffeine. I also tried installing pavcontrol and that did nothing. I will try the alsa script tonight and paste the results to the URL above. I also tried Ubuntu 12.04 LTS (I downloaded in 2013/at least a couple of years ago anyway) and it played sound though hdmi no problems, without me needing to do anything! I don’t know what is going on at opensuse but nearly every time I download a new version of it, there almost anyways seems to be problems with KDE. I would have thought that if most opensuse users use KDE, it would be better supported. Can the developers of opensuse please do a better job in making sure it works (all of it)! Like stop releasing it when it is NOT ready to be released. As KDE4 was NOT ready to be released as soon as it was! As this detracts from a very reliable operating system (Linux, that is) and will turn people off of wanting to use it. Thank you for your help though, as I do appreciate it, please don’t misunderstand me, thank you again. I will once again paste the results of the alsa script, so that hopefully I can finally hear SOMETHING from the hdmi.

Have you added the codecs. As default openSUSE has no proprietary stuff installed you have to get the codecs from packman. Note the open in the name. All default installs are 100% open source.

pavulcontrol does nothing itself you must run it to adjust the sound sources and sinks volume and other things

Part of the problem is we can not reproduce your problem.

I am not a developer but I do try to help users with their sound. Sound with openSUSE almost always “just works” for me.

Also, if one has no internet, a LOT depends on the timing/kernel version one selects. I have read of users (with no internet) who complained Ubuntu never worked for them for sound. Of course with no Internet they could not easily apply the Ubuntu kernel updates that fixed their sound. But for their hardware they were lucky with openSUSE, and on openSUSE sound ‘just worked’.

The same could be true for you and your hardware and kernel version wrt different GNU/Linux distros.

Frankly, GNU/Linux is NOT the sort of OS that one should run without internet access for updates. This is pretty much true for every GNU/Linux distribution - bar none.

Once again ? Apologies - but I can not find the first paste output.

That’s because I had not uploaded it yet, but now I have, URL:

gogalthorp](, I can play avi, mpeg, etc with the ANALOG sound! So YES I have installed the mpeg (among others) codecs!