No sound for 12.2

I’ve spent hours and hours and hours trying to determine why I cannot use my microphone. In the process of loading various drivers recommended here in the forums, somewhere along the way, I have now clobbered my sound. So now I have neither my mic nor any sound. Actually, it is possible I have the mic, but I cannot hear sound, so who knows. In the system settings -> multimedia -> phonon I am able to see the mic sound level, so I know that the driver is picking up my voice before tossing the data on the floor.

It just should not be this hard. The mic ought to have worked when I installed. How do I chase down this mess? Thank you!!

See also:

but I’ve learned not to follow up my own posts until I have an answer. So a new thread with a new emphasis, but same basic problem: sound is FUBARed.

Deleting and re-adding the sound device now has it working for the test sound within YaST. Applications that use sound still do not see it. Sound worked in 12.1. What happened?

– rebooting resolved the sound output issue.
The mic got resolved by figuring out that only alsamixer could turn on the mic, not kmix,
and that you have to right scroll past the last column to get the “extra” columns wherein the
mic volume level is shown to default to off. About six hours shot to heck. Very Clever.

Glad you got it working!

I found that I had to revert to alsa on all my machines in order to get the speakers working (different issue) but also learned that with Pavucontrol utility for pulse, you can toggle and change the levels on those channels as well.