No sound at Toshiba laptop

need help :-).
I’ve recently bought a new Toshiba Satellite A210 laptop. Installed Ubuntu first, but wasn’t able to make wi-fi working and had some more problems, so changed to openSuSE. Everything seems to be working all-right, except for sound. Amarok seems to be playing correctly, but there’s no sound coming - from the integrated reproboxes as well as from headphones. Other players (Kaffeine, video on youtube…) don’t play too. I’ve tried anything I could get in this forum, but nothing seems to help. I have installed the newest ALSA driver, but it didn’t help.

The sound card is SBx00 Azalia.

Yast says, there are two cards:
HDA ATI SB and SBx00 Azalia.

The first is with Index 0, the other cannot be configured due to some error (“Module for kernel ‘snd-hda-intel’ with sound promotion cannot be opened. This may be caused by wrong parametres of the module, including wrong IO or IRQ parametres”)

alsaconf is pretending that everything is all-right and working.

Here’s the /etc/modprobe.d/sound:

options snd-hda-intel enable=1 index=0

uniq.unknown_key:HDA ATI SB

alias snd-card-0 snd-hda-intel

Here is some more info about the card etc.

general pastebin - root - post number 1061170

Thanks for any possible advice!

Thanks, from the above I see:
Toshiba - A210 laptop, openSUSE 10.3 (X86-64), Kernel release is Alsa Driver version = 1.0.14, Alsa Library version = 1.0.14a, Alsa utilities version = 1.0.14. HDA-Intel - HDA ATI SB and Codec: Generic 11c1 Si3054.

First, a superior sound test is to copy and paste this into a konsole, making note of any errors:
speaker-test -c2 -Ddefault -l5 -twav

I also note this on your mixer:

Simple mixer control ‘Off-hook’,0

Capabilities: pswitch pswitch-joined

Playback channels: Mono

Mono: Playback [off]

Hence second, in your mixer, did you try change that playback to ON ?

Third, did you try installing “alsa-firmware”? After doing so, reboot and test your sound.

Now, assuming none of the above helps, a search on si3054 yields this (with updates clear in 1.0.15 and 1.0.16 of alsa):
Search results for si3054 - AlsaProject

Hence it appears likely an update to alsa 1.0.16 will help. You can find guidance for that here:
Alsa-update - openSUSE
in which case, the zypper commands you specifically need to send are (from an xterm/konsole with root permissions) in the exact sequence noted below:

zypper ar multimedia
zypper install alsa alsa-utils alsa-tools alsa-firmware libasound2
zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-default
zypper rr multimedia

after that, reboot and test your sound, … check your mixer, …

If your sound still does not work, and if your /etc/modprobe.d/sound file remains the same as noted above, then try change this file to:

options snd-hda-intel enable=1 index=0 model=toshiba
# uniq.unknown_key:HDA ATI SB
alias snd-card-0 snd-hda-intel 

and then restart your alsa with “rcalsasound restart” and test your sound, being careful to check your mixer. Thats a wild guess, as that code is typical for an ALC268, ALC861/660, & AD1981. But I seen no reference of that being used in an HDA ATI SB.

And if the above all fails, please run the diagnostic scripts again, and post the URL providing your updated sound configuration, and also provide the output of:
rpm -qa | grep alsa
rpm -q libasound2
rpm -qa | grep esound
cat /etc/modprobe.d/sound

I’m asking for esound, as I have read of users with your laptop (or similar laptops) selecting ESD in their desktop (without realizing that) and being unable to get it to work because they forgot to install esound (or simply forgot to change away from that sound daemon).

Thanks a lot, it’s solved now. I’ve already tried most of you suggested before, with no success. What helped was installing original Realtek codec. I tried it before, but Amarok always said that “xine cannot find a sound device” . For some reason it helped now, so the sound is OK now. God knows how does it really work… However thanks for your concern!
It has a little drawback though, the system is constantly freezing since then :slight_smile: . After a few minutes of work (approx 10) it freezes, sound keeps repeating one second and after a dozen seconds the screen goes blank, sound mutes and I cannot do anything but hold the power button to switch the computer off. Is there any log file, where I could find what really happened?

I have absolute NO IDEA as to what you mean by this, hence absolutely no idea as to what you did.

I gave you a sound test, and you did not tell me if it worked, or anything before you “installed an original realtek codec” (what ever that means).

Note I NEVER recommend installing realtek drivers. I believe that all realtek have done for Linux is taken an opensource alsa driver and done their own hacks to it. One should be able to get an alsa driver working with resorting to realtek hacks.

You can take a look at the various log files under /var/log

I can no longer help you here, as you have done something (some sort of unknown ‘original realtek codec install’) that I neither recommended, nor understand.

Good luck with your efforts.