No sound at all - onboard ASRock K7S8X motherboard

Hi, I’m getting no sound no matter what I seem to try.
My motherboard is an ASRock K7S8X and I’m using the onboard sound output jacks.
any ideas?

Try working your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE

To test if your sound is working, I recommend you try copy and pasting the following into a gnome-terminal or a kde konsole:speaker-test -Dplug:front -c2 -l5 -twavyou should hear a lady’s voice saying “front-left”, “front-right” five times. Note Linux is case sensitive.

If that does not work, try a shorter form version:speaker-test -c2 -l5 -twavIf you hear sound (ie if you hear the lady’s voice), then please post here, let us know this fact, and explain more as to what your sound problem might be.

If that does not work, and if you do not hear the lady’s voice, then we need more information to help solve your problem. To provide more information, with your PC connected to the internet copy and paste the following into a gnome-terminal or konsole:

wget -O && bash 

When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following into a gnome-terminal or konsole and post the output here.rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Please, in addition to all the above, advise if you are using KDE3, KDE4, or Gnome.

Once I have that information, I believe I may be able to provide helpful recommendation(s).

I see this is your first post here.

Before I forget, WELCOME to openSUSE Linux, and WELCOME to our forum.

celticJedi wrote:
> Hi, I’m getting no sound no matter what I seem to try.
> My motherboard is an ASRock K7S8X and I’m using the onboard sound
> output jacks.
> any ideas?

Just to start to put you at ease: the sound from my ASRock mb is great.

I see this is your first post here–welcome.

I assume that maybe you just installed SUSE for the first time?

Did sound work on that machine before you installed SUSE? If you can dual boot,
does it still work in another OS?

What version of SUSE are you using? What display manager (KDE3, KDE4, Gnome,
other–name it)?

hi and thanks for the welcome.
I’m running Gnome on SUSE 11.0
It’s a new install but the sound was working in windows and Ubuntu previously.
In the terminal I tried

speaker-test -Dplug:front -c2 -l5 -twav

and got

speaker-test 1.0.16

speaker-test: invalid option -- '1'
Unknown option '?'
kev@linux-2ip0:~> speaker-test -c2 -a5- twav

I then tried

speaker-test -c2 -l5 -twav

and got

speaker-test 1.0.16

speaker-test: invalid option -- 'a'

Please be careful how you type. You likely put a space in the wrong place.

Copy and paste it !

speaker-test -c2 -l5 -twav

looks like i mistyped. I got an output in the terminal but no sound

speaker-test 1.0.16

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 128 to 1048576
Period size range from 64 to 262144
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
 0 - Front Left
 1 - Front Right
Time per period = 3.612304
 0 - Front Left
 1 - Front Right
Time per period = 3.572352
 0 - Front Left
 1 - Front Right
Time per period = 3.906517
 0 - Front Left
 1 - Front Right
Time per period = 3.259420
 0 - Front Left
 1 - Front Right
Time per period = 3.904381

ok … and ??? … the output of the rest that I asked about?

ah missed that bit.

wget -O && bash

gives the following url


rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound


kev@linux-2ip0:~> rpm -qa | grep alsa
kev@linux-2ip0:~> rpm -qa | grep pulse
kev@linux-2ip0:~> rpm -q libasound2
kev@linux-2ip0:~> uname -a
Linux linux-2ip0 #1 SMP 2008-10-21 16:30:26 +0200 i686 athlon i386 GNU/Linux
kev@linux-2ip0:~> cat /etc/modprobe.d/sound

options snd slots=snd-intel8x0
# 1sCg.t4EpD1HCpmC:AC'97 Sound Controller
alias snd-card-0 snd-intel8x0


oh and I’m using Gnome on SUSE 11.0

I note the script, for your hardware audio codec, states:

 0 [SI7012         ]: ICH - SiS SI7012
                      SiS SI7012 with CMI9761B at irq 18 

So I researched that and noted Matrix:Module-intel8x0 - AlsaProject that your alsa driver should use a snd-intel8x0 module for the sound. That is consistent with the /etc/modprobe.d/sound file you posted.

I also searched for updates for CMI9761 on the alsa site, and found no recent updates.

I then looked inside the ALSA-Configuration.txt file to see if it provided any guidance for the SI7102. … It had this:

Module snd-intel8x0

    Module for AC'97 motherboards from Intel and compatibles.
			* Intel i810/810E, i815, i820, i830, i84x, MX440
				ICH5, ICH6, ICH7, ESB2
			* SiS 7012 (SiS 735)
			* NVidia NForce, NForce2, NForce3, MCP04, CK804
				 CK8, CK8S, MCP501
			* AMD AMD768, AMD8111
			* ALi m5455

    ac97_clock	  - AC'97 codec clock base (0 = auto-detect)
    ac97_quirk    - AC'97 workaround for strange hardware
		    See "AC97 Quirk Option" section below.
    buggy_irq     - Enable workaround for buggy interrupts on some
                    motherboards (default yes on nForce chips,
		    otherwise off)
    buggy_semaphore - Enable workaround for hardwares with buggy
		    semaphores (e.g. on some ASUS laptops)
		    (default off)
    spdif_aclink  - Use S/PDIF over AC-link instead of direct connection
		    from the controller chip
		    (0 = off, 1 = on, -1 = default)

    This module supports one chip and autoprobe.

    Note: the latest driver supports auto-detection of chip clock.
    if you still encounter too fast playback, specify the clock
    explicitly via the module option "ac97_clock=41194".

    Joystick/MIDI ports are not supported by this driver.  If your
    motherboard has these devices, use the ns558 or snd-mpu401
    modules, respectively.

    The power-management is supported. 

I noted it stated “See “AC97 Quirk Option” section below” so I looked at that:

AC97 Quirk Option

The ac97_quirk option is used to enable/override the workaround for
specific devices on drivers for on-board AC'97 controllers like
snd-intel8x0.  Some hardware have swapped output pins between Master
and Headphone, or Surround (thanks to confusion of AC'97
specifications from version to version :-)

The driver provides the auto-detection of known problematic devices,
but some might be unknown or wrongly detected.  In such a case, pass
the proper value with this option.

The following strings are accepted:
    - default	Don't override the default setting
    - none	Disable the quirk
    - hp_only	Bind Master and Headphone controls as a single control
    - swap_hp	Swap headphone and master controls
    - swap_surround  Swap master and surround controls
    - ad_sharing  For AD1985, turn on OMS bit and use headphone
    - alc_jack	For ALC65x, turn on the jack sense mode
    - inv_eapd	Inverted EAPD implementation
    - mute_led	Bind EAPD bit for turning on/off mute LED

For backward compatibility, the corresponding integer value -1, 0,
... are  accepted, too.

For example, if "Master" volume control has no effect on your device
but only "Headphone" does, pass ac97_quirk=hp_only module option 

Thats a lot to digest, but it suggests to me:
a. Since nothing obvious strikes me, that you really need to double check your mixer, and
b. its possible some of your mixer controls are swapped due to that quirk. …

So looking at your mixer I note:

Simple mixer control 'External Amplifier',0
  Mono: Playback [on] 

Try turning your External Amp OFF and test your sound.

Also, if that doesn’t work, I note:

Simple mixer control 'Surround',0
  Front Left: Playback [off]
  Front Right: Playback [off] 

You could turning surround sound ON.

Simple mixer control 'Center',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Mono: Playback 31 [100%] [0.00dB] [off] 

You could try turning ON your center surround …

Simple mixer control 'LFE',0
  Mono: Playback 7 [23%] -36.00dB] [on] 

23% ispretty low, you could try moving this up to 70%.

Simple mixer control 'IEC958',0
  Mono: Playback [on] ....... 
Simple mixer control 'IEC958 Capture Monitor',0
  Mono: Playback [off]
Simple mixer control 'IEC958 Capture Valid',0
  Mono: Playback [off]
Simple mixer control 'IEC958 Playback AC97-SPSA',0
  Mono: 0 [0%] 

You could try turning this digital audio ON and see if it works. If it doesn’t, switch it OFF.

Also, try that as user root. ie type “su” first in a gnome-terminal, and then try the speaker test. This is to check if you may have a permissions problems.

Also, if suggestions in the above posts did not work, install alsa-firmware, and reboot, and test your audio.

Before we go any further let me take the chance of insulting (and certainly not
meaning to) and ask:

Have you found the volume adjustment sliders and switches and read enough of the
documentation to fully understand exactly what the various “LEDs” are showing
you? That is, in some instances you can THINK you have turned the volume up, but
if you didn’t click on the red LED to turn it GREEN you didn’t allow anything to
actually flow to the speaker.

I do not know where those switches and sliders hide in GNOME. In KDE3 they are
found in kmix.

Ah, I have just learned that you may need to find the “GNOME Volume Control” and
instead of looking for red or green LEDs, look for speaker symbols with or
without a red X…

look in the lower left menu, or try holding down the Alt and pressing F2, then
type gnome-volume-control into the blank and press enter

good luck

thanks for all this help and sorry for sounding like a complete novice but where do I find my mixer controls?

I tried that but it still didn’t produce any sound. I’ve also run these commands whilst having the sound level meters on-screen, they showed no activity at all so I know that it’s not a problem with the speakers.

also done but still no sound

no insult taken - thanks for the suggestions and I’ve gone through what you’ve said with no result.

If using kde the program is called kmix. If using gnome I believe the program is called alsamixer.

I thought so, I’ve got AlsaMixerGUI but the only controls are for master and Capture volume leverls