No sound at all on openSUSE 12.2

I have the problem with sound on openSUSE 12.2 (kernel 3.4.28-2.20) since recently. The system is regularly updated from official repository+Pacman. A week or two ago, the problems with sound started, and currently the sound system is in a total mess. First I noticed that sound works just for less than a minute in Skype (I thought that Skype is to blame). After reboot the sound works in all applications just for short, and endless attempts to resolve the problem haven’t helped (the sound reappears only after reboot, sometimes after resume or after changing configuration). The problem is the same for all applications (Kaffeine, Skype, VLC player, Chrome…). I tried killing the pulseaudio, it restarts but nothing happens. I also tired to reinstalling all the pulseaudio libraries. I use Toshiba laptop with Intel and nVidia sound cards (both use snd_hda_intel module). I tried to change the primary card to from nVidia to Intel and back, but the sound appears just occasionally for a short time. I tried to configure Phonon, but behavior of the system is the same. I stress that everything have worked flawlessly for more than a year before the problems appeared. Any idea from where to start solving the problem?

Must Read This first:

Pulseaudio Basics for openSUSE with pavucontrol:

Check your Default Sound Card in YaST and make sure the one you use is Index 0 or the Default:

Make Sure your PulseAudio Profile for the card you do not use is Off:

Make Sure to select the Card Profile you do use that works:

Use This To Test Your Sound System:

S.T.A.R.T. - SuSE Terminal Audio Reporting Tool - Version 1.15:

Make Sure Your Multimedia is setup Properly:

Multimedia and Restricted Formats Installation Guide 12.2:

Test Your Multimedia to see if setup Properly:

MMCHECK - Version 2.45 - Check Your Multimedia in 16 Steps - Bash Script File:

Thank You,

Thanks for instructions. I selected internal audio as primary and switched off the profile for nVidia sound card. Currently, sound works fine, but I’ll test it more thoroughly today.

Sounds like you are going in the right direction. There is a lot of info in my previous post, please take time to look at it all.

Thank You,

Unfortunately, the problem with sound persists. I tried to use Skype, and the only thing that I heard was “Hello, welcome” when I connected to Skype Call Test. I ran the mmcheck script, and it discovered the files installed from VideoLAN:
libvlc5 -> VideoLAN Project (VideoLAN - VLC: Official site - Free multimedia solutions for all OS!)
libavutil52 -> VideoLAN Project (VideoLAN - VLC: Official site - Free multimedia solutions for all OS!)
vlc -> VideoLAN Project (VideoLAN - VLC: Official site - Free multimedia solutions for all OS!)
libdvdcss2 -> VideoLAN Project (VideoLAN - VLC: Official site - Free multimedia solutions for all OS!)
vlc-noX -> VideoLAN Project (VideoLAN - VLC: Official site - Free multimedia solutions for all OS!)
vlc-qt -> VideoLAN Project (VideoLAN - VLC: Official site - Free multimedia solutions for all OS!)
vlc-aout-pulse -> VideoLAN Project (VideoLAN - VLC: Official site - Free multimedia solutions for all OS!)
libvlccore5 -> VideoLAN Project (VideoLAN - VLC: Official site - Free multimedia solutions for all OS!)
vlc-gnome -> VideoLAN Project (VideoLAN - VLC: Official site - Free multimedia solutions for all OS!)

I have also noticed that some of packages were installe from openSUSE repository instead of Packman, and some are missing (such as MPlayer, since I don’t use it). No other errors were reported. Do I have to correct the repositories used to the suggested ones in the script?


First and foremost, we don’t post instructions here only to have you pick and chose what to follow and still claiming to have a problem you need help to fix. Fixing your multimedia makes sure all media file types will play. Skype may still be a sound setup issue. I suggest you take every action we suggest. If Skype does not work after most everything else does, consider starting a new message thread on using Skype. PulseAudio is our sound server now and you need to have it setup right, but there are additional tricks to enabling inputs for a mic and such. Playing audio online means you need to support the audio format properly. When Skype does not work, which part of your openSUSE system is at fault? Take the Multimedia Article to heart and make sure to pass (or have acceptable results) all tests in MMCHECK. Make sure to go through and install the suggested mixer for PulseAudio. Once you get sound in all parts of openSUSE and can play YouTube Videos and MP3 files correctly, then proceed to getting Skype to work.

Thank You,

I am sorry, maybe I didn’t explain clearly. I just mentioned Skype as an example. There is still no sound in any application, not just Skype. And what happens is the same in all applications: I can hear the sound (for example when playing mp3 file or watching youtube video) in the beginning, then it disappears after up to twenty seconds. After that, there is no sound at all either till I reboot, or sometimes it appears after changing configuration (I couldn’t determine the exact sequence of events which activates sound again). I have also tried to delete the sound cards and to configure them again.

In the meantime, I replaced the packages from wrong repositories, as suggested by the MMCHECK script (everything is as listed by the script). I confirm that the internal Intel sound card (which I always use) is set as primary, and its profile is enabled. nVidia sound card is secondary, and its profile is off. Unfortunately still no change in behaviour of the sound system.

So, once again, all the multimedia play sound, but just for a very short time. After that, nothing. dmesg and /var/log/messages show nothing suspicious to me.


Tell me everything about the “Primary Sound Card” (or chipset) and the computer it is installed in. Tell me about your speakers, are they amplified, and how they connect to the computer. For any screen captures, you can post them to SuSE Paste here: SUSE Paste, make sure to select image, then browse to image to upload, I normally upload png files and they must be <= 512 K in size. use Gwenview to shrink pictures down to an uploadable size if required. Set Delete After to Never. Then copy and post in the message here the Download Link in the picture online.

Thank You,

When this happens, does the sound stop abruptly, or does it fade out gradually ?

If it stops abruptly, what sort of checks have you done to ensure that one application using the sound device has not seized the sound device and is refusing to share the sound device with other applications ? Note this application (that may be seizing and refusing to share the sound device) could also be your desktop use of system sounds.

I assume you followed the advice in one of the links you were provided and advised to read, and installed the application ‘pavucontrol’.

I assume you did not disable nor inappropriately remove any alsa nor pulse audio applications.

When the sound works, what does the pavucontrol ‘playback’, ‘output devices’ and ‘configuration tab’ show ? (ensuring the filters set to ‘all streams’ (for playback) and ‘all output devices’ (for output devices) to provide better visibility into how it looks when the sound works.

Then when the sound stops, what does the pavucontrol ‘playback’, ‘output devices’ and ‘configuration tab’ show ? (ensuring the filters set to ‘all streams’ (for playback) and ‘all output devices’ (for output devices) to provide better visibility into how it looks when the sound stops.

If you think sharing the setup for those tabs in pavucontrol needs the assessment of others, then do a print screen of each pavucontrol tab setting, and then post the output here: Fast, Free Image Hosting - ImageBam Either post all 6 images or not at all. A partial print may omit important information.

Thanks to the question about the connection between the speakers and the computer, I tried to connect the headphones (what I do really rarely). I was
surprised that the headphones produce sound although there was no sound from the speakers.

So, I can now say that external sound output works correctly, and that there exists a problem with the speakers.

Regarding the question on how the sound stops, it stops abruptly, no fading out.

The details about my computer and behaviour of the pavucontrol:

Computer: Toshiba Satellite L750-1N3 laptop

Sound cards:
Primary - Intel Audio Device (HDA Intel PCH) - module snd_hda_intel
Secondary - nVidia Audio Device (HDA nVidia) - module snd_hda_intel

Speakers: Built-in laptop speakers - problematic, activate after changing configuration or reboot
Headphones: Working!

  • pavucontrol is installed
  • Input Devices tab: bar reacts to sound captured by internal mic
  • Playback tab (show all streams): bar doesn’t react when playing sound (I can hear the sound in the headphones, no sound from speakers)
  • Output Devices tab (show all streams): bar doesn’t react when playing sound (the same as previous), same both for Port Analog Speakers and for Port Analog Headphones
  • Configuration tab: GF108 High Definition Audio Controller Profile is Off, Internal Audio Profile is Analog Stereo Duplex, same for Analog Stereo Output

I have been using this laptop for 14 months, the only OS installed is openSUSE 12.2 (clean install of openSUSE 12.1, then upgraded to 12.2)+Restricted formats
installed from openSUSE community. I checked and corrected the multimedia packages according to the recommendations from MMCHECK yesterday. There were no problems with sound from speakers till a couple of weeks ago.

I hope that these details are useful.


SO if sound out the same stereo jack works with headphones and not for the external speakers, you do have a problem with the speaker side. Not sure what might be wrong, but like all things, it works great until it stops working, at a time of its own choosing. Good luck in finding this final problem.

Thank You,

Headphones and external speakers work OK (so the external output, which I usually don’t use, is OK), but internal speakers (which I use regularly) stop to work. I’ll boot some other live distro tomorrow to check how the sound card and internal speakers behave. Anyhow, thanks for trying to help me!

This reads like it could be a hardware problem to me. ie some sort of capacitance build up which after a short time frame inhibits the internal sound. I’ll be curious as to the results of your testing with a different distro. … I don’t suppose you also have a liveCD of an earlier openSUSE version where you noted this once worked ok (ie test booting to that) ?

Further to my own post, what I now do when travelling is carry a very light weight set of very small external speakers with me, that I plug in to my tablet, my smart phone, or my laptop, when I want audio. Their sound is superior to the sound of all my other portable devices. I use a set of the x-mini speakers. These are not proper vibation speakers, so their sound is NOT as good as the sound of full vibration speakers. BUT these are very small and significantly lighter than vibration speakers, and their sound IS better than that of the laptop. So they are highly portable and highly functional, and IMHO at a very light weight addition improve the sound output functionality of my portable computing devices.

I’ve just tested the sound on Ubuntu 10.04 live distro. The internal speakers worked flawlessly all the time. I had some older openSUSE live CDs, but I have to find them. Anyhow, this looks like the problem caused by the regular update from the last week or the week before, I remember that the kernel was updated in one of these updates and various multimedia libraries and applications (maybe some kernel module configuration as well) in other. Unfortunately, I don’t know any details about these updates.

Thanks for the link to these cute small speakers, I’ll try to find some just for case that this problem lasts longer. I hope that 12.3 will make it disappear :slight_smile:

You can always check to see what rpms were installed by typing in a konsole the command:

rpm -qa --last

now that will likely scroll by far too fast. So you could instead type:

rpm -qa --last | less

and use the UP and DOWN arrow (or Page-Up and Page-Down) to scroll up and down. And then press ‘Q’ to quit.

or one can redirect the text output to a file, and then open the file with a text editor, with something like:

rpm -qa --last > myrpms.txt

and open the file ‘myrpms.txt’ with a text editor, to see when various rpms were installed.

Thanks for instructions. I analyzed my Skype history file and concluded that the problematic update happened between Jan 31 (I had quite a long call, everything was working OK) and Feb 6 (I couldn’t use my computer for a scheduled meeting). During that period, four updates occurred. I tried to analyze the update log, and found that only these packages (as far as I know) were related to audio and multimedia in general (I included the previous update as well, since I rebooted the system a couple of times, and the older update could affect its behaviour as well):
phonon-devel-4.6.0-3.2.2 Wed 06 Feb 2013 11:41:33 PM CET
libphonon4-4.6.0-3.2.2 Wed 06 Feb 2013 11:41:32 PM CET
libpulse-devel-1.1-6.4.1 Wed 06 Feb 2013 11:21:34 PM CET
alsa-plugins-pulse-1.0.25-3.4.1 Wed 06 Feb 2013 11:21:32 PM CET
pulseaudio-1.1-6.4.1 Wed 06 Feb 2013 11:21:30 PM CET
libpulse0-1.1-6.4.1 Wed 06 Feb 2013 11:21:29 PM CET
libopus0-1.0.2-2.1 Wed 06 Feb 2013 03:43:34 PM CET
paprefs-0.9.10-5.1.2 Wed 06 Feb 2013 03:36:01 PM CET
xbmc-12.0-2.1 Tue 05 Feb 2013 03:04:34 PM CET
libvpx1-1.2.0-7.1 Thu 31 Jan 2013 11:11:01 PM CET
libaudio2-1.9.2-2.35 Thu 24 Jan 2013 07:33:44 PM CET

I must admit that I am not quite sure how to proceed further. One way would be to downgrade these packages, but I hesitate to do that.


That is an interestnig approach. If you downgrade, and find it works , then it would increase the probability that one of those packages is the cause.

Another approach is to create a new user account, and login as that new user. And check if that new user has the same problem. The idea there is to attempt to remove the possibility of a misconfiguration at user level.

samimk, did you ever figure this out? I’ve got the same problem. I’ve been using 12.2 for about 18 months and have had no problems with the sound. About 2 weeks ago, I installed the Chrome browser and started having problems. I’ve unistalled / rolled back to pre Chrome, but still have the problem… the sound works after reboot or when ‘messing’ around with sound settings for a while. But just abruptly quits.

oldcpu, I’m having the same problem as samimk. I’ve followed the instructions in this post, but still have no solution(s). I’m very curious about your suggestion to check to see if an application is using and seizing the sound device. Can you please explain how I can do this, or post a link to instructions on how to do this? Thank you very much!

( I would like to know how to do this to investigate my problem, but I also think it would just be cool to see what resources apps are using! :))