No sound - asus x5dij

I can not get the sound to work on my 64-bit laptop.

I have tried the self tests:
speaker-test -Dplug:front -c2 -l5 -twav
speaker-test -c2 -l5 -twav
aplay -vv somefile.wav
found in
No sound running OS 11.1 x64 - openSUSE Forums

My alsa info can be found at:

Additional info:
freefox@linux-q0rr:~> rpm -qa | grep alsa

freefox@linux-q0rr:~> rpm -qa | grep pulse

freefox@linux-q0rr:~> rpm -q libasound2

freefox@linux-q0rr:~> uname -a
Linux linux-q0rr #1 SMP 2009-08-15 17:53:59 +0200 x86_64 x86_64 x86_64 GNU/Linux

freefox@linux-q0rr:~> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.0BStUO5UoL0:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

All ideas, or help is appreciated.

Thankyou for that output. The configuration from the various commands you run look nominal and correct.

In the diagnositic script, I note confirmation of a bit-bit openSUSE-11.1 on the latest SuSE-GmbH packaged default kernel on your Asus x5JIJ with a VT1708S hardware audio codec.

The first thing I note is your mixer settings (either kmix in kde or alsamixer in gnome) are blocking your sound. You may have more problems than those, but you first must clear up those problems.

!!Amixer output
!!-------Mixer controls for card 0 [Intel]
Card hw:0 ‘Intel’/‘HDA Intel at 0xfdef4000 irq 22’
Mixer name : ‘VIA VIA VT1708S’
Simple mixer control ‘Master Front’,0
Front Left: Playback 0 [0%] -34.50dB] [on]
Front Right: Playback 0 [0%] -34.50dB] [on]
I recommend you move PC volume up to 95% while testing. You can lower the volume level later.

But having typed that, I then when to the alsa web site and did a search on your PC’s VT1708S hardware audio codec:
Search results for VT1708S - AlsaProject

I note some important updates in 1.0.18 of alsa and 1.0.21 of alsa, where your alsa version is a 1.0.17/1.0.18 mix.

Hence if moving the volume settings up higher for the Master volume control do not help, you should then try updating your alsa version. You can do that for your kernel version by following the guidance here to update your alsa user space: Alsa-update - openSUSE

Note one must send six zypper commands from a terminal with root permissions with your PC connected to the internet. The six commands to send in sequence in your case are:

zypper ar multimedia
zypper install alsa alsa-docs libasound2
zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-default
zypper rr multimedia

then restart your PC to unload the old alsa kernel modules and load the new alsa kernel module and then test your sound. Be certain to move up your mixer levels.

Now if the user space updates do not work, try the daily snapshot updates as documented here: Alsa-update-snapshot - openSUSE

In your case that means sending the following six zypper commands:

zypper ar multimedia
zypper install alsa alsa-utils alsa-tools alsa-firmware alsa-oss alsa-plugins alsa-plugins-pulse libasound2
zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-default
zypper rr multimedia

Now its possible you will be told on the 5th command that the app is already installed. Thats ok, send the command anyway, and send the 6th command. Again, restart your PC, test your sound (being certain to move your mixer controls up to a high 95% setting).

Good luck ! Please let us know how it works out.

I try to find where to adjust the volume for “Simple mixer control ‘Master Front’,0”
But I just can’t find it.

I have verified that Control center->system->sound->entities are set to alsa.
After that I have adjusten one volume control at a time and compared the output from the alsa-info.txt.files to determine what is changed. But nothing changes the ‘Master Front’ volume.

Volume control on panel:
Simple mixer control ‘Front’,0

Dubble clicking gives more controls in the window named ‘Volume control’:
I have choosen ‘show all’ in the drop down list.

Tab ‘uppspelning’ (‘play’ in direct translation from swedish)
System sound, Mono - changes has no affect on alsa-info.txt output.

Tab ‘utgångsenheter’ (‘output units’)
HDA Intel - VT1708S Analog - Simple mixer control ‘PCM’,0

Tab ‘ingångsenheter’ (‘input units’)
HDA Intel - VT1708S Analog - Simple mixer control ‘Capture’,0
Monitor of HDA Intel - VT1708S Analog - changes has no affect on alsa-info.txt output.

Tab ‘inspelning’ (‘recording’)
Shows no entities to control. Nothing.

I uploaded the latest test if it can be of any use.

Please give me a hint.

… I would , if you would give me a hint first. :slight_smile: … What desktop are you using? KDE3 ? KDE4 ? Gnome ? XFCE ? LXDE ? FVWM ? Enlightenment ?

That makes a difference.

KDE and Gnome are more popular and if you are using KDE4 note that you can add additional controls via a channel menu item in the kmix.

If you are using gnome, note that you can install alsamixergui to obtain gui control over your alsamixer.

But it would be useful it you let us know what desktop software , so that I don’t have to spend a lot of time trying to second guess a problem for each different desktop, especially given their are limits to my experience and I do not know each desktop as well as others (and hence I won’t reply/waste-your-time giving answers to the wrong desktop).

Sorry, I’m using Gnome.

And I must confess that I have not upgraded alsa software with zypper as you suggested.
I have check with yast, online update, that there is nothing new there.
Can I use yast to get the latest from alsa?
I’m afraid that using zypper will mess up for yast, or am I wrong about that?

OK, I am a KDE user and I do not know much about gnome.

Typically one uses the application “alsamixer” in gnome, for such controls. There is also a fancier gui for alsamixer, called “alsamixergui” that one can install. You can find it in the OSS directory (or on your installation DVD). Webpin is a good place to look for such apps: Webpin

[its a bit painful having to retype all of this, as links providing some of this information is in the stickie: NEWBIES - Suse-11.1 Pre-installation – PLEASE READ - openSUSE Forums plus google gives a wealth of information … but I have to assume you either did not see the stickie, or did not investigate all the links contained therein thoroughly - … which is an understandable problem with Linux … there is so much information , its hard to know where to go to start]

Note you can also control the mixer via direct amixer commands. There is guidance here: Amixer - ALSA wiki

So for example, to see what commands are available, you type:

  • scontrols #show all mixer simple controls
  • scontents #showcontents of all mixer simple controls (default command)
    and then once you know the command controls/conents, you can type:
    sset sID P # modifying as appropropriate to set contents for one mixer simple control.

Having typed that, I find amixer commands a pain, and I find it much easier to just use the mixer gui.

Now I have installed the suggested software, using yast.
There was a conflict about alsa-driver-kmp-default and the kernel-…something which choosed to ignore. Probably not a good thing to do.

alsamixergui shows two controls.

Master and Capture
But none of them have any affect on the Master Front volume!?
Master adjusts Simple mixer control ‘PCM’,0 and
Capture adjusts Simple mixer control ‘Capture’,0

Now I’m lost. Should I give it up, or should I go for the latest kernel too? Or what is the next step?

Now it works!
I’m not sure of what was wrong, but I looked over the installed packages ones more. I also made changes in the control-center -> sound and ensured that things looked correct, pointing out HDA Intel VT1708S Analog(ALSA). I choosed plain ALSA before because the tests in that window fails with the text "audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Kunde inte öppna ljudenheten för uppspelning. (that is: Could not open the sound unit for playback).

And a reboot. Thanks for your support.

Glad its working now. Your timing is good. I’m now on vacation, and would find it difficult to provide any good technical support given the limited internet connection I have now.

Hi folks,
I had exactly the same problem with my Asus :open_mouth:
The solution: update alsa! Suse 11.1 comes with alsa version 1.0.17/18 - you need to update to 1.0.20 or higher.
So download here: (Download - AlsaProject)
Unpack: tar -xjf alsa-driver-X.Y.Z.tar.bz2
Run: ./configure && make && make install
Restart alsa or easy reboot system and u may become happy :wink:

Custom compiling can be a pain for new users. The openSUSE packager for alsa, who is also an alsa developer, has created a number of repositories with rpms with the latest version of alsa, including daily snapshots that are even more cutting edge than the most recent version of alsa. To update to the latest alsa version, via an rpm as opposed to a custom compile, one can go here for guidance: Alsa-update - openSUSE