No sound, ALSA won't update - 12.1

Just built my new system with a GA-Z77X-UD5H, which uses Realtek ALC898. The audio works fine in Windows 7, but not at all in OpenSUSE 12.1 (both 64-bit). Followed the wiki. Realtek ALC898 appears to require ALSA 1.0.25, which I installed from Index of /repositories/multimedia:/libs/openSUSE_12.1. I’ve rebooted, but the change doesn’t look like it took:

zathras:~ # cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.24.
zathras:~ # rpm -qa ‘alsa
alsa-oss-32bit-1.0.25-37.2.x86_64
alsa-plugins-pulse-1.0.25-58.1.x86_64
alsa-oss-1.0.25-37.2.x86_64
alsa-plugins-32bit-1.0.25-58.1.x86_64
alsa-plugins-pulse-32bit-1.0.25-58.1.x86_64
alsa-1.0.25-115.1.x86_64
alsa-utils-1.0.25-61.1.x86_64
alsa-docs-1.0.25-115.1.noarch
alsa-firmware-1.0.25-26.1.noarch
alsa-plugins-1.0.25-58.1.x86_64
zathras:~ # rpm -qa ‘pulse
pulseaudio-module-zeroconf-1.1-1.2.x86_64
alsa-plugins-pulse-1.0.25-58.1.x86_64
pulseaudio-module-gconf-1.1-1.2.x86_64
pulseaudio-module-bluetooth-1.1-1.2.x86_64
libpulse-mainloop-glib0-1.1-1.2.x86_64
pulseaudio-module-lirc-1.1-1.2.x86_64
alsa-plugins-pulse-32bit-1.0.25-58.1.x86_64
pulseaudio-module-x11-1.1-1.2.x86_64
pulseaudio-module-jack-1.1-1.2.x86_64
libpulse0-1.1-1.2.x86_64
pulseaudio-utils-1.1-1.2.x86_64
pulseaudio-1.1-1.2.x86_64
libxine1-pulse-1.1.21-9.1.x86_64
libpulse0-32bit-1.1-1.2.x86_64
zathras:~ # rpm -q libasound2
libasound2-1.0.25-115.1.x86_64
zathras:~ # uname -a
Linux zathras 3.1.10-1.16-desktop #1 SMP PREEMPT Wed Jun 27 05:21:40 UTC 2012 (d016078) x86_64 x86_64 x86_64 GNU/Linux
zathras:~ # cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel

u1Nb.1Ev3xqQuarC:Intel Corporation

alias snd-card-0 snd-hda-intel

ALSA information is located at http://www.alsa-project.org/db/?f=c10f96b33085c93ad76bdef8a7bd2b3b261bd606

On 18/08/12 06:16, Randybob wrote:
> but the change doesn’t look
> like it took:
Have you used the switcher on that repo?
View by repository in software manager and select that repo and switch
system packages to that repo

Check very carefully in your sound settings that you have things set up
correctly
Are you using kde or gnome?

Not sure what you mean by switch - the repo is enabled, and I installed the updated ALSA from it. Not sure why 1.0.24 is still being reported.

I am using KDE.

First I suggest you have a look at this blog post here: Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

I also have a bash script you can use here: S.T.A.R.T. - SuSE Terminal Audio Reporting Tool - Version 1.12 - Blogs - openSUSE Forums

I saw reports that the issue is just enabling the audio using the Pulse Audio Volume control application pavucontrol which you may need to install. It is worth a try.

Thank You,

pavucontrol is installed, volume on my output devices is at 100%. After some further testing, it looks like I’m getting sound out of my front headphone jack in OpenSUSE, but not out of my rear speaker jack. I get sound out of both in Windows. Ran S.T.A.R.T. I figured this output would be of use:

Option 1:

alsa-1.0.25-115.1-x86_64 -> obs://build.opensuse.org/multimedia:libs
alsa-utils-1.0.25-61.1-x86_64 -> obs://build.opensuse.org/multimedia:libs
alsa-firmware-1.0.25-26.1-noarch -> obs://build.opensuse.org/multimedia:libs
libasound2-32bit-1.0.25-115.1-x86_64 -> obs://build.opensuse.org/multimedia:libs
libasound2-1.0.25-115.1-x86_64 -> obs://build.opensuse.org/multimedia:libs

You should expect to have at least four Alsa Packages Installed.
32 bit files are not required when using 64bit openSUSE install.

called ----> alsa-utils <--------- from the openSUSE Repository.
called ----> libasound2-32bit <— from the openSUSE Repository.
called ----> alsa <--------------- from the openSUSE Repository.
called ----> libasound2 <--------- from the openSUSE Repository.
called ----> alsa-firmware <------ from the openSUSE Repository.

Option 8:

pulseaudio-module-zeroconf-1.1-1.2-x86_64 -> openSUSE
pulseaudio-module-gconf-1.1-1.2-x86_64 -> openSUSE
pulseaudio-module-bluetooth-1.1-1.2-x86_64 -> openSUSE
pulseaudio-module-lirc-1.1-1.2-x86_64 -> openSUSE
pulseaudio-module-x11-1.1-1.2-x86_64 -> openSUSE
pulseaudio-module-jack-1.1-1.2-x86_64 -> openSUSE
pulseaudio-utils-1.1-1.2-x86_64 -> openSUSE
pulseaudio-1.1-1.2-x86_64 -> openSUSE

You need the several programs (around 9) installed to use Pulse Audio from openSUSE

Not sure what other packages I would need.

I note this:


    6.736991] ALSA hda_codec.c:4914 
**    6.739669] ALSA patch_realtek.c:1291 realtek: No valid SSID, checking pincfg 0x4007e619 for NID 0x1d**
    6.739670] ALSA patch_realtek.c:1307 realtek: Enabling init ASM_ID=0xe619 CODEC_ID=10ec0899
    6.743013] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input6
    7.702769] Adding 8790012k swap on /dev/sda5.  Priority:0 extents:1 across:8790012k 
**    7.729820] mount[781]: WARNING: All config files need .conf: /etc/modprobe.d/50-sound.conf.old, it will be ignored in a future release.**
    7.730631] fuse init (API version 7.17)
**    7.730966] mount[785]: WARNING: All config files need .conf: /etc/modprobe.d/50-sound.conf.old, it will be ignored in a future release.**
    7.853867] mount[791]: mount: fusectl already mounted or /sys/fs/fuse/connections busy
--
    9.386461] ntfs-3g[804]: Ownership and permissions disabled, configuration type 1
**   10.449824] vboxadd[825]: WARNING: All config files need .conf: /etc/modprobe.d/50-sound.conf.old, it will be ignored in a future release.**
   10.457781] microcode: CPU0 sig=0x306a9, pf=0x2, revision=0x10
--
   11.066412] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
   11.068156] SuSEfirewall2_init[887]: Loading basic firewall rules WARNING: All config files need .conf: /etc/modprobe.d/50-sound.conf.old, it will be ignored in a future release.
   11.069128] ip_tables: (C) 2000-2006 Netfilter Core Team
**   11.070140] SuSEfirewall2_init[887]: WARNING: All config files need .conf: /etc/modprobe.d/50-sound.conf.old, it will be ignored in a future release.
   11.072347] SuSEfirewall2_init[887]: WARNING: All config files need .conf: /etc/modprobe.d/50-sound.conf.old, it will be ignored in a future release.
   11.073486] SuSEfirewall2_init[887]: WARNING: All config files need .conf: /etc/modprobe.d/50-sound.conf.old, it will be ignored in a future release.
   11.074420] SuSEfirewall2_init[887]: WARNING: All config files need .conf: /etc/modprobe.d/50-sound.conf.old, it will be ignored in a future release.**

There should be NO reference to a 50-sound.conf.old. Did you create that file ?

Are you keeping backup files in /etc/modprobe.d ?? If so , that is a bad idea as they can be interpreted as regular entries. Place your backups somewhere else.

Note the SSID of your PC’s hardware audio codec can not be determined. You may need to manually force an audio model option.

I did create it, it was a backup I made before I started messing with it. It’s important to note that I was having this problem before I made this file as a backup. Removing.

How would I manually force an audio model option?

There is a ‘horribly’ out of date wiki that I wrote here: SDB:Audio troubleshooting - openSUSE and it gives some hints how to force a model option.

I am incredibly busy at work currently (the work that pays my salary) and it will be like this for the next five months. So unfortunately I do not have the time to follow up on the details. Others on this forum have seen my ‘methodology’ at work in various support threads, so maybe one of them can chime in with a similar or better method. Sorry and good luck.

Guys, this guy was in the correct track!

You are 100% correct. As is clearly indicated in the changelog Changes v1.0.24 v1.0.25 - AlsaProject

ALSA: hda - Add support of ALC898/899 codec

You need ALSA 1.0.25.

The part you missed is that ALSA has a user-space part and a kernel-space part. You only updated the user-space part, but /proc/asound/version shows the kernel-space part version. The kernel-space part is actually the one that contains the drivers, so the really important one.

Since building kernel modules is a bit different than the rest the kernel-space part is in a different repository. Add Index of /repositories/multimedia:/audio:/KMP/openSUSE_12.1 and install alsa-driver-kmp-desktop (if you use “kernel-desktop” and not “kernel-default”).

Is better explained here: SDB:Alsa-update - openSUSE

Performed the upgrade. However, no change in sound, in spite of it. Currently:

cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.25-git20120824.
Compiled on Aug 23 2012 for kernel 3.1.10-1.16-desktop (SMP).

cat /proc/asound/modules
0 snd_hda_intel

cat /proc/asound/cards
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xf7530000 irq 46

Your ALSA information is located at http://www.alsa-project.org/db/?f=3b46814e3b0b990bce0924cf3df3079687e9b558

As far as adding the model info to 50-sound.conf, there is nothing for ALC898 in any of the files within /usr/src/linux-3.1.10-1.16/Documentation/sound/alsa/. Shouldn’t there be now that the kernel space was updated?

Can you allow us to do a quality check of the rpms you installed to ensure you did not miss any ?

Please, what is the output of:


rpm -qa '*alsa*'
rpm -q 'libasound2'

zathras:~ # rpm -qa '*alsa*'
alsa-oss-32bit-1.0.25-37.2.x86_64
alsa-plugins-pulse-1.0.25-58.1.x86_64
alsa-oss-1.0.25-37.2.x86_64
alsa-plugins-32bit-1.0.25-58.1.x86_64
alsa-plugins-pulse-32bit-1.0.25-58.1.x86_64
alsa-1.0.25-115.1.x86_64
alsa-utils-1.0.25-61.1.x86_64
alsa-docs-1.0.25-115.1.noarch
alsa-firmware-1.0.25-26.1.noarch
alsa-driver-kmp-desktop-1.0.25.20120824_k3.1.10_1.16-1.1.x86_64
alsa-plugins-1.0.25-58.1.x86_64
zathras:~ # rpm -q 'libasound2'
libasound2-1.0.25-115.1.x86_64

I checked each package version and that looks ok. There is a newer alsa-driver-kmp-desktop version, but IMHO updating that driver further is unlikely to help.

I recommend you write a bug report which will obtain the attention of an alsa driver developer who also works for SuSE-GmbH. There is guidance here how to do that: openSUSE:Submitting bug reports - openSUSE . You should be able to use your openSUSE forum user name and password when logging on to bugzilla. Monitor the bug report around daily and within a week you should get a reply, asking for more information or asking you to run a test. Ensure you clear the ‘need info’ flag on that bug report mechanism each time you reply, so that those providing support know that you have replied.