no sound after upgrading to 11.2


after upgrading from 11.1 to 11.2 I can get no sound when playing audio files.

I am using Gnome desktop.

I have posted my ALSA information here:

Thanks in advance for any help.


Define audio files? MP3? WMA? Something else?

Have you installed the restricted formats package?
Restricted Formats/11.2 - openSUSE-Community

Please also advise which sound device you are trying to use? Mother board? or your second sound device (a PCI card).

When testing for basic sound functionality, I recommend you try EACH one of the 3 sound tests here: SDB:AudioTroubleshooting - openSUSE [ie the 2 speaker-tests and the alsa web site test]

If ANY of those 3 work, then the sound problem is most likely a mixer or codec problem.

Also, if you had any custom settings in your /etc/modprobe.d/sound file, please note that file is depreciated and does do anything. The config file is now /etc/modprobe.d/50-sound.conf

I too had no sound after installing 11.2 over my old 11.0. The ‘SDB:AudioTroubleshooting - openSUSE’ site (SDB:AudioTroubleshooting - openSUSE) was very helpful to me. I have 2 soundcards, one a crappy on-board, and another an Audigy2 from Creative Labs. In Yast, the tests of the soundcard for the on-board were successful, but the sound would not output with my non-root user logged in until I added the user to the ‘audio’ group. The Audigy would not work until I went into the command-line ‘alsamixer’ (note: the GUI mixers always seem to not display a complete list of volume Items available to a card, use the command-line mixers when available) and unmuted the ‘Audigy Analog/Digital Output Jack’.

Thanks for sharing your solution. The need to unmute the ‘Audigy Analog/Digital Output Jack’ seems to bite a lot of new users. Good on you for picking it up.

I have tried playing back WAV, MP3 and an ordinary audio CD, and I get no sound with any of these formats.

No, I haven’t.


I would like to use the second (PCI) card. I don’t need the one on the motherboard.
The PCI card is the only one that is configured in the Yast/Sound panel. It is also set as primary sound card.

The first test (speaker-test -Dplug:front -c2 -l5 -twav) works, but the second one (speaker-test -c2 -l5 -twav) does not.

However, I can play the test sound in Yast/Sound panel for the PCI card.

No, I haven’t got any custom settings in this file.

Perhaps banshee is not using the PCI card, but I don’t know how to verify/change it?


I have added my non-root user to the audio group, but it didn’t help.

I have also tried setting the volume in the alsamixer. There is no ‘Audigy Analog/Digital Output Jack’ in there for my PCI sound card,
but I have raised the volumes for all output channels. Unfortunately it didn’t help.


Sorry, I NEVER use banshee. I only use smplayer and vlc.

Adding yourself to the audio group is useless.

If you don’t have an Audigy you won’t have the option.

If the card produces a test sound in Yast, it is working. Since you opened up all in the mixer, my guess is you’re trying to play restricted media. Follow the link in the post above and you’ll end up fine.


Please answer Chrysantine’s questions:

I have tried playing WAV, MP3 and an ordinary audio CD.
No sound with any of these.

I have now also tried installing the additional codecs (using
the provided link), but still I get no sound. It seems that
despite installing the codecs, banshee still can’t decode the
stream (it displays the message “Unknown stream” when I try
to listen to an mp3 radio).


How about help us help you? You can do that by install smplayer and vlc and see if they have the same problem ?

I have installed the smplayer, and it works fine :slight_smile: So I will switch to using it rather than banshee.

Many thanks to all of you for your kind help.


Most likely it’s just a case of installing the right gstreamer-plugin - but at least your audio works as it should.