No sound after upgrading from 12.2 to 12.3

I just upgraded my 64bit OpenSuSE 12.2 to OpenSuSE 12.3 and found that there is no sound from the speaker.
From YAST/Hardware Information, two audio devices are listed (I have only a soundcard, integrated in the Motherboard)

00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Caicos HDMI Audio [Radeon HD 6400 Series]
I ran “pavucontrol” and tried to configure the sound fron there, to no avail

I ran /usr/sbin/alsa-info.sh and upladed the information the location of the information is http://www.alsa-project.org/db/?f=a27c043e0835edea4f89f5559bb43b3e445edf20Has anyone an idea? can someone help?Thanks

Could you post /proc/asound/cards content? Also which desktop do you use (Gnome/KDE/…)?

BTW the second “sound card” is HDMI output, maybe it is used instead of the real sound card?

Unfortunately that link does not work.

The link should be http://www.alsa-project.org/db/?f=a27c043e0835edea4f89f5559bb43b3e445edf20

According to the log PA is running:

Pulseaudio: Installed - Yes (/usr/bin/pulseaudio) Running - Yes

There are 2 sound cards:

0 [Intel ]: HDA-Intel - HDA Intel HDA Intel at 0xd0200000 irq 46 1 [Generic ]: HDA-Intel - HD-Audio Generic HD-Audio Generic at 0xd0120000 irq 47

Maybe PA is used the wrong one? Could you check it in pavucontrol?

Did you try reinstalling from Yast sometimes that works. Since you have 2 cards there could be some confusion

Yes, it is possible to check in pavucontrol. I provide some examples how to do that in my blog on pulse audio: https://forums.opensuse.org/blogs/oldcpu/pulseaudio-basics-opensuse-pavucontrol-96/

From that I note a 64-bit openSUSE-12.3 on a EMACHINES 7260SP with v.1.0.26 of alsa and a 3.7.10-1.1-desktop kernel. Both sound devices use the snd_hda_intel kernel module, with 2 instances running. One of the sound devices is a ALC880, and I assume the 2nd one is an HDMI.

I note from the aplay this:


!!Aplay/Arecord output
!!--------------------

APLAY

**** List of PLAYBACK Hardware Devices ****
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

and no other sound device.

That suggests to me that your ALC880 was not picked up by alsa for some reason.

Have you tried to go into YaST > Hardware > Sound to configure your audio device ?

as a upgrader myself, could you run

pulseaudio --check

for me this gave the error

E: [pulseaudio] core-util.c: Failed to create secure directory (/run/user/1000/pulse): Permission denied

which meant, that /run/user/1000/pulse was owned by root and therefore not accessible. you can change that using

sudo chown -R /var/user/1000/pulse $USERNAME

(watch for the 1000, your number might differ) and then start pulse yourself:

pulseaudio -D

havent found a way to change this behaviour yet. posted myself this question:

https://forums.opensuse.org/english/get-technical-help-here/multimedia/485563-12-3-no-sound-after-reboot-run-users-id-pulse-owned-root.html

Thanks to everyone for the help

I run Pavucontrol and the device listed there is RV710/730 HDMI Audio adeon HD 4000 series] Digital Stereo (HDMI) and only this output device is listed
I have erased via Yast both cards and configured them again (I wonder, I have really only a sound card) I get te message “Fatal error unable to connect to PULSE AUDIO”

Did you reboot (to restart both alsa and pulse) since going to YaST ?

Before wasting time trying to configure with pulse, I recommend you ensure that alsa can configure the device. It was not clear last time. So please, again run the diagnostic script, so we can see if there was any difference (and again post the output URL here). That information is very important in attempting to understand what is happening, and what is not happening.


/usr/sbin/alsa-info.sh