No sound after updating to KDE 4.4

Hello!
I seem to have a problem with sound after upgrading KDE. All multimedia applications (Amarok, xine, vlc) do not produce sound at all. :frowning: Sounds at startup and notifications have also disappeared.
However, when I go to yast -> sound -> play test sound , it works.
I tried to update my sound drivers following instructions from here: Alsa-update - openSUSE but it didn’t change anything.

I also tried to configure the sound output device in Amarok (Configure -> Playback -> Configure Phonon). The only option that it offers is PulseAudio Sound server, and when I press “test”, nothing happens (although it is supposed to play a sound).

I have the following packages installed:
alsa-plugins-pulse-1.0.23-28.1.i586
alsa-driver-kmp-default-1.0.23.20100626_2.6.31.12_0.2-1.1.i586
alsa-firmware-1.0.23-8.1.noarch
alsa-utils-1.0.23-20.1.i586
alsa-plugins-1.0.23-28.1.i586
alsa-1.0.23-62.1.i586
alsa-tools-1.0.21-2.5.i586
alsa-tools-gui-1.0.21-2.5.i586
alsa-oss-1.0.17-53.1.i586
libasound2-1.0.23-62.1.i586
pulseaudio-lang-0.9.21-57.2.noarch
pulseaudio-0.9.21-57.2.i586

I don’t know what other information I can provide… if someone can help me with advice, I would be very grateful!

Look for your soundcards priority in the KDE-systemsettings → Multimedia. Your soundcard should have the highest priority in each section.

There are two possibilities that I can speculate:

  1. you have somehow introduced a permissions problem, and you need to add your regular user to group audio and reboot, or
  2. there is an order of sound devices in yast > hardware > sound and the order of devices under KDE Menu > Configure Desktop > Multimedia does not match that under YaST

At the risk of saying close the barn door after the hoarse is gone, if sound worked before, and all you did was update KDE, then its extremely unlikely (almost not plausible) that a problem with the alsa sound driver as it was before the KDE update. … The risk here is by such an update you might make things worse, …

In this case I note your alsa-tools versions are the wrong versions now, and not consistent with your other alsa applications. Instead you should have installed:

alsa-tools-1.0.23-9.3.i586.rpm         
alsa-tools-gui-1.0.23-9.3.i586.rpm

… but that may not be the problem. In truth, I do not know.

Is phonon-backend-xine and phonon-backend-xine not available for 4.4 of KDE ? If they are available for KDE-4.4. why not install them? They may give you more choices.

I confess, its problems like this which are a MAJOR reason why I do NOT update unless it is an official update, which 4.4 is NOT.

>there is an order of sound devices in yast > hardware > sound and the order
>of devices under KDE Menu > Configure Desktop > Multimedia does not match
>that under YaST

I gyess the problem could be that those are different devices. In Yast it is “VT8233/A/8235/8237 AC97 Audio Controller”, and in Kde > configure desktop > multimedia it is PulseAudio sound server.
I also have phonon-backend-xine and phonon-backend-gstreamer installed, but it doesn’t seem to help.

I admit that the update probably have caused this problem. I guess if nothing works I can try to install an earlier version of KDE (although the reason why I did the update was because I needed a program, Contor, which was only available for KDE4.4… )

Anyway, thank you for your feedback! I will try to update the alsa-tools package, just in case it helps.

You could of course try disabling pulse for a brief time to see if that helps.

… and then later re-enable it.

ie if you think it a pulse audio problem, you could open up a Terminal session and enter su - and then the password.

At the terminal prompt enter this command (with root permissions).

setup-pulseaudio --disable

restart and test.

If that does not work, then you MUST enable it again with (with root permissions):

setup-pulseaudio --enable

I don’t quite get why it is necessary to use PulseAudio at all, as this is a soundserver mainly created for a GNOME-environment.

…] and in Kde > configure desktop > multimedia it is PulseAudio sound server.

Again:

Well, the problem is that in Kde settings > multimedia it does not have my sound card at all. PulseAudio is the only option in the list.

I don’t think it is a pulseaudio problem. I didn’t actually have it in the beginning. First I updated KDE and got the problem with the sound, then I updated the multimedia packages and still had the problem, then I tried to install pulseaudio hoping that it just might work. But before I installed it my soundcard wasn’t in the KDE > Multimedia list either (there wasn’t anything at all, actually.)

I come to think that maybe KDE4.4 just doesn’t support my sound card and/or driver, and it was a mistake to upgrade. For now I will try to downgrade KDE to 4.3 and see if in 11.3 it gets any better. Thank you for your comments!

If you disable PulseAudio (setup-pulseaudio --disable), then your soundcard will suddenly appear after you re-run KDE Control Panel / Multimedia.

Sometimes simply restarting pulseaudio will make everything okay in KDE:

as non-root type: “pulseaudio -k”, then “pulseaudio”. Then try using Amarok or something like that.

The problem could still be PulseAudio, even though it worked before in 4.3, because KDE and Pulse still don’t play very nicely with each other.

I had also a problem with phonon and pulseaudio. The problem was, that phonon can use pulseaudio directly now (as far as I remember).

The solution was zu edit the file /etc/asound-pulse.conf


# PulseAudio plugin configuration

# Let's create a virtual device "pulse" for mixer and PCM

pcm.pulse {
    type pulse
}

ctl.pulse {
    type pulse
}

# Let's make it the default!

pcm.!default {
    type pulse
}

ctl.!default {
    type pulse
}

pcm.phononpulse {
    type plug
    slave.pcm {
        type pulse
    }
    hint {
        show on
        description "PulseAudio"
    }
}