No sound after update...

I have used the search tool extensively and have found several issues similar to mine but not exactly the same.

As the title states, I ran the suse Update and now I have no Sound. I have run the test sounds and they do work. My sound card is working. It is almost as if somewhere in the configs all my programs are pulling the wrong data. Is there some way to reset the sound engine.

Any help in this matter would be much appreciated.

thanks in advance.


I got my system Sounds to work. Found the “use Software Mixing” was turned off. Still no sound from any multimedia app or from firefox.:expressionless:

Reference no sound from multimedia apps, as pointed out in the multimedia stickie, openSUSE is deliberately packaged such that proprietary audio does not work. Welcome to multimedia sub-area - openSUSE Forums

I recommend you 1st update your software package manager repositories (repos) with 4 and only 4 repos. Specifically I recommend OSS, Non-OSS, Update and Packman. No others. None (at least none while you are new to this). There is guidance on how to do that here:
Repositories - openSUSE-Community
ignore the codec link on that page (for now) and click on your openSUSE version, and then setup OSS, Non-OSS, Update and Packman. No others.

Once that is setup, you can install some good multimedia apps with the zypper command. Remove xine-lib if you have it installed (it is deliberately crippled), and for example you can install other apps with:
zypper install smplayer libxine1 xine-ui libffmpeg0 mplayerplug-in flash-player

Good luck.