No sound after installation

and does that give sound ? Do you get any errors ?

Nominally by default, assuming there is no setting in pulse audio to the contrary, sound by default will be routed to sound-card-0. In your PC’s case, sound card-0 is the analog sound device, which should be your speakers. This uses the Intel CA0132 and not the nVidia HDMI.

No, the NVidia is your HDMI and you have stated you are not using the HDMI.

which of the 12 options ? I have no idea what you mean by this. Saying something is set ‘randomly’ does not inspire confidence.

If no sound now, try each of the following two commands, one at a time. They look similar but they ARE different. Does either give sound ?

This first one should send the test sound to sound card-0 which I think is the analog speakers :


aplay -d plughw:0,0 /usr/share/sounds/alsa/test.wav

This second one should send the test sound to sound card-1 which I think is one of the HDMI devices (and I do not expect this to work for sound) :


aplay -d plughw:1,0 /usr/share/sounds/alsa/test.wav

Please advise of any error associated with the above.

I get no sound from the speaker-test, nor does it spew out any errors. There is one difference between the tests on the different machines, which is that each speaker test on the LEAP 42.1 machine seems to hang before moving on the other, as though waiting for a response, while the tests on the 13.2 machine move along smartly. Without knowing the internals of speaker-test I can’t begin to speculate what is happening here.

If no sound now, try each of the following two commands, one at a time. They look similar but they ARE different. Does either give sound ?

This first one should send the test sound to sound card-0 which I think is the analog speakers :

aplay -d plughw:0,0 /usr/share/sounds/alsa/test.wav

This second one should send the test sound to sound card-1 which I think is one of the HDMI devices (and I do not expect this to work for sound) :

aplay -d plughw:1,0 /usr/share/sounds/alsa/test.wav

Please advise of any error associated with the above.

Neither of these gives a sound. Each gives the output

Playing WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo

Are these 100% identical machines in hardware? Without knowing the detailed internal hardware of each machine I would not speculate as to what is happening there.

I’m waiting for an explaination as to what these 12 options may be.

I’m starting to think your PC’s sound problem is hardware.

Do you have another OS on this PC where the sound actually works ?

Check the plugs. Bypass the KVM. Run pavucontrol and see if it says the output is plugged in. Could be your hardware does not sense the speakers trough the KVM

As I said, I wondered that myself, which is why I swapped the connections with a PC, running openSUSE 13.2, in which the sound is working. Initially this other machine was connected to position 1 on the KVM, the new machine on position 4. I swapped these and the old 13.2 machine produces sound but the new machine does not. I think hardware is not a problem.

But I will try directly connecting the speakers as gogalthorp suggests, just to check if the LEAP 42.1 software can handle the KVM.

They aren’t identical. The openSUSE 13.2 machine is around four years old, with a non-functioning graphics card. The LEAP 42.1 machine is new.

I’m waiting for an explaination as to what these 12 options may be.

There are actually 13 options. They relate to the the diagnostics from the NVidia card:

card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

In the configuration tab of the audio settings in the system tray there is a drop-down menu for the NVidia card, the top three of which state

Digital Stereo (HDMI) Output
Digital Surround 5.1 (HDMI) Output
Digital Surround 7.1 (HDMI) Output

These three options are then repeated for HDMI 2, HDMI 3 and HDMI 4. The thirteenth option is “Off”.

Sorry I didn’t give these details before as I thought the NVidia card was irrelevant.

I just tried the test again with the option set to “Off”, but no change.

I directly connected the speakers to the PC but still no sound. However, I did get a noise when I plugged the jack in, so no problem with the actual connection.

I think we can safely conclude that the hardware is working and that the problem is software related.

Incidentally, where doe sit say in pavucontrol whether the output is plugged in or not?

I appreciate this may be frustrating for you … but you have to understand what we can see (and not see) and not hear when you do these tests. When you state (during a repeat test) that ‘still no sound’ that means NOTHING to me as I have no idea as to what that test was.

One of the commands I gave previous should have unequivocally worked. The fact that they did not is puzzling. But if your subsequent tests use different test of sound then it could be your tests were invalid - and I can’t make that judgement as you are not telling us what the test may be each time you test for sound.

I’m very close to recommending to you to raise a bug report on this - it should work. The only remaining aspects i can think of are to FORCE the intel driver assignment to specific cards and to FORCE an audio codec setup at boot - but frankly nothing you have provided so far suggests those are the optimal actions to take.

Hence raising a bug report may be best (to avoid wasting time).

I don’t think you can conclude from that noise that the hardware is working.

as for the question on pavucontrol, I have no idea as to what you mean. My understanding of pavucontrol is it has 5-tabs: configuration, input devices, output devices, recording and playback. For our purposes in this thread we can ignore the “input devices” tabe and “recording” tab as that is not what is being attempted.

In pavucontrol configuration tab you MUST select the appropriate device. In your case it should be something like “analog stereo duplex” or “analog stereo output” or some other selection. It is different for every hardware and we can’t see your pavucontrol so we can not see what your choices are.

In the “output devices” tab make certain you have in the botton “all output devices” selected and in the top port selection have the correct output selected.

Then in the playback tab, when you start to play sound from an application, that application will appear, and you will have in a drop down tab the opportunity to select what output device to send the audio to. As soon as the application stops, the entry for the application will disappear.

if you have sound working on openSUSE-13.2 you should be able to study pavucontrol and see how it works. It has not changed in LEAP.

I can’t help here as I can not visualize what you are talking about.

I can not help here as (1) I never touch the system tray for sound on my PCs and (2) I can not visualize what you are referring to since I never touch that setting. I fear you may have misconfigured something you should not have touched.

No worries - it makes no difference as I still don’t know what is being talked about there.\

To test the speakers I ran (as suggested on https://en.opensuse.org/SDB:Audio_troubleshooting)

speaker-test -Dplug:front -c2 -l5 -twav

plus the tests you suggested.

The speaker-test command sends a sound to each speaker in turn (a woman’s voice saying “Left speaker” and “Right speaker”), which produces no sound with the LEAP 42.1 machine.

How do I raise a bug? I’m not even sure what I’d be reporting a bug about.

I don’t think you can conclude from that noise that the hardware is working.

as for the question on pavucontrol, I have no idea as to what you mean. My understanding of pavucontrol is it has 5-tabs: configuration, input devices, output devices, recording and playback. For our purposes in this thread we can ignore the “input devices” tabe and “recording” tab as that is not what is being attempted.

In pavucontrol configuration tab you MUST select the appropriate device. In your case it should be something like “analog stereo duplex” or “analog stereo output” or some other selection. It is different for every hardware and we can’t see your pavucontrol so we can not see what your choices are.

In the “output devices” tab make certain you have in the botton “all output devices” selected and in the top port selection have the correct output selected.

Then in the playback tab, when you start to play sound from an application, that application will appear, and you will have in a drop down tab the opportunity to select what output device to send the audio to. As soon as the application stops, the entry for the application will disappear.

if you have sound working on openSUSE-13.2 you should be able to study pavucontrol and see how it works. It has not changed in LEAP.

Is it possible to run pavucontrol from the command line? As I said, the graphics card on the 13.2 machine is non-functioning.

I’m not sure what I mean by my question about pavucontrol. It was addressed to gogalthorp, who suggested that pavucontrol would say whether the speakers were plugged in or not. My reading of pavucontrol is exactly the same as yours.

I’m not sure what other tests I could run of the hardware. I accept that I have not tested the sound card in the LEAP 42.1 machine itself, but I think it’s clear that there is no problem with either the speakers or the KVM. I could test the machine if I had Windows installed, but I had to deinstall it because of the Windows 10 / UEFI bug.

If you can suggest any other tests I could run I’d be most grateful.

of course its a bug (unless you misconfigured things in your effort to get it to work). The severity of the bug is not clear. The bug is on the kernel driver not giving sound initially, and later the openSUSE packagers can change the actual focus of the bug report dependent on the result of investigations. This should “just work” for you. I gave you advanced tests that should give sound. It does not. Clearly its a big or something was messed up in some of the configuration menu aspects you described that you tweaked, that I never touch.

There is guidance here on opening bug reports on openSUSE:
https://en.opensuse.org/openSUSE:Submitting_bug_reports

You can log on to bugzilla with your openSUSE forum username and password.

In the case of sound you describe the problem, do NOT reference a forum thread as the openSUSE packager will NOT read a forum thread. And attach to the bug report the text file you get by sending the command as a regular user in a konsole/xterm :

/usr/sbin/alsa-info.sh --no-upload

Thats the only way I run it. Type in an xterm/konsole “pavucontrol”.

You could boot to a liveDVD from another distro (such as Knoppix) and see if sound works there.

One other test you could try with your openSUSE is to go to YaST and add to your user permissions to group ‘audio’. Save the change, reboot and do the same audio tests (using commands I provided previous). See if the additional permissions makes a difference - where I note this is a very speculative stab in the dark.
.

Note be sure your user is in the audio group, some sound devices need that. You have to re-log after any group changes to your user

Pursuing this I decided to have another look at the configuration of the cards in Yast. It told me that there was a third card “C60/X99 series chipset HD Audio Controller” which is not configured. I figures it might be interesting to see what this could do, so I clicked “Edit” to configure it and chose “Quick automatic setup”. It came up with an error saying that the kernel module snd-hda-intel for sound support could not be loaded. It suggested that “This may be caused by incorrect module parameters, including invalid IO or IRQ parameters”.

I got the same error message when I chose “Normal setup”.

A driver problem would fit all the symptoms I have seen, and you expressed concern in your first reply that you saw two instances of the driver running.

Does this suggest anything? Or do you think that this third card is a red herring?

Tried that, but still no sound.

When I do this on the LEAP 42.1 machine it brings up the same graphics display as when I run it from KDE.

When I run it on the 13.2 machine it responds “Unable to init server: Could not connect: Connection refused”. I think pavucontrol runs graphically, even if initiated from a command line.

You are supposed to have 2 instances running of the intel driver. I suppose you could replace the /etc/modprobe.d/50-sound.conf file content with this content:


options snd_hda_intel index=0 vid=8086 pid=8d20
options snd_hda_intel index=1 vid=10de pid=0fbb

reboot and test, but I doubt that will make any difference. The 8086:8d20 is your analog device (which uses the alsa snd_hda_intel sound module) and the 10de:0fbb is your nVidia HDMI device (which uses a second instance of the alsa_hda_intel sound module ) . If using that custom /etc/modprobe.d/50-sound.conf file works, then do NOT go to YaST hardware sound as that will undo the custom setting.

Again - I think a bug report is the quickest way to get support to solve this
.

I don’t see the relevance of 13.2 machine errors here since the sound there works. Reporting that just confuses the issue.

That’s correct. But one can start it from the command line in addition to starting it from the GUI, which is what I interpreted your question to be.

I didn’t have time to take investigations further immediately, but continued with configuration of applications. By accident I noticed that I was getting a very weak sound out of my speakers from one application. Using Youtube to test, I can now hear sound, though not very strong, if I turn my hardware and pavucontrol volume controls up as far as I can. Its weak but audible.

Everything software seems to be up to full volume, but there’s a possibility that I’ve missed something. There seem to be a number of places where the volume is controlled. So any suggestions as to what I should check before I start to suspect a problem in the sound card itself?