No Sound after 11.1 upgrade

I recently upgraded from 10.3 to 11.1 and now find that Amarok and sound in general do not work very well or at all. Sometimes I can get the sound to actually play but when it does it is very distorted. I have tried just about everything I can find in other threads as well as messed around with things on this site… SDB:AudioTroubleshooting - openSUSE

I am really stuck now… here are a few things I have tried…

ran alsaconf, used yast to adjust sound card, reinstalled amarok… now I can’t get MP3’s to work even after attempting the codec installs.

I am almost ready to just back everything up and install again… without doing an update this time. Any thoughts on what I should try?

My card shows in yast as:
MCP51 High Definition Audio
Configured as sound card number 0
Driver snd-hda-intel

Here are results of /usr/sbin/

Note, once you have basic sound functionality, you should back off on your volume levels to 65% or so (or as far as practical) to remove distortion. Some apps in particular (such as vlc) are notorious for their individual volume controls causing distoriton.

Note you need to replace Novell/SuSE-GmbH packaged versions of applications with Packman packaged versions of multimedia players. Its not enough to just add codecs.

In particular, replace any videolan packaged versions of apps with packman packaged versions of the apps.

You could try working your way through this troublshooting guide:
Check your multimedia problem in ten steps - openSUSE Forums

I had installed the packman versions of amarok prior to posting and it was still messed up.

I found that I had to also update xine libraries with the packman ones and it seems to have resolved the issue. It now works the same as it did before in 10.3. Not having music for a couple days really was beginning to mess with me, but the world is right again.

Strangely enough my graphics seem to be working much better also… or with music it just seems that way.

Thanks for the reply.