no sound acer aspire one

I have installed 11.1 from DVD to the same computer (Acer Aspire one 10" netbook) which was analysed in a related post. Everything is OK, except the louder does not work. Earphone is OK, as it is written in other posts.

I tried to do that is suggested in this post, but nothing good happened.

Information list:

http://www.alsa-project.org/db/?f=38...ebadf35ed481cd

alsa-oss-1.0.17-1.37
alsa-utils-1.0.18-6.4
alsa-plugins-pulse-1.0.18-6.12
alsa-1.0.18-8.7
alsa-plugins-1.0.18-6.12
linux-fy1t:/usr/sbin # rpm -qa | grep pulse
pulseaudio-0.9.12-9.6
pulseaudio-module-jack-0.9.12-9.6
pulseaudio-module-lirc-0.9.12-9.6
libpulse-mainloop-glib0-0.9.12-9.6
alsa-plugins-pulse-1.0.18-6.12
libpulse-browse0-0.9.12-9.6
pulseaudio-utils-0.9.12-9.6
pulseaudio-module-zeroconf-0.9.12-9.6
libxine1-pulse-1.1.15-20.8
libpulse0-0.9.12-9.6
libpulsecore4-0.9.12-9.6
pulseaudio-esound-compat-0.9.12-9.6
pulseaudio-module-x11-0.9.12-9.6
pulseaudio-module-bluetooth-0.9.12-9.6

libasound2-1.0.18-8.7
Linux linux-fy1t 2.6.27.7-9-pae #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux

options snd slots=snd-hda-intel

u1Nb.41ZggzuIzR9:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel
alias snd-card-0 snd-hda-intel model=acer-aspire

Some idea?

When you copied and pasted your original post, the URL was corrupted. I believe this is the URL you are referring to: http://www.alsa-project.org/db/?f=38622916bb8b0b77888786dbd8ebadf35ed481cdand yes they are not the same. click on the quote you provided - it goes no where. Click on the quote I provided - it should work.

I note your acer aspire one is running a 32-bit openSUSE-11.1 with a 2.6.27.9-pae kernel. Your acer aspire has an ALC272 hardware audio codec.

I looked at your mixer settings from the diagnostic script, and also looked at the rpm list you provided, and I can not see anything that is obviously wrong.

You could try updating your alsa version from 1.0.17/1.0.18 to 1.0.20. You can do that by opening a terminal or konsole, and type ‘su’ (no quotes, enter root password when prompted) to get root permissions, and then with your acer aspire one connected to the internet, copy and paste and execute into the terminal/konsole the following commands one at a time:

zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.1/ multimedia
zypper install alsa-utils alsa-oss alsa-plugins alsa-plugins-pulse alsa-tools alsa-firmware
zypper rr multimedia
zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1/ multimedia
zypper install alsa-driver-kmp-pae
zypper rr multimedia

Then restart your PC and test your sound.

The line in red makes no sense to me.

I recommend you delete /etc/modprobe.d/sound file and then after rebooting with the new alsa version, go to YaST > Hardware > Sound and set up your sound card. That will regenerate the /etc/modprobe.d/sound file.

Thanks for the suggestions. I have already update the alsa in the way you described in the answer. However it did not help. So I went back to the original version. You wrote that a different kernel is needed for the acer aspire one. Maybe I have to update kernel previously and then update alsa(?) But I do not know how to update kernel! (I am not a newby in SuSE, but I am rather an “user”, sorry.

Thanks for the suggestions. I have already update the alsa in the way you described in the answer. However it did not help. So I went back to the original version. You wrote that a different kernel is needed for the acer aspire one. Maybe I have to update kernel previously and then update alsa(?) But I do not know how to update kernel! (I am not a new user in SuSE, but I am rather an “user”, sorry.

Updating to a SuSE-GmbH provided “official” kernel is relatively easy, although it is good to take a few precautions, and the complexity involved depends mostly on the hardware and drivers on one’s PC. Updating a kernel may break drivers that are compiled specific to the older kernel. Those drivers typically are

  • graphics card driver;
  • wireless driver;
  • sound driver;
  • webcam driver;
  • virtual box;
    So for example what I do, before any kernel update, is first check that there are ‘drivers’ (typically packaged in rpms) for those functions/drivers that I mentioned. The most current openSUSE-11.1 kernel is the 2.6.27.21 and so before updating, I would check what those drivers are.

Now if one is using the openGL graphic driver (as opposed to a proprietary graphic driver) then typically one need not worry about a kernel update. For sound, typically the SuSE-GmbH alsa packager will package alsa rpms for the new kernel. For virtual box, one just sends a command from the konsole to rebuild the virtual box aspects that need up updated for the new kernel. But for wireless and webcam, typically one needs to go to a place like web pin Webpin and search for rpms for the new kernel. I recommend searching BEFORE updating the kernel.

Then, also before updating to a new kernel, I find it useful to make a backup copy of the /boot/grub/menu.lst file, where that file is typically modified during the installation of the rpms for the kernel update. Then after the update is done, I compare the old menu.lst file against the new and make certain they are ok.

Note if one is unhappy with the new kernel, as long as one has the installation CD/DVD, it is typically possible to roll back to the old kernel.

There are also ways to have more than one kernel installed, in a dual (or tri, or quad, or whatever) boot selection. Of course the drivers will only be tuned to one of the installed kernels and not to all. But explanation as to how that can be done is outside the scope of this post.

Now something really strange has happened (at least for me.) I updated the alsa again as you suggested. Additionally I deleted the sound file as you suggested. The voice appeared!!! I was happy, but I relised that the wlan connection is dissapear. I change to the windows partition (to write thys symptoms) but the sound became bad in windows, and the wlan connection disappear here too! Then I goes back to the original version of alsa. Nothing has happened. Then I realised that the alsa update load a new packadge (alsa-driver-kpm-pae) I deleted this packadge, and winwows works well. Then I made reparing from dvd and now linux is ok again, but no sound (again.) :slight_smile:

I am a bit worry about the kernel update, since this simple alsa update caused a lot of strange symtoms.

One rather speculative possibility, is that the loading of the wlan is interfering with the loading of the alsa sound driver.

Try this :

  • get your linux wlan working, and then
  • with wlan working, test your linux audio and then
  • if your linux audio is not working, type: su -c 'rcalsasound restart’
    and enter root password when prompted for a password, and test your sound.
    The theory/speculative idea we are testing is to see if reloading the sound driver later (ie loading it long after wlan has been loaded) might help.

I have done what you recommended. The sound driver is restarted, but nothing has happened. No sound, but earphone is working.
(Now I am using the original alsa versions, not the updated one)

I do not know whether is important or not, but I use KDE3 not the newest version 4.

IMHO you have a superior chance with KDE3. KDE4 has quirks and it is more difficult wrt sound.

I am beginning to believe that I can not help. But one last attempt.

With your wireless set up to work, please reboot and test your sound. I assume only headphone will work. Then restart your sound with su -c 'rcalsasound restart’

Then test sound again (be certain to check the settings in your mixer kmix).

And then with your PC connected to the internet run the following command to post your dmesg output to the web:

dmesg > dmesg.txt && curl -F file=@dmesg.txt nopaste.com/a

and post here the URL it gives. ONLY post the URL. Maybe the dmesg will give a hint as to what is going wrong.

I have lost track. What version of alsa, and what kernel version do you have installed now?

OK. I have done what you suggested. Her are the URL:
dmesg.txt - nopaste.com (beta)

Again: since the alsa update was so chatasctrophic for me I set up the original version back again, which was listed in my first post.
Sorry, if it was not clear.

(My experience is, that the installed alsa-driver-kmp-pae packadge resolved the sound problem on on side but caused the missmach in wlan on the other side.Maybe a dufferent version of this packadge could work correctly? What is your opinion?)

I can not see anything in the dmesg indicating a problem with wireless. I note both video for webcam and ACPI for power management being loaded at that time thou … however I assume running “rcalsasound restart” later did not help, so that IMHO eliminates that as a possible problem (or did sound work better after “rcalsasound restart” ) ? You are kind of forcing me to guess.

This appears to be the 1st alsa loading:ACPI: Power Button (CM) [PWRB]
input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input5
ACPI: Lid Switch [LID0]
input: Sleep Button (CM) as /devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input6
**HDA Intel 0000:00:1b.0: PCI INT A → GSI 16 (level, low) → IRQ 16
HDA Intel 0000:00:1b.0: setting latency timer to 64
**uvcvideo: Found UVC 1.00 device USB 2.0 Camera (0c45:62c0)
input: USB 2.0 Camera as /devices/pci0000:00/0000:00:1d.7/usb5/5-2/5-2:1.0/input/input7
**hda_codec: Unknown model for ALC662, trying auto-probe from BIOS…
ALSA sound/pci/hda/hda_codec.c:3047: autoconfig: line_outs=1 (0x14/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3051: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3055: hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3056: mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3064: inputs: mic=0x12, fmic=0x18, line=0x0, fline=0x0, cd=0x0, aux=0x0
**acer-wmi: Unable to detect available WMID devices
ACPI: Sleep Button (CM) [SLPB]
usbcore: registered new interface driver uvcvideo
USB Video Class driver (v0.1.0)
ACPI: AC Adapter [AC] (on-line)

And this a repeat of alsa loading during the rcalsarestart: HDA Intel 0000:00:1b.0: PCI INT A disabled
HDA Intel 0000:00:1b.0: PCI INT A → GSI 16 (level, low) → IRQ 16
HDA Intel 0000:00:1b.0: setting latency timer to 64
hda_codec: Unknown model for ALC662, trying auto-probe from BIOS…
ALSA sound/pci/hda/hda_codec.c:3047: autoconfig: line_outs=1 (0x14/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3051: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3055: hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3056: mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3064: inputs: mic=0x12, fmic=0x18, line=0x0, fline=0x0, cd=0x0, aux=0x0

There is a possibility that the 29-May rpms were corrupted. I see some 1-june rpms are in place. You could try again.

As long as your kernel version did not change, this should not happen. If you do try the newer alsa again, and sound works, but wlan does not, then if you have a wired internet connection, run the dmesg curl command again. Or simply dmesg > dmesg.txt, open dmesg.txt in a text editor, and post it to a pastebin site: pastebin - Type, paste, share. and post here the URL. DO NOT POST THE DMESG HERE. Its far too big.

Anyway, no matter what, I recommend you write a bug report on this: Submitting Bug Reports - openSUSE Be certain to file the report under component “sound” to get the SuSE-GmbH alsa packagers attention.

I did not experience any difference in sound functions between the before and after rcalsasound restart.

I think it is better if I wait a bit for the newer alsa version, and send a bug report now. I thank your effort!!!

I think these two lines reflect the problem you are having. I do not know the solution. Good luck with the bug report.

hi,
this seems to be an old thread, but nevertheless:

My machine is acer aspire one 150d with 82801G sound card and openSuSE 11.1 with xfce. I was only able to get sound from Yast sound config tool -> test sound. After that i upgraded Xfce to lates version from Xfce repository and since it might have been a permission problem, this seems to have solved it (it is also a fix for running nm-applet as non-root user):

>cat /etc/PolicyKit/PolicyKit.conf

<config version=“0.1”>
<match action=“org.freedesktop.hal.storage.mount-removable”>
<return result=“yes” />
</match>
</config>

But, in the end, the microfone is still dead. The funny thing is, PulseAudio Volume manager seems to show some input noise, but the level meter does not react to any sound input. I tried updating Alsa to 1.0.12, but no progress. Can anyone help me with the mic?

Are you referring to an internal mic or an external mic?

Alsa 1.0.12 is ancient! openSUSE 11.1 comes with 1.0.18 of alsa. Do you mean 1.0.21 ?

Please provide the output of running in a terminal/konsole, with your PC connected to the internet:
/usr/sbin/alsa-info.sh
If it asks to update, you need to run it in root permissions to do an update (as a regular user does not have write permissions to /usr/sbin). Otherwise you can run it as a regular user. Be certain to select the SHARE/UPLOAD option. When it completes it will give you a URL. Please post here the URL. Just the URL.

Please also provide the output of running:
rpm -qa ‘alsa
rpm -qa ‘pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

thank for the reply; yes, i was referring to internal mic and alsa 1.0.21 (latest)

output of alsa info (as root):
http://www.alsa-project.org/db/?f=0cc1c4d02411b575cb75b553567c2f748e49a43f

output of rpm -qa 'alsa
alsa-tools-1.0.18-1.13
alsa-docs-1.0.18-8.12.1
alsa-plugins-1.0.18-6.12
alsa-utils-1.0.18-6.4
alsa-oss-1.0.17-1.37
alsa-firmware-1.0.17-1.42
alsa-1.0.18-8.12.1
alsa-plugins-pulse-1.0.18-6.12

output of rpm -qa 'pulse
pulseaudio-0.9.14-2.2.1
pulseaudio-esound-compat-0.9.14-2.2.1
libpulse-mainloop-glib0-0.9.14-2.2.1
pulseaudio-module-gconf-0.9.14-2.2.1
libpulse0-0.9.14-2.2.1
pulseaudio-lang-0.9.14-2.2.1
vlc-aout-pulse-1.0.3-2.2
alsa-plugins-pulse-1.0.18-6.12

output of rpm -q libasound2
libasound2-1.0.18-8.12.1

kernel:
Linux 2.6.27.37-0.1-pae #1 SMP 2009-10-15 14:56:58 +0200 i686 i686 i386 GNU/Linux

output of cat /etc/modprobe.d/sound
options snd slots=snd-hda-intel

u1Nb.41ZggzuIzR9:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel

OK, thanks. I note an Acer Aspire One running a 32-bit openSUSE-11.1 with the 2.6.27.37-pae kernel, with 1.0.17/1.0.18 of alsa and an ALC272 hardware audio codec.

I noted your mixer selection appear limited … although they are set wrong for recording from the front mic (which is an analog mic, I believe):

!!Amixer output
!!-------------
!!-------Mixer controls for card 0 [Intel]
Card hw:0 ‘Intel’/‘HDA Intel at 0x56340000 irq 16’
Mixer name : ‘Realtek ALC272’
Simple mixer control ‘Front Mic’,0
Front Left: Playback 27 [87%] [6.00dB] [on]
Front Right: Playback 27 [87%] [6.00dB] [on]
Simple mixer control ‘Front Mic Boost’,0
Front Left: 0 [0%]
Front Right: 0 [0%]
Simple mixer control ‘Capture’,0
Front Left: Capture 31 [100%] [30.00dB] [off]
Front Right: Capture 31 [100%] [30.00dB] [off]
Simple mixer control ‘Input Source’,0
Capabilities: cenum
Items: 'Front Mic’
From the above its clear you have your front Mic boost at zero, and you have the front Mic capture OFF. Hence nothing can be recorded with the front mic with those settings.

But having typed that, I’m not convinced the front mic is your integrated mic. Is there any chance your integrated mic is a digital mic?

I did a search on the ALC272 on the alsa web site , and I obtained this hit: Search results for ALC272 - AlsaProject which indicates an update to the ALC272 in version 1.0.20 of alsa, providing a digital mic capability to record. If your integrated mic is a digital mic, then its possible you need at least 1.0.21 of alsa for this to work.

I also note that there are many model options applicable to an ALC272 that can be forced, if the alsa auto probe of the ALC272 did not work at boot for 1.0.21 of alsa (fro the HD-Audio-Models.txt file) but none for 1.0.18 of alsa.

Ergo, I think you should try an update of alsa to 1.0.21.

To update to 1.0.21 of alsa, I recommend you go to YaST > Software > Software Repositories and disable your CD/DVD as a repository. Change your “openSUSe-11.1 Update” repos, OSS repos, and Non-OSS repos to a priority of 110. Close YaST. Then with our PC connected to the Internet you open a terminal/konsole, type “su” (enter root password when prompted) to get root permissions, and then copy, paste, and execute the following:

zypper ar http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_11.1/ multimedia
zypper install alsa alsa-docs alsa-tools alsa-plugins alsa-utils alsa-oss alsa-firmware alsa-plugins-pulse libasound2
zypper rr multimedia
zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1_Update/ multimedia
zypper install alsa-driver-kmp-pae
zypper rr multimedia

select Yes to changing vendor. After installation complete, restart your PC and test.

@oldcpu: Thank you. I guess that the mic problem is pretty much solved for me.

Here is what i did in addition to instructions in previous post:

I installed skype and in the first run the mic actually worked:)( after some volume control clicking and arguing with skype’s auto adjusting of volumes )

The only “problem” that remains is PulseAudio daemon, which crashes with a message mentioning “cpu is overloaded”, so I can’t use any application that eats up too much CPU time ( on this computer it means no browsing etc. ), cause the crash mutes the mic and kills skype after the call is finished. But restarting skype reenables the mic.

Great! Did you end up updating alsa to 1.0.21 ?

Sorry to read of the stability problem.

Out of curiousity, if you did update alsa, what is the output of:
**rpm -qa ‘alsa
**

Unfortunately I can not help with Skype problems as I never use that software.