No sond

On my new system i install 64 bit ver. suse 11.3
In Kmix i see only HDA NVidia
Seems HDA Intel -5 Series/3400 Series Chipset High Definition Audio not work!
It is report of s.m.a.r.t script-

Start Yast - Hardware - Sound. If both devices show up, set the right one to be the primary one. On next login you should be OK.

Thank you for advice ,but not work
Both devices not work
I try to use NVidia whit HDMI kable,but not work…

From the script I note a 64-bit openSUSE-11.3 with the kernel and the 1.0.22/1.0.23 alsa, on a Gigabyte H55M-D2H motherboard, with an ALC887 hardware audio codec.

The script indicates these sound devices recognized :

!!Soundcards recognised by ALSA

 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfbff8000 irq 29
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfaffc000 irq 17 

but the mixer output looks bad:

!!Amixer output

!!-------Mixer controls for card 0 [Intel]

**amixer: Mixer load hw:0 error: Invalid argument**
Card hw:0 'Intel'/'HDA Intel at 0xfbff8000 irq 29'
  Mixer name	: 'Realtek ALC887'
  Components	: 'HDA:10ec0887,1458a102,00100302'
  Controls      : 40
**amixer: Mixer hw:0 load error: Invalid argument**

There are also a few errors in the !!ALSA/HDA dmesg output at the bottom of the script page, but I don’t have the expertise to understand them.

I tried surfing google on “H55M-D2H alsa” and found others with the problem. Some Fedora users found replacing alsa with oss worked, but that is rather drastic and I recommend avoiding that if possible.

I searched the alsa web site to see if I could find any recent updates to the alsa driver for the ALC887 and I could not.

I searched bugzilla to see if I could find an openSUSE bug report on this, and I could not.

Anyway, despite my failure in searching, I recommend you update your alsa applications (including libasound2) per the wiki guide here: SDB:Alsa-update - openSUSE Yes, that guide needs updating, but its philosophy applies still. Install alsa-driver-kmp-desktop for your kernel, and also update all of your alsa apps and libasound2. Double check to see if those alsa apps updated. If they did not, then you likely made a mistake.

Reboot and test.

If that does not work write a bug report on openSUSE-11.3 component “sound” and describe in that bug report your problem (there is guidance here for writing bug reports: ). Do not bother referencing this thread as the openSUSE packager (who is also an alsa driver developer) will not read a forum thread. Attach to the bug report a new generation of the diagnostic script which creates an alsa-info.txt file, after running:

/usr/sbin/ --no-upload 

Then watch the bug report every day or two, and answer any questions from the openSUSE packager. When you answer a question, be certain to clear the “NEED INFO” flag on that bug report.

Good luck.

Now I make This :
in /etc/modprobe.d/50-sound.conf i put “#” infirst line "options snd slots=snd-hda-intel,snd-hda-intel "
and replace whit “options snd-hda-intel model=generic”
and now a have sound ,but it is temporarily decision because it not provide full use of resource

I’m glad to read you made some progress. Still, I recommend you continue and write the bug report ! That will get the attention of an alsa sound driver developer (who is also the openSUSE sound packager) and if any one can solve this problem, he can.

I took a look at the HD-Audio-Models.txt and no where could I find reference to the “generic” model option.

I note from this thread a user with an ALC887 who got sound working (in a limited fashion) by using the “generic” model option. They also tried other options with similar results.

#options snd-hda-intel model=generic #headphone and webcam mic don't work
#options snd-hda-intel model=targa-2ch-dig #headphones and webcam mic doesn't
#options snd-hda-intel model=medion-md2 #headphones and webcam mic don't work
#options snd-hda-intel model=acer #headphones and webcam mic don't work
#options snd-hda-intel model=auto #headphones and webcam mic don't work
#options snd-hda-intel model=acer-aspire #headphones and webcam mic don't work
#options snd-hda-intel model=lenovo #headphones and webcam mic don't work
#options snd-hda-intel model=targa-dig #headphones and webcam mic don't work
#options snd-hda-intel model=3stack-dig #headphones and webcam mic don't work
#options snd-hda-intel model=6stack-dig #headphones and webcam mic don't work
#options snd-hda-intel model=3stack-6ch #headphones and webcam mic don't work
#options snd-hda-intel model=3stack-6ch-dig #headphones and webcam mic don't
#options snd-hda-intel model=6stack-dig-demo #headphones and webcam mic don't

I note in the HD-Audio-Models-txt file these options for the ALC882/883/885/888/889, but none of those are the ALC887 which is what is in place in your pC.

  3stack-dig	3-jack with SPDIF I/O
  6stack-dig	6-jack digital with SPDIF I/O
  arima		Arima W820Di1
  targa		Targa T8, MSI-1049 T8
  asus-a7j	ASUS A7J
  asus-a7m	ASUS A7M
  macpro	MacPro support
  mb5		Macbook 5,1
  macmini3	Macmini 3,1
  mba21		Macbook Air 2,1
  mbp3		Macbook Pro rev3
  imac24	iMac 24'' with jack detection
  imac91	iMac 9,1
  w2jc		ASUS W2JC
  3stack-2ch-dig	3-jack with SPDIF I/O (ALC883)
  alc883-6stack-dig	6-jack digital with SPDIF I/O (ALC883)
  3stack-6ch    3-jack 6-channel
  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
  6stack-dig-demo  6-jack digital for Intel demo board
  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
  acer-aspire	Acer Aspire 9810
  acer-aspire-4930g Acer Aspire 4930G
  acer-aspire-6530g Acer Aspire 6530G
  acer-aspire-7730g Acer Aspire 7730G
  acer-aspire-8930g Acer Aspire 8930G
  medion	Medion Laptops
  medion-md2	Medion MD2
  targa-dig	Targa/MSI
  targa-2ch-dig	Targa/MSI with 2-channel
  targa-8ch-dig Targa/MSI with 8-channel (MSI GX620)
  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
  lenovo-101e	Lenovo 101E
  lenovo-nb0763	Lenovo NB0763
  lenovo-ms7195-dig Lenovo MS7195
  lenovo-sky	Lenovo Sky
  haier-w66	Haier W66
  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
  6stack-dell	Dell machines with 6stack (Inspiron 530)
  mitac		Mitac 8252D
  clevo-m540r	Clevo M540R (6ch + digital)
  clevo-m720	Clevo M720 laptop series
  fujitsu-pi2515 Fujitsu AMILO Pi2515
  fujitsu-xa3530 Fujitsu AMILO XA3530
  3stack-6ch-intel Intel DG33* boards
  intel-alc889a	Intel IbexPeak with ALC889A
  intel-x58	Intel DX58 with ALC889
  asus-p5q	ASUS P5Q-EM boards
  mb31		MacBook 3,1
  sony-vaio-tt  Sony VAIO TT

Again, my recommendation is to try the alsa update, followed by (or before raising) the bug report.

I update alsa en it works full channel support !Tanks

Great news !! Glad to read it.

Have a Happy New Year.

I have to add a comment here: with the same hardware chipset as @OP I had sound running ok on a fresh install of 11.3 but sound does not work anymore after applying the updates. There is definitely some bug.

Same hardware is a Gigabyte H55M-D2H motherboard ? If so, then I recommend you write a bug report on 11.3 component sound. There is guidance here: openSUSE:Submitting bug reports - openSUSE . You can use your openSUSE forum username and password to log on to Bugzilla.

After 10 days I have soud but no kmix control of device!
My bug report:Bug 661949 Submitted – No sound in Intel ACL 887 at MB H55M-D2H

Good on ya for raising the bug report. Its now a matter of waiting to see how the SuSE-GmbH sound packager responds.

Same hardware is a Gigabyte H55M-D2H motherboard ?

No. ASUSTeK P7H55-M PRO with Intel(R) Core™ i3 CPU 530 @ 2.93GHz. Device: pci 0x3b64 “5 Series/3400 Series Chipset HECI Controller” (that’s the one OP mentioned).

Anyway: in my case it seems to be a permissions problem. Adding the user to the group ‘audio’ solved the problem. This was common practice back in 11.1 but I thought this has been fixed long ago.