no shutdown with opensuse 12.1


I have a Macbook Pro 7.1 with an intel chip and nvidia graphic drivers. I had shutdown issues (such as the screen flickering several times before shutting down) with opensuse 11.4, now, after installing 12.1, I see that the laptop simply does not shutdown. It flickers continuosly for minutes and does not shut down. I have added Nvidia respos while upgrading the system. Can someone help me resolve this ?

Thanks in advance.


On 11/23/2011 10:26 AM, linuxnewb wrote:
> Can someone help me resolve this ?

i’m pretty sure this is a hardware specific issue…

-open an x-terminal (you didn’t say, but if you had said you were
running KDE, i would have said: open a ‘konsole’)
-log in as root
-type in and enter

shutdown -h now

does that work ok? (ok, meaning smoothly and without screen flicker?)

yes–i know that is not a suitable fix, but it might work until the Mac
Hardware Owner/User and Linux Guru come by and stumbles into your
miss-named thread…

and, next time you boot add this to the “Boot options” on the first
green screen during boot


that might work to help shutdown, but it might also greatly increase
fan noise, or CPU temp, or battery use, or all of those and more…

report what happens (does it at least ease shutdown…if so i have
another trick you can try–while waiting for the Mac Guru to see s/he
should be looking inside this missnamed thread)…

wish you had written “Macbook Pro 7.1, no shutdown with 12.1”?? :slight_smile:


I had the same problem, albeit my laptop is a Toshiba with an ATI driver.
I managed to get the ‘idiot’ to switch of completely by going into ‘desktop personal settings’ and changing the ‘Login’ section ‘shutdown’ and changing the “Halt” box, from halt, to poweroff.

I am not an expert but it worked for me!


Dear Denver,

Sorry, I jut was in a hurry to report it and did not much on the title of the thread. YesI use KDE. The command line shutdown works smoothly and swiftly. But graphic way does not. I am hesitant to add acpi=off options seeing the warnings. I will try and report soon.