No screens found

I previously used 11.1 with KDE 3.5. Since I have /home on a separate partition I decided to install 11.2 from scratch to avoid any conflicts with KDE 4 installing. No problems on first reboot and some updates were installed. Now at each boot I’m dropped into text login. If I try <startx> I get <no screens found> and /var/log/Xorg.0.log gives <screens found but none have usable configuration>
However if I add vga=952 at the boot screen (for a 1280x800 laptop) I get into graphical login and everything works well (yes even KDE 4).
Below is an snip from /etc/X11/xorg.conf.
Could someone help me sort the problem?

Section “Monitor”
Option “CalcAlgorithm” “XServerPool”
DisplaySize 305 230
HorizSync 30-52
Identifier “Monitor[0]”
ModelName “1280X800@60HZ”
Option “DPMS”
Option “PreferredMode” “1280x800”
VendorName “–> LCD”
VertRefresh 50-60
UseModes “Modes[0]”

Section “Modes”
Identifier “Modes[0]”

Section “Screen”
SubSection “Display”
Depth 15
Modes “default”
SubSection “Display”
Depth 16
Modes “default”
SubSection “Display”
Depth 24
Modes “default”
SubSection “Display”
Depth 8
Modes “default”
Device “Device[0]”
Identifier “Screen[0]”
Monitor “Monitor[0]”

Section “Device”
BoardName “Framebuffer Graphics”
Driver “fbdev”
Identifier “Device[0]”
VendorName “VESA”

You have two issues.

If vga=952 helps, add it to /boot/grub/menu.lst, like this:

kernel /vmlinuz- root=… splash=verbose showopts vga=952

Then reinstall grub, by saying, as root, something like this:

grub-install /dev/sda

(There are other ways also.)

The graphics card’s driver probably is not installed, the default one (a bad one) is active. Find out what card you have, and install the appropriate driver. Installing driver for nvidia cards is very easy. Not so for other cards. Look in Yast -> Hardware -> Hardware information to see what graphics card do you have, and what is its current driver.

Grub does not need to be reinstalled if the vga parameter is changed. The vga kernel command is being used by the vesa framebuffer driver (“vesafb”) compiled into the kernel. It has nothing to do with X. Also, fyi the vanilla grub script grub-install is not supported on openSUSE; that script will simply run the grub shell making a batch call from /etc/grub.conf - which is created by YaST Boot Loader.

Re the xorg.conf file: It is calling the “fbdev” framebuffer driver. Try renaming the file to xorg.conf.mybackup and rebooting without xorg.conf. The new X server is written to do detection and configuration on-the-fly (although there are times when this does not work, the fallback being to again use xorg.conf which is still supported). The file /var/log/Xorg.0.log will tell you which driver it tries to use. There are open source drivers for Intel, Nvidia, and ATI devices, although the latter two do not support all resolutions and device features.

As already suggested, you may have a graphics device for which a driver needs to be installed; these commands as root should tell you what it is:


hwinfo --gfxcard

You probably will need to install the hwinfo package to run the second command.

Thank you both for your help, much appreciated.

Dumping Xorg.conf into a backup file solved the boot into text problem, but at 800x640. Major panic here when I found an empty /menu.lst file. Then found I could edit using Yast>systemconf>bootloader, and fixed the display problem.

Then I tried <more …/menu.lst> as root in the Konsole, and of course it was all there. But I have never been presented with an empty file before when looking at /boot files as normal user. Seems a silly change from the days of 6.xx and 8.xx which I learnt on. Obviously one needs to change things as root, but one ought to be able to check situations easily as user.

Thanks again.


Seems you got it straightened out then, terrific. And yes, the files under /boot (and associated grub files elsewhere) have been read forbidden to users for quite a while, IIRC as a security provision.