No scan results from WLAN RTL8187b with Suse 11 64Bit

this thread is a fork from the thread “WLAN Stick RTL8187b with Suse 11 64Bit”
Quoted below are my original post and Larry’s reply

Hi all,
I seem to have a closely related problem with my wifi configuration, thus I post it in this thread. I hope not to confuse the current issue. If needed I can start a new thread.

My wireless interface looks properly configured, as well as drivers and firmware, but I get no results from scans.

I’m using OpenSuse 11.0 x64 , kernel version

lsusb returns:
Bus 001 Device 002: ID 0bda:8189 Realtek Semiconductor Corp. RTL8187B Wireless 802.11g 54Mbps Network Adapter

dmesg | grep 8187 returns:
usb 1-4: Product: RTL8187B_WLAN_Adapter
phy0: hwaddr 00:15:af:cc:9a:0e, rtl8187 V0 + rtl8225
usbcore: registered new interface driver rtl8187

iwconfig gives for the wireless:
wlan0 IEEE 802.11 ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thrff Fragment thr=2352 B
Encryption keyff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

But running iwlist scan returns:
wlan0 No scan results

I initially had a pb with the driver, and first made unsuccessful attempts using ndiswrapper, but I solved it, following this helpful thread, with the compat-wireless package.
Now I load the driver at startup using modprobe (as shown with hwinfo --wlan)
Driver Info #0:
Driver Status: rtl8187 is active
Driver Activation Cmd: “modprobe rtl8187”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #38 (Hub)

There is no switch to enable/disable the antennae, and the wifi led is on. However, I’m wondering whether the wireless card really sends radio signals.

Any idea ??
Thanks in advance for your help.

Re: WLAN Stick RTL8187b with Suse 11 64Bit
Have you run ‘iwlist scan’ as root or as a general user? The
difference is whether it does an active scan or if it just returns
left-over stuff.

What does the command ‘dmesg | grep wlan0’ show?

FWIW, you should have started a new thread.


Thanks for your reply Larry.

I do run ‘iwlist scan’ as root.

Running the command ‘dmesg | grep wlan0’ returns
ADDRCONF(NETDEV_UP): wlan0: link is not ready

Which processes should I link ?

Hiranyaka wrote:
> Thanks for your reply Larry.
> I do run ‘iwlist scan’ as root.
> Running the command ‘dmesg | grep wlan0’ returns
> ADDRCONF(NETDEV_UP): wlan0: link is not ready
> Which processes should I link ?

What kernel are you using and where did the RTL8187B code come from?
Your ‘dmesg | grep 8187’ output seems to be missing some lines. Mine shows

rtl8187: 8187B chip detected. Support is EXPERIMENTAL, and could
damage your
phy1: hwaddr 00:11:6b:3e:c4:0a, RTL8187BvB(early) V0 + rtl8225z2
usbcore: registered new interface driver rtl8187

On your device, the phy1 line should differ a little, but not by as
much as yours does. AFAIK, all 8187B devices use the rtl8225z2 radio


I’m using kernel version
The TRL8187B driver came from a compat-wireless package, thus it’s not the native one (which I couldn’t find on my version, although it should be included and working, I suppose).

Do you mean the rtl8225z2 driver should already be present with this kernel ?

No, RTL8187B will not work with the kernel. It was not included in the
mainline kernel until 2.6.27.

I have no idea what is in compat-wireless, but you are not getting the
output I would expect for an RTL8187B.


Hi, I posted this update on the thread I was previously active on. Thought it wouldn’t do any harm here either.

I don’t mind telling you I spent hours trying to get this off the ground and the most frustrating part was second-guessing myself as to whether I can read and type settings correctly as I was encouraged to think this was my fault…

Copied from the other thread…

Not completely sure how useful this update is but here goes...

Having had one too many kernel Oopses, I uninstalled the compat-wireless package.

I then went out and spoke to a very helpful guy in my local PC World (the shame of it, I know...) and he told me the belkin usb dongle had an rt73 compatible chipset. I bought one, downloaded the firmware (via Yast) installed, left the previous connection I'd set up in tact and up came my wireless network, couldn't have been easier...

The reason I'm not sure how useful this post is because as a result of the above I am led to conclude that either 1) There was something else installed in my system conflicting with the drivers provided in compat-wireless or (2) they're not quite there yet... I posted this update as I spent hours checking and double checking every aspect of my configuration as I thought the drivers were working. I hope this will save others those hours...

The belkin usb adapter was €30 in my local PC world. much cheaper than the time I spent even if it would be 'nicer' to use the on board adapter...

I’ve had the exact same issue with my RTL8187b device on OpenSUSE 11.0 64 bit.

I downloaded the latest compat-wireless drivers, and after compiling and installing it worked! I finally have wireless on my laptop! And yes…I was going nuts trying to get it working.

There is one issue I’ve seen…so use as you see fit. WEP or an open system will probably work fine…WPA seems to have this issue:

I’ve been able to successfully connect using WPA…but after a suspend and resume the connection can’t be re-connected…I get the following in the dmesg.

wlan0: authenticate with AP 00:0f:66:d5:42:7d
wlan0: authenticated
wlan0: associate with AP 00:0f:66:d5:42:7d
wlan0: RX ReassocResp from 00:0f:66:d5:42:7d (capab=0x5 status=0 aid=8)
wlan0: associated
wlan0: disassociating by local choice (reason=3)
wlan0: deauthenticated

Does the compat-wireless come included in the DVD iso? or do I need to open it up and slipstream that package in the iso b4 burning to DVD? Also will it work on the rtl8187B that have this ID:

Bus 007 Device 003: ID 0bda:8197 Realtek Semiconductor Corp. 

The compat-wireless package backports the latest drivers from wireless-testing to older kernels. There is no way it could be on the CD or DVD. You will need to download the package (use Google to find it) and compile it to get that code.


That’s gonna throw me in a catch-22 there since there are no free ports in the wired side of the router here in my mom’s house.

black-leopard wrote:
> That’s gonna throw me in a catch-22 there since there are no free ports
> in the wired side of the router here in my mom’s house.

Can you temporarily disconnect one of the machines?