No .rpm for TrueCrypt?

I’m new to OpenSUSE, just installed yesterday, but not new to Linux (2 years or so). I’m trying to install TrueCrypt on my new installation of OpenSUSE 11.1. I’ve downloaded the appropriate .tar.gz from their website, but the file inside doesn’t seem to be an .rpm. I’ve extracted it multiple ways, and tried renaming it to an .rpm, but when I try to install it it says it isn’t one. However, opening the file in a text editor, the first section of text seems to indicate that is is an .rpm file.

Has anyone else had this problem? Is this something TrueCrypt screwed up on, or is it something bizarre happening on my end? Or maybe something blindingly simple.:\

I’ve never installed TrueCrypt before, but from what I have seen is the file inside the tarball is a script file. Did you try running the script ?

Maybe try as root:
bash truecrypt-6.2a-setup-opensuse-x64
or something like that.

Agh, I could kick myself. Yeah, that worked. Wish they wouldn’t call it an .rpm on the site.

Thanks very much.