No 'Record macro' in Libre Office

As in title, I’m using Libre Office on my OpenSuse 11.4 and there is no ‘Record’ option under macro.
I have search the net and some suggest this solution - to check box ‘Enable experimental features’ in Options.
I did that but still no Record Macro at all.

Can anyone help?

If this is an important feature for you, you may have to reinstall OpenOffice. Alternatively, try LibreOffice 3.4.2 but, if you cannot find it in the Experimental features, it may not have been implemented yet.

You will need to update to LibreOffice 3.4.2
You can find it in this repository:

Wait a minute!!! Don’t hurry for 3.4.2, it’s still on the “unstable” repo and there are several new issues filled against it!
3.3.3 shows the “Record macro” button under “Tools → Macro” if “Enable experimental features” is selected. Did you restart LibO after enabling them?

I just tested this with installing from
and there was NO “Record macro” function.

Returning to 3.4.2 restored the function.

Thanks a lot for your answers.
It’s not a life-or-death issue, so I can wait for stable version of 3.4.2

Could you please point me to these issues?

I cannot find any openSuSE bugzilla reports for 3.4.2.x, and there are only 4 Linux (20 in all, mostly MS specific) bugs that I can find for LibO 3.4.2 release at After some experimentation I have moved two of my users from to to alleviate specific file import problems. I would be grateful if you could forewarn me of possible problems.

As far as I am aware 3.4.2 has been classed as “enterprise ready” and recommended by TDF, and it is only the OBS builds that are in Unstable. But then the same build was in both Stable and Unstable for some time. If I had problems with the build, I would have tried the rpms.