no ping from linux to windows server 2012 r2

I cannot ping any windows servers or windows clients from within Linux. I can ping internal pings (Linux) to my static ip address which is 192.168.1.32 for device enp5s0, my static wifi address 192.168.1.31 on device wlp4s0, can ping gateway, can ping fqdn/host name, internet up and running. I also have a working samba server (on Linux) which I have as a pdc to allow my management to keep sensitive material. from the windows server 2012 R2 side I can ping the Linux static ip and fqdn as well as the gateway. my distro is opensuse 13.2 with all the latest updates installed.
That’s my setup so here’s the question :-----]]]
When I try to ping windows from within Linux (ip or host name) it resolves to the wifi static ip address which in turn then error’s destination host unreachable.
I am very new to linux (I’m a windows installation guy, yep, that’s me ;—]] ). I have been on this project for about 5 weeks. This is where my windows skills end
Please don’t hesitate to request any additional data, and I would like to thank anyone that can push me in the right direction, Simon

“Destination host unreachable” is an error message with a very specific issue… The machine is unable to function on the network because of a local problem, likely a configuration problem.

You need to start with how your network interface network settings are configured, by DHCP? Usually DHCP will assign working network settings, it’s very rare for DHCP settings to be non-working.

You should also verify your local network interface is working.
One way is to run the following command, which should return your network settings for a localhost and any other network interfaces.
Post the results of the following if you don’t understand the results

ip addr

Although not critical at the moment, you should also post whether your machine’s network settings are still managed by Wicked (which is default) or whether you have switched to Network Manager since you are configuring wireless (and particularly if your machine is a laptop which can move between different WiFi networks).

TSU

TSU, a huge thank-you for letting me have some of your obvious expertise. ok, i have done a little research and these are the details that i believe you need from me. They are:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: wlp4s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether f4:f2:6d:d6:ac:59 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.31/24 brd 192.168.1.255 scope global wlp4s0
valid_lft forever preferred_lft forever
inet6 fe80::f6f2:6dff:fed6:ac59/64 scope link
valid_lft forever preferred_lft forever
3: enp2s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether fc:aa:14:82:80:70 brd ff:ff:ff:ff:ff:ff
4: enp5s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether c4:6e:1f:01:b7:69 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.32/24 brd 192.168.1.255 scope global enp5s0
valid_lft forever preferred_lft forever
inet6 fe80::c66e:1fff:fe01:b769/64 scope link
valid_lft forever preferred_lft forever

[size=3]
You will notice that device ‘enp2s0’ is down. This is deliberate. Why?. It was recommended from knowledgeable people like you, that as a starter i should only use 1 ethernet card for configuring Samba with, and that it should be a static ip address, hence not using DHCP for device ‘Enp5s0’.

from your reply it appears to be like a windows scenario of no route to host?. Could this be a firewall issue (my firewall skills are not that great, sorry for that)?.

yes, i am still using wicked from within yast. i have not switched to network manager at any stage of the installation.

yes, i am using WiFi for my internet access, and i have no issues to report there.

Hope i have interrupted your questions and have given you the correct details. TSU, you have a great day now, Simon

[/size]

First,
When you post code or code results (like your ip addr), you should place them within the “code” tags… If you’re using the web form, it’s the hash button (#). That will remove all formatting and bring attention to its info.

If you’re running network services (like SAMBA shares) on your machine, then yes… you will want to make your machine available on a fixed (not necessarily static) IP address to improve reliability (If your IP address changes, then any locally cached information on another machine will need to re-discover your machine and update).

But, a static address (manually configured) is the “hard” way to accomplish your goal, the “better” way is if your DHCP server supports reserved leases, then you only need to create that reserved lease on your DHCP server so that any time your machine with it’s non-changing MAC address contacts your DHCP server, your server will recognize the machine, find it on its table of reserved leases and issue the same IP address for that lease.

The advantage is that you cannot(or at least nearly so) make any mistake configuring a machine when a machine is configured by DHCP.

From what you posted, I can also see that you have your wired patch cable plugged into your machine. Physically unplug it. When you have multiple network interfaces connected to different physical networks but using the same network id (192.168.2.0/24), unless you have also assigned a different priority to each interface you will likely find packets leaving your machine on the wrong interface (TCP/IP is a 2-way protocol, communication between any 2 machines assume that they’re using only one network interface on each machine unless you do something highly unusual).

After unplugging your wired interface, you <may> need to review and verify your network services are still running, and assigned to the <correct> network interface which is of course your wireless.

Fix those, reboot your machine (or, possibly restart network services) and see if that fixes your problems.

TSU

People will notice I posted an incorrect networkid in my previous post (corrected in this post in red).

TSU

…and assigned to the <correct> network interface which is of course your wireless.

Hello TSU. Thank you for your continued support.

ok, I understand all of your info. apart from the line listed above. Not sure how to approach this. Would you mind expanding on this a little bit please?.

My network services xinetd have been enabled as they had been disabled. I enabled services and server services to on.

TSU, there’s no rush on this project. I have 2 months (approx.) to get most of it up and running. All this is being done in a lab, completely separate from the production servers etc.

Thank-you very much, simon

Network services are generally speaking any “server” applications you have running on your machine.
For example the following (not intended to be complete)

SAMBA
Any other kind of file sharing services, like FTP, HTTP
DNS
DHCP
Any kind of mail server
Any kind of web server
Any kind of Internet proxy
Any kind of firewalling services for your network
If you have network security or directory services installed like LDAP

In other words, typically your machine provides to other machines in your network.
Each service might be configured to provide its functionality on a specific network interface, or maybe multiple or all interfaces. If any these apps were set up to function on your wired interface only, they need to be modified to work on your working wireless interface.

TSU

Hi TSU

Thanks for all your guidance over the last few weeks. I now have a complete Linux wireless server. I have Samba, internet and a canon network printer. Most of the work I did was on a windows server, so I doubt if anyone on a Linux forum wants to hear about windows ;----]]

cheers, its Friday night and time to hit the lager !

Glad you got it all worked out…

TSU