No picture in openSUSE 11

Hi there!
I just finished installing opensuse on my asus g1sn laptop, and I don’t get a picture when trying to boot to opensuse. I can see my mouse pointer though, and move it, so it shouldn’t be out of range or anything along those lines. Booting into failsafe works fine, but if I try to change my resolution with sax2 in failsafe I get the same problem. Just a black screen with my mouse pointer scurrying around.
Any suggestions are greatly appreciated, and feel free to ask if you need more information.

Did you try to use sax2 -r?
Also what I did on my laptops: I knew my resolution (e.g: 1280x800), I set it up on sax2 BUT I didn’t use TEST, just SAVE and reboot the computer.

Thanks for the reply!
Tried the save and reboot, didn’t work.
Also tried it with sax2 -r, didn’t work either.

What are the specs of video card?
I will do in this way:
as root
#zypper se name_of_video_drivers
#zypper rm the_result_of_previous_qeury

The OS should be able to re-detect the video card and install generic vga drivers. After that you can try to install specific to your video card drivers.