no permissions to run any user scripts or executables

So basically, i have absolutely no permissions to execute any of my own compiled binaries. Just keep getting a “Permission denied” message if i just run it and “cannot execute binary file” if i run sh myexecutable

I have to add sh to run even a simple shell script which is also super strange, and i have absolutely no tab completion other than for the main system files. Even in the current directory i have no tab completion on shell scirpts that have .sh extensions unless I type sh

This is a brand new install in case that makes any difference.

chmod +x

It might still not do what you want. So try:


That’s because the current directory is not on your path. Put the script in your “bin” directory and give it execute permissions, and it will probably work (unless there are script errors).

OK I’m going to add the fact that I’m a professional developer and have been running linux exclusively for almost 15 years. I’m no stranger to making completely brainless mistakes but file permissions and knowing how and when to specify the current directory are not my problem

Paths are not (perhaps I should say SHOULD NOT BE) the issue either as I have all the necessary dev directories in PATH.

There are no script errors. all the shell scripts have and continue to execute perfectly on RHEL, fedora and arch boxes.

And finally, the executables also have and continue to run perfectly on RHEL, fedora and arch boxes.

Then check whether the file system has been mounted with the “noexec” option.

Maybe I should also add that if I try to run/debug from within nsight (thats the nvidia cuda IDE) I get

/bin/bash: /pathTo/executable: Permission denied
/bin/bash: line 0: exec: /pathTo/executable: cannot execute: Permission denied


I’m starting to think I must have really screwed something up because I also had this strange conflict with evdev, synaptics and libinput and had to remove libinput to get my touchpad working. Ao maybe I was trigger happy selecting packages and installed a bunch of pointless stuff that has caused some strange conflict problems.

So that wasn’t the problem but you did point me in the right place so thank a million.

I checked the mount parameters and the partition I use for dev wasn’t mounted with user_xattr.

thanks again.