No pdf shuffler any more

I used to scan in documents and saved them as .pdf files. Then I used pdf shuffler to create a single pdf document out of these scans (merge pdf files). Now with the upgrade to 15.4 pdf shuffler does not exist any more. I tried to install it as .tar.gz file but it needs PyGTK (version 2.10.0 or higher) files and this does not seem to be available for openSUSE. Now my question is what is a simple software where I can merge pdf files which runs on Leap15.4?
Any help is appreciated!

Try pdftk.

I use the sidebar with document pages preview in Libreoffice Draw and simply drag&drop pages from one document to the other. Or delete pages. Afterwards choose “Export to .pdf”…

Thank you, theo, I have tried 2 other pdf tools which are available here and like pdftk they want to set up 15 more repos several with “SLE-15-SP*:/GA/” (replace the * with 1, 2, 3 and 4) and always there on one of them it stops with an error message. Then I have to clean up all the other repos it has installed. It is quite hopeless is ther no pdf tool in the official list which just installs? I would think other people have to scan in their invoices and create files which need to be send to their accountant too!

Then you tried the one-click install. Do not use that, but use another way of installing it. The one-click is :

Package: poppler-tools has “pdfunite”.

pdfunite ./a.pdf ./b.pdf result.pdf

pdftk is available in standard repository.

zypper install pdftk

You have not said what other tools you tried.

pdfarranger is the best successor of pdf-shuffler. Same functions, just better.

@fuerstu, please do not use the 1-click when you want to try this one.

Yep, PDF Arranger as recommended by another poster.

Good morning everyone and thank you for all your replies. First arvidjar, the other two packages were pdfsam and pdf arranger. Each of them would download about 15 repos including those SLE repos etc and none worked with the “one click install”. Now all of youwrite about not using this feature but without explaining how to install these packages. THere is the “expert download” but I am no expert and I remember trying this once and then when trying to install I got the message that another package was missing and I looked for that and when I tried to install that the message came that another package too was missing and I tried about 5 or 6 times with looking for this package and in what repo to find it and since then I stuck to “one click install”. Zypper se finds pdftk but not pdfarranger which two of you recommend. I can see it with package search in the repo txutxifel but how do I install this without the “one click install” and without dependency mess?
Further what I need must be something used from the GUI since my wife is doing most of the accounts and she uses it most. It seems that pdftk is command line only.

simple-scan will scan multiple individual pages and create a PDF from them all; you can also rotate them if they are not in the orientation you want. No need for single scans; do them all at once.

Thank you john_hudson, I have never used that. However I don’t collect all the invoices and scan them together in the sequence they are needed. However that would be another option. I now managed to install pdfarranger and it looks quite good. However the question I posed yesterday was not answered.*** How do I install software packages without the one-click install*?** As a wrote before I am no expert and I ended up with a dependency mess where I had to give up. Again and again I read in the forum that you should not use the one click install but nowhere have I seen how to do it otherwise. The link hcvv send was just one example where the command zypper in xxx worked and pulled up the dependencies. That means the repo where this package is included is already installed. THe link to the bug report does not help me either. The one-click install is even worse now because some of these 15 repos produce error report and this does certainly undermine the confidence in the whole process. Is there anyone here who can give instructions how to install the software without the one-click install (especially for someone who was stuck in a dependency mess when trying to do this some years ago). Maybe today someone is able to give me more information.

That depends on where the software is. First thing to try is to check if it is in one of the repos you are already subscribed to. E.g. with YaST > Software > Software Management. You then get the Search view. Type (part of) the name you are looking for in the search field and Search. Could be that you need to check the “RPM provides” box when you e.g. know the name of the executable, but not the name of the package. When it is found, great, check the box(es) before the paclkage(s) and Accept. There are of course zypper commands for these actions.

When it is not in the repos you have, you might find it is in another repo. Then first add that repo (using YaST > Software > Repository Management or zypper ar) where the main thing to enter is of course the URI of the repo. (using a good Alias is recommended, because that is easy to use in commands. When the repo is added, the above of course is applicable.
Many recommend then to disable that new repo. Then there will not, by incident, packages be installed from it that you want e.g. from the standard repo. Only enable for a short time when you think you should update the package(s) you have from that repo.

One step further is when you find an RPM somewhere, not in a repo, that can be downloaded. Just install it with zyppr in. When it happens often, you could create a local repo where you gather such packages.

Next step is when a so called tarball is provided. Then you must unpack the downloaded tarball and build it local on your system. As such builds are normally not RPMs, installation is through a script provided with the tarball. The tarball most likely includes a README for details.

As you see many possibilities, not always with good results. But we are here to try to help you with individual software when you provide the details of what you found and where and what you did until you got stuck.

Unfortunately there is no definitive answer, each install case may require a slightly different approach, also user’s here will have their own “favoured” way of accomplishing the task.

The situation is compounded also by the fact that Leap 15.4’s software search function is currently broken and so far no-one has stepped forward to offer a fix.

Taking your example of “pdfarranger” :

I would use search on OBS
and select the package from “Office”
from the “Build Results” section I would select openSUSE_Leap_15.4
from there I would select “Go to download repository”

Take that URL ( ) and use zypper to add and refresh the repository:

zypper addrepo
zypper refresh

Then zypper in the package:

paul@HP255G7:~> sudo zypper install pdfarranger
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 25 NEW packages are going to be installed:
  gtk4-schema libcairo-script-interpreter2 libcloudproviders0 libgstplay-1_0-0 libgstplayer-1_0-0 libgtk-4-1 libharfbuzz-gobject0 libimagequant0 libqpdf28
  libtracker-sparql-3_0-0 pdfarranger python3-cssselect python3-gobject-cairo python3-gobject-Gdk python3-lxml python3-olefile python3-pikepdf
  python3-Pillow python3-pycairo typelib-1_0-GdkPixbuf-2_0 typelib-1_0-Graphene-1_0 typelib-1_0-Gtk-4_0 typelib-1_0-HarfBuzz-0_0 typelib-1_0-Pango-1_0

25 new packages to install.
Overall download size: 7.3 MiB. Already cached: 0 B. After the operation, additional 23.8 MiB will be used.
Continue? [y/n/v/...? shows all options] (y): n

After having established that pdfarranger was installed and working I would disable the newly added repository, only enabling it if I wanted to periodically check for newer a newer version.

There are other ways of achieving the same end, I make no claim to this being the “best” or “definitive” method, other methods may be faster or simpler.