When restarting after shutdown, NO PASSWORD is needed !!! When starting after timeout, password is needed.

Somebody else having had that problem and figured out how to remedy?

Jan Christian

Password for what? Are you logging in in the console, in the GUI, which display manager (which desktop), do you have automatic login enabled?

In short, a one and a half line problem description is seldom enough to raise our mind reading level to the maximum.

Sorry, I should have known better!

In my world, a shutdown is to power off, I realize that my world is too small and too limited! Here comes a hopefully better explanation:

I want to power off and stop all running processes., so I click on the icon at the lower left screen corner getting several options. I choose
*Shut Down’ and the the screen goes black with some icons. I click on Shut Down, and the screen goes all black, no reaction to any key
except ‘power_on-key’.

After some hours, I ‘power on’ the PC, and the PC starts, and without me touching the PC, I am back into where I left (i.e. same screen,
same software ready to be started, e.g. FireFox, ThunderBird, …). Then, after some fiddling around, I want to take a break of more than
5 minutes, and the PC goes - as desired - into hibernation, and I have to login with password (as expected and desired).

System is running Tumbleweed (last update yesterday), passwordless login is not enabled, System is Tumbleweed, desktop is KDE.

I sincerely hope you find the above explanation sufficient.

Best regards,
Jan Christian

First information we now understand is that this is KDE.

It looks that you have configured KDE to hibernate after 5 minutes of no activety and that that works as intended, inclusing it asking you for the user password after starting from hibernation and before the user giveing access to the restored session. So that is all as intended.

But now, you use Shutdown and (confirm that in the screen that is shown then). What this should do is, after the confirmation, you should see your session for a short time, the system then loging out and showing something like the boot splash or the console #1 with the shutdown texts. Then the system should switch off power.

When then the power button is pushed to switch on, the first thing you should see is some splash from the BIOS probably with a logo from the manufacturer. Then it will switch to the Grub screen where you can choose the “normal” sytem to be booted, or some fall back system, etc.

Do you see that or not?

After that the boot splash should be seen, until the login screen comes up (or, when you have automatic login enabled, it should now login without password asking).

What I describe above is much more then what you seem to see. Can you confirm that you see nothing of those shutdown, grub and boot screens?

I usually set my boxes as the OP did. To use a password for system power-on (not after suspend, hibernate or lock screen) I use Yast > User & Group management > Technical options. There you can check/uncheck Automatic login & passwordless login.

True: I see the some options, there is a warning that the system will shut down in 30 seconds, I use the shutdown option, not wanting to wait the full 30 seconds.

Do you see that or not? Yes, yesterday there were 4 options, today 2 (Tumbleweed update in between)

Something shows in a fraction of a second, then i am logged in. According to Yast, I have no automatic login.

No, ref above.

Best regards,
Jan Christian

Nevertheless it looks very much like an automatic login. Can you show us what YaST show to you?

A screen shot can be uploaded to are right, it is an automatic login, but - as I interpret it - it is not passwordless. Further, I am pretty sure that I never opted for any passwordless login anywhere. And - as I see it - it is inconsistent that I can enter the system without a password when starting up my PC, but have to supply a password when the system goes into hibernation due to 5 minutes’ inactivity.

Best regards,
Jan Christian

Ok, I assume you have now unchecked that automatic login (or left it as it is, but you now understand that it is switched on.).
And yes, “automatic” means that the user mentioned there is logged in direct after boot and of course without password provided. When a password would be needed, there is no “automatic”.

I can of course not know (being not clairvoyant) why it is on. It could be that you checked it at system installation (when the possibility is offered), not really understanding at that moment what it is about. But that is all guessing.

And about that inconsistency. It might look so for some people. But in fact these are two very different things.

  • Automatic login of a certain user is a feature that can be switched on in the Display Manager. And it is a system configuration (remember you need to change that as root). So it is the system manager that creates it (maybe on request of the user).
  • Screen locking (after how many minutes, and all other details) is configured by a user for himself (for security reasons, going to the toilet without leaving the session open to passers-by) in his desktop environment (another user on the same system may have it different). It is configured in the desktop (and might function different in KDE, Gnome, etc.). If a password is needed to unlock the screen is part of the DE policy for this (maybe configurable by the user). Remember that every program can ask for a password, hash that using the known algorithm and compare the result with the encrypted password as stored on the system).

So yes, it might look inconsistent, but in the end it is the result of inconsistent configuration of the two mechanisms.

BTW, as a by-product, please understand for the future that saying things like “According to Yast, I have no automatic login.” or any other conclusion you may have come to, do not make much sense to us. We want to see the original computer facts and then come to our own conclusions.

This is from the Help button on that screen:

Auto Login
By setting Auto Login, skip the login procedure. The user chosen from the list is logged in automatically.

Passwordless Logins
If this option is checked, all users are allowed to log in without entering passwords. Otherwise, you are asked for the password even if you set a user to log in automatically.

A bit confusing choice of words. How would the system login the user automatically yet ask the password?

There’s also the advanced settings in Plasma System Settings -> Login Screen (SDDM) -> Behavior. There it doesn’t ask to request for password.

There’s a patch for SDDM to read from sysconfig:

We can see that SDDM doesn’t care about passwordless login, only cares for autologin.

‘Problem’ solved, thanks to everybody ! In hindsight, it was easy ensuring that a PW is required on login: yast > sysconfig editor > display manager > search for password > passwordless login > replace <user-name> with ‘no’.

Henk and other ‘gurus’: Please do a QA on the above.

Jan Christian
PS: I am about to send a message about multiple languages in openSuSE, it may be very confusing.

I will become a bit pedantic as an afterburner.

Whatever your case of the multiple languages is, in all of them openSUSE is written openSUSE. As you can see many times on all the pages of this forum and other openSUSE web sites. Please assume that openSUSE itself knows best how to spell openSUSE.

Also, please next time do not use all caps for your thread title. Many people interpret all caps as shouting. And you probably will not want to shout to people when you want them to help you. :wink:

‘Name ist Schall und Rauch’ (Goethe, Faust ii)
Der Name S.u.S.E. stand dabei als Akronym für Software- und System-Entwicklung

Jan Christian

I am fully aware of that. But when you are still living in those times, then be prepared for more misunderstandings,as well here as elsewhere in life.