No Output to StarTech USB audio

Greetings All,

I have a StarTech USB audio adapter which I have been unable to get output from in Suse.

Pavucontrol allows me to adjust the output to this device, and even shows some signal when playing media. However, no output makes it to the headset/speaker jack of the USB device.
There does not appear to be any issues with playing media to the internal sound card & speakers of the computer.

I booted up a Live Ubuntu disk, the device was recognized, and output made it with no problem.
This leads me to discount a hardware problem.

I’m running Suse 11.4 on a Lenovo Thinkpad T420s.

Any advice would be greatly appreciated.

Thanx in advance.


Can you do a screen print of each of the pavucontrol screens (while playing a song or video with a media player) so we can see what settings you have applied. ie configuration, output devices, playback.

I’m trying to help a user in a different thread who is trying to get sound playback out of BOTH his headsets at the same time (USB and regular) : Sound to multiple output devices with pulse? … you should NOT need a sink for a simple USB headset playback.

Try again with the right links:
By richardrosa at 2011-06-10
By richardrosa at 2011-06-10
By richardrosa at 2011-06-10
By richardrosa at 2011-06-10


In your the pavucontrol Playback Tab, instead of selecting "Simultaneous … " try selecting only the “USB PnP Sound Device Analog Stereo”.

Also, in case we are missing anything, in the “playback tab” for ‘show’ select ‘all streams’.

Selecting the USB in the ALSA control mutes the internal speakers, but no output on USB device. However, VU indicator on the Output devices panel shows output to the device. Donno where this output is going to, but it probably is not the StarTech…
By richardrosa at 2011-06-10


You still have "simultaneous … " selected in the application from which you are playing a multimedia file.

The picture was taken before changing playback device.
By richardrosa at 2011-06-10

Here is the Output Devices tab after selecting USB only:
By richardrosa at 2011-06-10


hmm … its hard to give good advice when the pix are wrong. >:(

You have extra devices that are confusing to me.

With your USB headset plugged in, please run the following diagnostic script and provide the output. DO NOT change your configuration from which you had in the above, as if you do then running the script is pointless as the configuration has changed and that makes this harder.


run that with your pc connected to the internet. Select the SHARE/UPLOAD option. Post here the URL/web address that it give you when the script finishes. Do NOT post the script content here. Just post the website/URL address where the script is located.

Please also provide output of:

rpm -qa '*alsa*'
rpm -qa '*pulse*'
rpm -q libasound2
uname -a
cat /etc/modprobe.d/50-sound.conf

Something else is puzzling me … which is the presence of the "simultaneous … " options. DID you do an edits to ANY sound configuration / pulse configuration files? If so please advise.

Here you go =>

rpm -qa ‘alsa

rpm -qa ‘pulse

rpm -q libasound2

uname -a
Linux #1 SMP PREEMPT 2011-04-25 21:48:33 +0200 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel,snd-usb-audio

u1Nb.bN26Eo2L1+7:Intel Corporation

alias snd-card-0 snd-hda-intel

tGrL.HwZeh6foz16:USB PnP Sound Device

alias snd-card-1 snd-usb-audio


OK, your USB sound device sound is muted. You need to unmute it. Look at this from your mixer :

!!-------Mixer controls for card 1 [Device]

**Card hw:1 'Device'/'C-Media Electronics Inc.     
**  USB PnP Sound Device at usb-0000:00:1d.0-1.2, fu'
  Mixer name    : 'USB Mixer'
  Components    : 'USB0d8c:013c'
**Simple mixer control 'Speaker',0**
  Front Left: Playback 0 **[0%]** -28.37dB] [on]
  Front Right: Playback 0 **[0%]** -28.37dB] [on]
**Simple mixer control 'Auto Gain Control',0**
  Mono: Playback [on]

I know, you are saying “muted - tell me something I don’t know”. :\

I think I can tell you that your USB sound is muted IN YOUR MIXER.

Did you custom create that 50-sound.conf file ?

Were you configuring things in YaST for your USB sound device ?

That is the first time I recall seeing a 50-sound.conf file like that.

I don’t believe I changed anything in the Yast control. I did check the Sound settings to see if the device was detected (it was).

OK, your USB sound device sound is muted. You need to unmute it. Look at this from your mixer :

That makes sense. Any idea how to unmute? I’ve tried every Mixer GUI that is installed. Everyone says that the device should NOT be muted.
I’m unfamiliar with sound card commands, so if you know of one that should work, I’ll give it a try.


Found the magic. GMixer allowed me to unmute the USB. Output is now working!

There are just too many different controls for this sound system :frowning:

Thanx for your assistance.


Good news !

I am curious, now that you have it unmuted, … when you select 'simultaneous … ’ do you get sound out of both the USB headset and out of your speakers at the same time ?

The answer is Yes, once I went through all the various “mixer” panels and got all the sliders and buttons in the right position. I have 5 mixer GUI programs (Mixer, Gmixer, PulseAudio Volume Control, AlsaMixerGui, and Kmix). Each one seems to do something a little different, but unless all the ducks are lined up, no output. GUIs are supposed to make things easier, not more complicated.

I wish I understood how this whole sound system worked a little better :frowning:

Thanx again.