No option to boot into Windows (Leap 15.1)


As you’ll understand from my limited post history, I’m a linux noob. My colleague set up my dual boot system. Or tried.

My issue is that when I boot my computer it goes directly into linux. This is mostly fine but I would like to be able to access Windows at times.

I have found the YaST Boot Loader and under “Bootloader Options” a drop-down menu offers a “Window Boot Manager”. Before I select this and restart my computer, are there any warnings from this community that I should take into account? Can this screw up my access to return to opensuse, where all of my work is located? I’ve not used Windows in a year of having this pc.

Please let me know what information you require from my setup.

As far as I know, you should go to the tab Bootloader Options and check there the box Detect foreign OS (wording maybe different, I have a translation here).

But please wait for somebody to confirm this (and do indeed not use another bootloader before being very certain).

Select whatever you want as default, you will always be offered openSUSE too:

You need to check probe foreign os, like shown in the picture, by karlmistelberger in yast.

Try this first, then save and reboot. Leave all other settings alone for now.

Because as far as I understand it, you already have openSUSE working right ?

Yes, I have been only using openSUSE.

I already had “Probe Foreign OS” checked. So, I should be receiving options when I start my computer, yes?

My concern is that if I change my default boot section I will not be able to return to openSUSE. Any further advice?

When booting grub will wait for input, see “Timeout in Seconds”. Use Up and Down keys to select another entry and Enter to go.

I slowly get the idea that the OP does not get the Grub menu at all.

In his post #1 he states:

My colleague set up my dual boot system. Or tried. My colleague set up my dual boot system. Or tried.

So nobody of the people discussing here, the OP included, have any idea what is done.

But the OP (and only he) can tell us what happens when the system is booted. So please @lwilgrant , tell us step by step what happens when you boot. Specially if you get a Grub menu or not al all.

This is correct. I do not see the Grub menu at all. I just start my computer and it automatically boots opensuse.

  • Open Yast2 > Bootloader, make a small change, undo it and reinstall.
  • Open a console and run the following command:
karl@3400G:~> grep -v ^\# /etc/default/grub|grep -v ^\$
GRUB_CMDLINE_LINUX_DEFAULT="quiet mitigations=auto"

Hi, thanks for the detailed response.

Can you elaborate on what to reinstall? Do you mean that I should reinstall the Yast boot loader?


“The easiest way to configure general options of the boot loader in your openSUSE Leap system is to use the YaST module. In the YaST Control Center, select System › Boot Loader. The module shows the current boot loader configuration of your system and allows you to make changes.”

Hi. Apologies for leaving this off for so long.

I tried the recommended approach from @karlmistelberger, and I still boot directly to Opensuse.

Any other advice for getting the boot menu?

Make sure that the file /etc/default/grub contains the following definitions


(and make sure that each of those parameters is set only once in this file).

Then switch to a virtual console (Ctrl+Alt+F2) login as “root” and do

# grub2-mkconfig -o /boot/grub2/grub.cfg

followed by

# systemctl isolate

what should reboot your machine.

If your system still boots directly into openSUSE without showing any GRUB2 menu then please load the files /etc/default/grub and /boot/grub2/grub.cfg up to and post the link here.

By the way:

Are you UEFI- or CSM-booting?
Do you have secureboot enabled?

If you are UEFI-booting please show the result of

# efibootmgr -v



Followed the first set of commands with no success in getting the menu upon reboot.

First paste from /etc/default/grub:

Second past from /boot/grub2/grub.cfg

According to the Yast 2 Boot Loader Settings “Boot Code Options” tab, I have “GRUB2 for EFI” and “Enable Secure Boot Support” selected, if that answers the questions over UEFI and secureboot.

Third paste from efibootmgr -v output:

Running ‘grub2-install’ will update uefi entries

Note that if you have fast boot on in Windows Linux will not see Windows since it would not be shutdown completely .

Note that you should be able to get to Windows via the UEFI boot menu.

Followed this:

Running ‘grub2-install’ will update uefi entries

When I rebooted, I again had a black screen. Previously, this would eventually lead me directly to Opensuse. The first time returning to this black screen, I had the thought that, perhaps I am just not seeing the menu?

So I scrolled down once and hit enter. This brought me to Windows!

This is good news, however, now when I reboot (still with a black screen initially) I hear a single beep and I am directed straight to Windows. I can no longer access Opensuse, it seems.

Please, if anyone has advice for me, let me know. I have some important files on my linux partition that I stupidly did not back up before playing with this.

To elaborate, after some testing the order of events is:

Boot computer
Black screen
Nothing until I press “Enter”, which takes me to Windows. Scrolling up/down and then hitting “Enter” also takes me to Windows.

Two possibilities

  1. Fast boot is own and Windows thinks it is hibernating

  2. The UEFI is one that insists you use Windows.

You should have a UEFI boot option. Which key to hit depends on the Hardware. Consult the Docs for the Machine/Motherboard. The options may show at the bottom of the Machines splash screen for a short time.

Please show the output of

# lsblk -f

Run the command as „root“ in a console (Ctrl+Alt+F2) and show the complete output; i.e. include the command line you used, the output and the next (empty) prompt and enclose all in CODE tags (# button in the tool bar of the forum editor).

Sorry! Just saw your latest posts.

If you cannot boot into your installed openSUSE system boot your installation media, start the rescue system and issue then the command shown above.