No Operating System

Hello , can anyone offer a solution to this , I have been trying to install openSuse 11 on a IBM X41 , previously the machine was running 10.3 no probem. Now I install and all appears good , but when I restart it it just says ‘No operating system’ I have no other drives or storage devices attached and it is trying to boot from the correct disk. I do a Grub fix using the install disk and still the same happens. I have installed Suse 11 on 5 other machines (all desktop IBM’s) with no problems.
The Laptop had some awful IBM software on it that it used for rescue and recovery for windows before , could this be causing a problem ?
Any Ideas ?


  • mat271180 wrote, On 07/08/2008 12:46 PM:

> The Laptop had some awful IBM software on it that it used for rescue
> and recovery for windows before , could this be causing a problem ?
> Any Ideas ?

That’s probably it, it is often a hidden partition and grub installs in the wrong one. Can you boot the installed system when you boot with the install DVD inserted?


What happens when you use from the install cd the option boot from hard drive (local drive)
can not remember the exact name.
If this fails too, in my opinion for one reason
or the other the install fails again


Hello ,

Thanks for the help
Yes if I run the install disk and use the boot from local disk it still just says ‘no operating system’.
As Busksfled said I think it is this IBM thing that is causing the problem. The disk is 40GB and when I go into the install program and look at the partitions it can only see 38 GB in total, 2 GB is not seen , I bet it is looking inside this partition for its boot stuff.
I remember when I got the laptop new it had windows ‘obviosly’ and there was some kind of ‘encrypted’ disk space on it for keeping all you top secret documents in , needles to say I never used it. It may be this.

Any idea how I can remove a partition YASt can not even see , will Fdisk do it ?

I am even considering getting a new disk but seem stupid when the one in the machine it technical ok.:eek:
I just tryed to reinstall 10.3 and it does the same , it seem to be not happy since I wiped windows.



if you really don’t need it, try disabling the system recovery stuff in the BIOS and run a partitioner of your choice.


Hello ,

Thanks , I was not aware I could do that , I’ll have a go.

I had the same problem on a Thinkpad T-23 without the recovery partition. After a lot of research I believe the problem is that openSUSE 11.0 does not install the grub bootloader in the MBR. There is an option to do this during installation. I am going to try that to see if it fixes the problem.

Hello , yes seems to be a Think pad thing , I have got it working but I am not sure why its working !!
I installed as a LVM not a partitioned setup.
Strangely this works , but the ‘boot’ is still in a partition so I don’t know why it works , is it not just the same as partitioned setup ?

I totally admit I do not really understand what I am doing , I am pretty new to Linux , I am sure someone who knows what they are doing can explain to me why this works.

Thanks for the help.


If you have a live-cd to boot from, do a fdisk -l to see if the first partition is a utility/recovery partition. If so, you would want to install the loader to the MBR and configure menu.lst for the root to be (hd0,1).

Thanks I will have a go , I don’t have a Live CD but I can get one , its worth a try as I don’t like this LVM installation it’s rather messy.
Thanks for all the help.