no operating system found


The situation.

I had xp on my laptop.
I installed opensuse 11.1 on a seperate partition with live cd.
(standard, don’t know if that is mbr or something but…)

everything was good, i did get grub and i coud chose between windows and suse.

then i changed the boot order in yas and did set windows default (i did that before with 10.3 too)

I reboot and i get the message: no operating system found.

problem: my second computer is having dificults to boot (beceause of gis age) and i’m the middle of my exams.

so, can you please help me with the fastest way to get my windows back. (I don’t care for opensuse at this moment)

fast help is welcome :slight_smile:

(is it good to boot the windows rescue cd and somehting there or?)

edit: forgot to say that when i tried to reinstallopensuse 11.1 i did in the install (whare you ratitoin) get errors where he wanted to format windows partition but did get an fls error or somehting. normally he did always detect this good. so i’m now really worried, i really can’t offord to lose my windows machine now.


I would boot from the Windows CD and go into “repair installed system” or whatever it’s called. I think there is a fixboot command you can run, as well as some mbr repair options. One of those should work. This should be the fastest way to fix the problem.

The Suse rescue options don’t work so don’t waste your time with those.

If you re-install Suse, and set bootloader options during the install process when you give passwords, desktop environment, etc, just before you press the “install” button, this seems to work best in 11.1. Changing the boot options after I installed killed my system too, so this is apparently normal behavior 11.1 and so I don’t think you did anything wrong, it’s just a serious bug that needs to get fixed.

There is a good bootloader guide here
GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.

hi, i tried the fixmbr,

i seems it is now even worse, i only get a blinking cursor when trying to start up.

Can you please help me further (if still possible :slight_smile: )
Your fast help is really appreciated


Boot suse

open a terminal and go su, then type

fdisk -l

post result here

and copy and paste the contents of: /boot/grub/menu.lst

you need to be root to view it

I thought I said fixboot, but I was just guessing from memory. Once you get into the repair options and type “help” you’ll get a list of commands to use.

It’s been years since I have had to do this but it does work and should be fairly easy to figure out with a little Windows-grade common sense.

you are right foresthill…
fixboot is the right command.there is nothing wrong with it.
to fix the boot loader just pop in your xp cd, select to ‘repair partition instead of new installation’.
then t will ask for the partiotion of your windows instalaltion.(it will give you all possible choices.usually it will 1.)enter that number and hit will then ask for the admin password.give it if you have one.then all you have to do is hit ‘fixmbr’ and enter.thats all you need to do.restart and you will be able to boot into xp as before.
the problem is you will no longer get the linux boot loader and linux instalaltion will be will have to install it again.for now just restore windows.after your exams you can try out he linux.

beceause i in other post did read that it had something to do with the mbr i tought your last command would be the one to go. Probally it wasn’t and i now made it worse,(my fault)

now i tried: boodfix c
and rebooted but no difference.
Any further ideas?

i’m sorry for the stupid talk i’m making at this moment.

I will try to giva a clear situation now.
dual boot xp and opensuse 11.1 (acer install, so maybe other structure?)

after my problems i did: fxmbr.
and now fixboot c too .

Now i only get blinking cursor.
Anyway thanks for you guys fast responses, really appreciated.

no problem brother.dont feel that way.
well no problem if you used fixmbr.fixboot alone will be sufficient.and fixmbr will not make difference (yes it will write a new mbr,but that is not at all a problem right now) i do that all the time.
when you fix the boot xp, the windows boot loader will be back and you should be booting into windows with out any problem.there is no way it can go another way.try the procedure again it sohould be enough

hi, thanks for helping. here some causes that i see?

-i’m using an other xp boot cd than the acer ones. when i put the acer one in he immediately tries to install a new system. but i don’t really see a problem in this.

-when doint fixboot i must do fixboot c or something.
Can it be that i must do somthing other than C?
(when i chose the number i hae the option c:\windows)

-cood it be that the mbr is not on the same place beceause it’s an acer installation?

any help welcome

You want to use a regular Windows XP disc, not the Acer restore disc.

If you don’t have a Windows XP disc, I would just reinstall OpenSuse, and you should be good to go, just DO NOT CHANGE YOUR BOOTLOADER CONFIGURATION, stick with the stock set up.

maybe you just need to fix the boot settings

post result of su terminal

fdsik -l

and contents of


i did google a little, and i fount this stuff:

acer has a special mbr, (not regular) but i did reinstall the mbr frum usual cd.

i already tried to reinstall opensuse, but when i leave everything standard he tries to format windows but gave errors. i think it was lfs or something (red warning message where he shows what he will do)

i think the best option is to find how to get my acer mbr back, but i don’t seem to be able to find it.


here i am again,

at the moment i’m reinstalling opensuse 11.1.
Now he detected windows and the other partitions good again.
Probally beceause of the fixboot and so on.

Now i hope that when i reinstall i will get my computer back. Fingers crossed.

Sorry for my unclear messages, but my nerves are jumping up and down.


I appreciate your nervousness - but please do try to calm down a bit, or you may make the situation much worse.

First, the original message you got “no operating system found” comes from the bios and means there is not usable program code in the MBR. This is what the fixmbr command is designed to fix.

Second, fixboot only rebuilds the partition boot sector. You have not gotten far enough to known if that is a problem or not. But if you keep using it, you could create another problem after the first one is fixed. Throwing “maybe” solutions at the problem only will make things worse.

Third, as I think you already realized, the Acer CD is not for repair or even re-installation. It is to copy back to the hard drive from a copy of XP exactly as Acer put it on in the factory. In other words, all your programs and all your data added after the machine was first new, will be gone.

Fourth, nothing you did with fixmbr or fixboot will affect what openSUSE will do in its installation.

Fifth, you can control exactly how you want openSUSE to install and set up the boot. The safest and fastest way to get XP back is to do this in the openSUSE installer:

  1. At the Boot Loader section, click on the heading to enter the dialog.
  2. Click on the Boot Loader Installation tab.
  3. In the Boot Loader Location column, check “boot from root partition” and make sure no other boxes are checked.
  4. Click on the Boot Loader Options button (upper right), and a new screen will appear. Then check (upper left) only the box “Write Generic Boot Code to MBR”.
  5. Click OK. Click Finish.

When you reboot, you should get XP. You will not see any option for booting openSUSE - we will work on that after you get XP back.

hi all,

This is a new day, and i’m calmed down and happy again.
After all the solution was to install opensuse 11.1 again. For some reason i now didn’t get the error’s.
So now i’m back like i was.

Here some stuff i learned yesterday:

-Don’t do unusual stuff in an exam period
-Try to stay calm (will need that to in my exams) :shame:
-Once you invite tux in your computer he wants to stay there :open_mouth:
-Tux is a good friend for me if all goes regular
-Tux plays with me if stuff goes wrong
-In the end tux will rescue windows and live side by side again. >:)

But the most important lesson:
-Linux (opensuse) has a brilliant community.

Thanks all. lol!

Thanks for the kind thoughts. Glad all is well now. :slight_smile: