No openoffice - ouch

Ok I get it someone decided to delete openoffice claiming libreoffice is better. Not my experience at all. Of the 200 to 300 thousand old documents that openoffice was quite happy to open / print / resave as needed the libreoffice will open less than 50%, has trouble printing anything it was not the creater of and due to subtle differences in the way things in libreoffice work slows things to a crawl. This leap 15 upgrade is not as I expected. I have 13.2 which handled 2% of what 42.3 couldn’t. Just replaced 42.3 with leap 15 which can’t seem to do anything. Case in point, openoffice is dead (present but won’t start). zypper says it is ok, Yast says it’s ok, zypper can’t remove it, Yast can’t remove it. If the *** package is obsolete and doesn’t work anymore why can’t I remove it!!!

During the upgrade to leap 15 I got a lot of messages about python conflicts but then at the end it said upgrade successful. zypper confirms anything relying of python is broken due to missing libraries. All my 32 bit libraries needed for my ide are no longer available. So here is what I figure:

Go back to opensuse 13.2 for openoffice, 32 bit apps ( obd2 car reader, xbasic, campground reservation system, etc)
Find out how I can force leap 15 to remove openoffice
Find out how come most of libreoffice does seem to work right (many features greyed out)
Wait for leap 15 fixes to eventually be figured out.

Sometimes, Zypper is not quite as helpful as it could be — please check the following:

  • Repositories?
  • “rpm --verify --all”
  • It may be that, the RPM database isn’t OK: “rpm --rebuilddb”

Specifically, which 32-bit libraries does the IDE you’re using need? — Did the IDE upgrade correctly?

Python needs libcrypto and libssl libraries – both provided by the libopenssl1_1 and libopenssl1_1-32bit packages.

  • Do you have the SSL library packages installed?
  • You’ll also need the libsqlite3-0 and glibc-devel packages …

Get the latest Apache OpenOffice from here:

or
http://www.openoffice.org/

I am running it in Leap 15.0 & TW with no issues whatsoever.

Just choose the RPM version and follow the instructions to install it.

In my opinion, when you pass version (42.3 to 15) it is advisable to do a clean installation, you can also update I do not doubt it, but there are several things to do before starting with the update, delete configuration files of various applications is one of these, having the separate / home just do not format it and you have all your files in place. During the update there are certainly dependencies to be solved, and not everyone knows how to behave, just choose the wrong option and create a malfunction.
To see if it is a problem that the LibreOffice update does not work the documents you have you can try a live Leap 15 and see if it works properly with your documents http://download.opensuse.org/distribution/leap/15.1/live/
So you will have your answer, good work

I would definitely not use 15.1, rather a 15.0 live image to see if things work in that environment. FWIW, my oldest documents are from 2001, and I never once found LO to refuse to open, or mess up documents. Talking about docs, spreadsheets, presentations, databases.

Re. upgrading 42.3 -> 15.0, my experiences are that changing the repos and dupping to 15.0 works fine, where I admit having done some reading before, so I knew about some changes, like f.e. the move to firewalld.

Under no circumstance should anyone be using Apache OpenOffice at this point - it has a critical vulnerability which has only been patched in LibreOffice: OpenOffice Vulnerable to Remote Code Execution, LibreOffice Patched

That is an inaccurate statement.

Instead, you should say that nobody should use Apache OpenOffice if they are in the habit of downloading unknown ODT files from unknown sources and opening them in their office suite. Not a smart thing with or without this vulnerability. Not a smart thing with any unknown file from any unknown source in any application, including LibreOffice, whether there is a known vulnerability or is not.

Been almost a month and still can’t delete damaged openoffice package even as root zypper yast and rpm won’t delete openoffice, new package from www.openoffice.org downloads but won’t install. Says it conflicts with existing openoffice package.

rpm -verify -all replies nothing to do, rpm -rebuilddb replies with just the system prompt no output at all
Thinking I should just copy my /home/me folder out of the way try and remember how to make the install usb and install leap 15 fresh. I can boot to old version of linux and see if old version of libreoffice can read the openoffice files or I can use the old openoffice to read the files and copy paste them into libreoffice to save.

As for what libraries my ide needs I have no idea. I installed the ide under 11.2 with absolutely no problems or dependencies unresolved and with each upgrade right through to leap 42.3 nothing seemed wrong but then came leap 15.0 and it can’t run. Thinking because Leap 15.0 doesn’t work on 32bit systems and this ide only works on 32bit systems I may be out of luck.

It’s probably not surprising that an application relying on Python would have problems after all these years…
You can try a hail mary and install a Python native to an earlier version of openSUSE… but you’d have to do something like install Python from PyPi if it’s not available in the 15 repositories (likely the case).

Recommend you first make sure that your files are backed up and safeguarded in case anything becomes damaged.

I don’t know how complex your system is and the apps you have installed, you may want to consider a re-installation with a modern version of Open Office (or LibreOffice). You’ll probably find all sorts of additional benefits by removing all the cruff in your system.
You might even consider a temporary system downgrade to see if that would enable you to remove your broken Open Office, followed by a brand new Open Office install <after> you upgrade again to 15.

Also, what is this “ide” you’re referring to?

TSU

And if you don’t require all of the extraneous stuff that comes with openoffice or Apache OpenOffice or any of the derivatives,
There is this; https://www.freeoffice.com/en/download and is is free.
It works in leap 42.3 and Leap 15 and come with as a .rpm download.

When you have some 32 bit dependencies for old programs, and you want to upgrade to a 64 bit system, there can be many problems. There is however a tedious but usable solution.
If you only have one or two programs that need the old 32 bit system, then do the following:
Create a bootable USB external memory stick say 32 GB or above with the OLD version you know works from an OLD version ISO. Ensure it boots in your computer as an external ‘hard disc’. Install the programs you need for old system. Copy onto another USB stick the relevant documents you use with this. Thus you have an OLD bootable system and OLD data external USBs that can work together.
Ensure you have a full external back up of all your data separately, for use with NEW system (back up of “/home” ?).
Now. Do a clean install of LEAP 15 reformatting the “/” root but not reformatting or touching your “/home”.
Check everything works with LEAP 15 and all your “/home” is on disc
Then you have two computer systems, One. A new install LEAP 15 on which you do all your normal stuff and onto which Both LibreOffice and Open Office can be installed and work. TWO. An external booting OLD system by booting a USD OLD system and its specific data on a separate USB data USB.

I use this method for specific old government software which only works in an old 32 bit Linux system, which needs to be retained in working order for a long period of years due to tax reasons.

I wish you good success for your problem.

What you describe here can be done much more safely and easily with virtualization like Virtualbox, you can install an old OS in a VM and install the version of Open Office you need. You can even configure a “shared folder” to provide access to files without moving them.

But, that only provides access to the files, becomes more of a security risk over time and does nothing to address the mess in the current LEAP 15.

TSU

Ok after much deliberation and testing, here is what I found out. All my Old openoffice docs,spreadsheets, presentaitons work in libreoffice and openoffice on versions of linux 13.2, 42.1, 42.2, 42.3 but do not work libreoffice with leap 15 upgrade nor do they work in libreoffice with a fresh install of leap 15. The leap 15 upgrade is broken in many senses. openoffice is somehow locked such that it and it’s files show but not even root w zypper or yast or rpm can remove it or replace it. The only way to get rid of the non functional openoffice is to fresh install without openoffice. Libreoffice on both leap 15 upgrade and leap 15 fresh can’t open old openoffice made files but if i use an old libreoffice version under another linux version I can re-save the loaded documents and as such leap 15 libreoffice can open them. Same version of libreoffice under leap 42.3 and Leap 15.0 yet 42.3 can open my old openoffice stuff but but leap 15 can’t.

kicad made documents for schematics and pcb’s behave differently even with the same identical libraries of parts and templates. In Leap 42.3 all parts are correct and pcb layout is exact. Under Leap 15 kicad wants to substitute inappropriate parts and the schematic layout is all garbled. This also results in the pcb layout being all messed up. It is like vector graphics algorithm is wrong. Tried this on both leap 15 upgrade and leap 15 fresh install.

Amarok sounds like someone is squeezing the singers unmentionables in leap 15 upgrade but is only slightly off in leap 15 leap 15 fresh install.

Compiled xbasic programs (32bit) no longer run in leap 15 because the base 32 bit libraries that the core assembly functions call are missing from leap 15.
Same problem with the IDE for xbasic, missing core libraries for gcc 32bit.

Whole point of having a 64 bit system is to be able to make use of 64 bit integration without abandoning old working programs. Backwards compatibility is mandatory on any professional operating system. Leap 15 IMHO breaks this trust. The following professions are negatively effected by this, government, education, health sciences, software engineering, accounting, banking, manufacturing, and probably many more than I can think of.

As a general rule 32 bit lbs are not installed by default but most should be available in the repos.

Note upgrades do not remove anything so old software may be still available where as a new install won’t install anything but the defaults and any special thing you may select in the installer that is available on the install media.

Using rpm to remove, how exactly did you try, and what resulting messages did you get?