No openGL after update

Hi all,

  • first my hardware:
    Laptop Dell E7240

lspci -nnk | grep VGA -A2

00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 0b)
        Subsystem: Dell Device [1028:05ca]
        Kernel driver in use: i915
  • kernel:
4.4.49-16-default #1 SMP Sun Feb 19 17:40:35 UTC 2017 (70e9954) x86_64 x86_64 x86_64 GNU/Linux
  • problem:

cat /var/log/Xorg.0.log | grep EE

        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
   220.182] (EE) AIGLX error: dlopen of /usr/lib64/dri/ failed (/usr/lib64/dri/ undefined symbol: _glapi_tls_Dispatch)
   220.182] (EE) AIGLX: reverting to software rendering
   220.193] (EE) AIGLX error: dlopen of /usr/lib64/dri/ failed (/usr/lib64/dri/ undefined symbol: _glapi_tls_Dispatch)
   220.193] (EE) GLX: could not load software renderer


name of display: :0.0
Error: couldn't find RGB GLX visual or fbconfig

Trying to load KDE:

Plasma is unable to start as it could not correctly use OpenGL 2.
 Please check that your graphic drivers are set up correctly.

Looks like for some reason I lost my OpenGL support. I didn’t notice this at first (I use fluxbox most of the time and apps that don’t require OpenGL), but I believe it happened around the updates I applied on 24th.
At that time I had following repos enabled:                       

Since I thought the issue had something to do with the Mesa/Xorg I start downgrading mesa/xorg, but that wasn’t helping, so I finnally disabled all the above repos and did “zypper dup”
Right now I have following repos enabled:                                                                                                                                     

I also tried removing /etc/X11/xorg.conf.d folder and rebooting, but nothing I did so far made a difference.
I’m not quite sure where to go from here, what to look/check for.

Any help with this issue would be greatly appreciated.


i have this problem for a few days now, i suspect libglvnd

Thank you so much! libglvnd is in fact the problem, I just removed it and I’m back in business.

I thank you as well, cuz i didnt knew if i can remove this package without harm. If you know where to fill a bug, please do so, so other ppl will not face this problem.