No one but root can use KrandRTray

:disapointed:Greetings All;
And thanks in advance for all responses.

The problem I’m having is no one but root can use the KrandRTray to resize or rotate the screen.
Software level is Open Suse 13.2 KDE v4.1 or whatever comes with the 13.2 distro.
On other user accounts trying to use the utility, the (busy) icon shows up then just goes away.
So the question is “Is this is a permissions problem” or a “Missing file problem”.
Help does not seem to be available in the online help system.
BTW: this was a clean install, old stuff wiped out.
Only tweeked two files to get sis660 onboard hardware to work those files were:
“/etc/X11/xorg.conf.d/50-device.conf” and
“/etc/X11/xorg.conf.d/50-monitor.conf”

All other users are restricted to a resolution of 1280x1024 and seems to be unchangeable
with this tool.
However the users can use xrandr to change but changes do not hold or persist.

I can’t find krandrtray on my new and updated 13.2 KDE.

  1. Is your system that has been upgraded or a new install?>
  2. Although not located in the tray, have you tried modifying the display the normal way, ie
    Do a KDE search for kscreen, select “Display Configuration”
    (An alternative to the above is KDE Start > Desktop Preferences > Display and Monitor)
    Your display should be identified, click on it.
    Modify.

TSU

BTW -
I can’t know for sure since I can’t find any way to install krandrtray on to my system for now,

But,
I suspect if you open up the propeties of the applet, the command may be invoked without running “kdesu”
Fix that and I suspect your tray applet will run. Of course, you’ll need to provide root permissions to make the change.

If this worked before and this is an upgraded system from a previous version of KDE (and probably openSUSE), you may just be seeing the closing of a security loophole.

TSU

:\On my system (13.2) this app is located @
Applications - System - Desktop Applet - Screen Resize & Rotate.

I did a right click on the menu and sent the icon to the Panel.

There on the panel I left clicked then the busy icon appeared for
a while then went away.
That was yesterday, I then turned off the system.

Then today I went back and after the system restarted I found two
icons now, one that does what is described and one that actually
works as it does for root; funny when I did this in the root
account it functioned as it should.

I did what you suggested with the kscreen tool and was able to
affect changes, this is similar functionality as the krandrtray
tool provides, accept for being panel available.

Now I’v noticed in all other user accounts that I’v got two
krandrtray icons on the panel one that works and one that don’t.
This behavior was not repeated in the root user account.
So it is still a mystery as to why it work for root but
not for Joe common user. Seems to be a bug (unconfirmed).

Anyway the problem seems to have resolved it’s self.

Information:
Clean install:
Old OS Open Suse 11.4
New OS Open Suse 13.2
Four partitions setup:
One : Linux Swap (swap) ---- FS (swap)
Two : Linux Root (/) ----------- FS (ext3)
Three : Linux Sub (lstore) ---- FS (ext3)
Four : DOS FAT32 (win32) — FS (dos fat32)
All four partitions were formatted to remove all existing data.
Nothing from the old install was saved accept for the browser
bookmarks.

Maybe someone else will have this problem and find this Information
useful or even find a solution to the double icon problem.
It seems that I cannot remove the first icon from the panel.

Thanks for the “kscreen” tip.

Just a FYI -
What you described doesn’t exist on my newly installed 13.2/KDE.
(The only desktop applets listed are Clipboard Tool, Download Manager and Wallet Management Tool)
So, I suspect what you have may exist only on an upgraded machine, and therefor may no longer be supported officially.

TSU