No NetworkManager in Leap to conrol wifi connections

Settings show that I am using NetworkManager Services. NetworkManager is definitely running. But I can’t find the connection console to change any settings nor to access another wifi connection - it connects automatically to my home wifi fine. Can you please help me troubleshoot this? I can’t use my laptop’s wifi away from home.

As the NetworkManager client/applet is something that should run in your desktop, at least tell us which desktop you use.

And since you used the prefix 42.2, please check if you are really using Leap 42.TWO which is still in Alpha3 test phase or if you are referring to the current released Leap 42.1.

OK, thanks - I can see I’ve not been helpful. So, using 42.1 sorry and using the Plasma desktop.

Do you mean that you lack the “Networks” popup in the system tray (normally between the loudspeaker and the clock) with its associated “configure network” button (under the mouse pointer in the attached image)?
http://paste.opensuse.org/44438807 (if image doesn’t show, see this http://paste.opensuse.org/44438807 )

Can’t find any kind of manager for this anywhere

Let’s see what you have installed

rpm -qa|grep Network

Forget my last post, it is ‘plasma-nm5’ that provides the necessary. You could check that it is installed, although it normally would be. Do you have a NetworkManager plasmoid present in the system tray?

If the icon is not visible, right-click on the small triangle that reveals the hidden icons > System Tray Settings > make sure ‘Networks’ is enabled.

yes, it is installed and nothing in the system tray. Is this related to this https://forums.opensuse.org/showthread.php/510574-System-Tray-seems-broken-in-KDE-Leap ??

Try adding the ‘Networks’ widget like this… Right-click on the system tray > Unlock widgets, then right-click on it again and select Panel Options > ‘+ Widgets’, search for ‘Networks’ then click on it. Does that add the required visibly?

seems easy enough and it worked - can’t imagine why I couldn’t see it before…!! Thank you.

I’m not sure why it wasn’t there to start with, but glad you can now connect/configure network connections. :slight_smile:

PS Don’t forget to lock the widgets again. You don’t want things changing or disappearing on you!