No Network

Hello beautiful people of this forum,

This is my very first post in this forum and so hoping I could get some help here. Be warned that I am very new to linux and though I can grasp some of the concepts… BUt really, I am a newbie…

I have this laptop with a model number asus k40ij which I installed Open Suse 11.0 on another partition. The laptop has dual boot with Windows.

Problem is, the ethernet, wireless card and the sound card is not working… I tried to to insall every packages that I think has something to do with drivers of the said phreiperals to no avail.

I cannot download from the internet for any required software since there is no medium that is active on my laptop to do such connection.

I am more of a networking guy who wish to know more about the great OS which is Linux. Hope you can show me steps on how to install packages the correct way. Also, id like to know if the laptop I have is supported.

If in case I am able to download the software needed for it, how do i transfer it to the Suse OS?

With an up and running Suse laptop, I am sure I can use that tool to know more about the OS.

Thanks for your time… :slight_smile:

First thing : why don’t you installed de openSUSE 11.3?

Thank you for your reply. Can you direct me to a link where to download such update? I’ll try to look for one but it would be nice if I can get from an experienced user. The disk I have installed was only given to me by a friend. Anyway, thanks for your advice.

You can download openSUSE 11.3 from here

Hi levi8200
Welcome to the SuSE forum community.

As noted several times above SuSE 11.3 plays “nice” with most common WiFi hardware encountered in laptops, when you install I would recommend a hard wired net interface, once YaST has worked it’s magic the WiFi should not be a challenge.

Best of luck and enjoy SuSE

thanks a lot guys… hopefully I am able to install it successfully. By the way, the software available for download, is just a trial version? Do I have to purchase the full version after the trial period expires?

It’s the full version – no purchase required.

And enjoy openSUSE ! :wink:

Hello Sirs,

I have now installed Linux 11.3 in my laptop and guess what, Ethernet works and I can get online using the said OS! It’s cool, I love it and I can’t get over it. I chose GNOME over KDE… I haven’t tried wireless though for it’s not available at the moment. With new OS comes confusion and complexity… here are the things I noticed:

  1. On my Desktop I have 4 icons, 3 are functioning… The 3rd one is not. That icon is “Open SuSE”!!! When I try launch it, I get an error “There was an error launching the application.Details: Failed to execute child process “ggreeter” (No such file or directory)”

  2. The sound is a bit weak, but it’s tolerable. That is the last of my priorities.

  3. On my Mozilla Browser, I cannot watch videos that requires Flash Player. I tried to download one using the link below:

Adobe - Install a different version of Adobe Flash Player

I selected .rpm for Linux since that is the closest I think is applicable.

I have the file under Download Folder with a filename “flash-plugin-10.1.102.64-release.i386.rpm”…

I tried to install several times but it’s not working. Below is the error message:

“[PK_TMP_DIR|dir:///var/tmp/TmpDir.kG6PNw] Repository already exists.”

And for that, I still can’t view videos using the mozilla browser.

  1. When I tried to download an MP3 file over the net to test the audio, I get this error:

PackageKit-gstreamer-plugin requires an additional plugin to decode this file
The following plugin is required
MPEG-1 Layer 3 (MP3) decoder
Do you want to search for this now?

When I click on search, I get this error again:

Failed to search for Plugin
Could not find plugin in any configured software source

  1. When I click on Online Update under YaST, there are a lot of errors. See below:

***Download failed:
Failed to download /repodata/repomd.xml from Index of /update/11.3
History:

  • [AbstractCommand.cc:224] URI=http://download.opensuse.org/update/11.3/repodata/repomd.xml

***Cannot access installation media
Index of /distribution/11.3/repo/oss
(Medium 1).
Check whether the server is accessible.

***Download failed:
Failed to download /suse/setup/descr/ftp-11.3-22.1.i586.pat.gz from Index of /distribution/11.3/repo/oss
History:

  • [AbstractCommand.cc:224] URI=http://download.opensuse.org/distribution/11.3/repo/oss/suse/setup/descr/ftp-11.3-22.1.i586.pat.gz
  1. When I install VLC for 11.3, again, I failed.

***Download failed:
Failed to download /suse/setup/descr/non_oss-11.3-22.1.i586.pat.gz from Index of /distribution/11.3/repo/oss
History:

  • [AbstractCommand.cc:224] URI=http://download.opensuse.org/distribution/11.3/repo/oss/suse/setup/descr/non_oss-11.3-22.1.i586.pat.gz

***Download failed:
Failed to download /media.1/media from Index of /distribution/11.3/repo/oss
History:

  • [AbstractCommand.cc:224] URI=http://download.opensuse.org/distribution/11.3/repo/oss/media.1/med

***Software installation
The installation has failed. For more information, see the log file at /var/log/YaST2/y2log. Failure stage was: Adding Repositories
Error Message
An error occurred while attempting to subscribe to the required repositories. Review the yast2 logs for more information.
The following repositories could not be added
Index of /pub/videolan/vlc/SuSE/11.3/

Well, thats a lot!!! But I am not giving up on it. Please help me on how to deal with it. If you give instructions, put a number before it so that I know which part you are referring to. Please be detailed with your instructions because I am really really new to this. You are talking to a guy with no programing background… Just plain networking (Cisco)… So go easy on me. Don’t throw tomatoes on me, use stones instead…

waiting for your reply guyz…

Levi

Did you try in a terminal sudo rpm --install Download/flash-plugin-10.1.102.64-release.i386.rpm

Lest we forget: Welcome aboard

Don’t go to 11.3, because its not good. if anything try openSUSE 11.2 first and use 11.3 as a last resort

Ok… I will revert back to 11.2… hopefully everything goes well… :slight_smile:

Don’t go to 11.3, because its not good. if anything try openSUSE 11.2 first and use 11.3 as a last resort

I must respectfully disagree strongly with anyone who would make such a broad generalization. I have resolved issues on three machines that had very much the same problems reported in the original post by nothing more than installing 11.3. That was all I needed to do to solve the issues quickly and easily. On the other hand, as my signature indicates, this machine was easier to get up and running on 11.2. (Now even that situation has changed, as I recently installed 11.3 on an identical machine, since there are now some newer files available in the initial update.)

The bottom line: “YOUR MILEAGE MAY VARY”