no network, stuck on setting network address

using networkmanager on KDE in my opensuse leap 15.0, no cable and no wireless network, I tried to delete /etc/resolv.conf and to run netconfig update -f and reboteed and rebooted but no network connection obtained

Your description “stuck on setting network address” is nowhere confirmed in your post.

Maybe it is better to follow this recipe:

You check from bottom to top:

Is the NIC up with an IP address?
ip addr
Can you connect to another system on your LAN?
ping -c1 <IP-address of your router>

(I hope you know that address)
Do you have a default route to the Internet?

ip route
Can you connect to a system on the internet?
ping -c1 130.57.66.6
Can you resolve host/domain names?
ping -c1 forums.opensuse.org

Take care. As soon a one step fails, that must be resolved first. It is useless to go to the next step before it is resolved.

BTW deleting /etc/resolv.conf may help when you have problems with resolving host/domain names (DNS). but when you have no IP address (as you assume), this is pretty useless.

So start with 1. and do not hesitate to post the output here to get help on the interpretation.

yes, I confirm

manythanks, well, I don’t understand if from bottom or from top of your instructions, but, I do both:

pla@pla4-TW:~> ip addr1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 80:fa:5b:69:82:7d brd ff:ff:ff:ff:ff:ff
    inet6 fe80::9292:6add:1d82:9544/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 9a:be:81:87:25:5b brd ff:ff:ff:ff:ff:ff
pla@pla4-TW:~> ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 80:fa:5b:69:82:7d brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 18:1d:ea:9e:86:71 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fe49:f156:174d:c899/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
pla@pla4-TW:~> 
pla@pla4-TW:~> ping -c1 forums.opensuse.orgping: forums.opensuse.org: Name or service not known
pla@pla4-TW:~> 



furthermore, I can connect with wireless to my cell phone acting as hotspot.
with cable, where the pc where I’m writing this post is connected and working, I cannot connect, and also with wireless

Hi
Can you reboot your router? Sounds like it’s not dishing up dhcp addresses…

My first guess would be the router as well — and if it’s an older model, maybe it has difficulties with those newfangled IPv6 packets, in which case disabling IPv6 could do the trick.
There are multiple options:

  • disable IPv6 in YaST2/Network Settings
  • add ipv6.disable=1
    as a kernel command line parameter
  • create a file /etc/modprobe.d/blacklist-ipv6.conf with contents »blacklist ipv6« (without the quote marks)
  • create a file /etc/dracut.conf.d/01-no-ipv6.conf with »omit_dracutmodules+=" ipv6 "« in it, then generate a new initrd

All of these changes require a reboot in order to test a IPv4-only system with your router. Hopefully, though, restarting the router suffices, as malcolmlewis suggested. Good luck.

yes, I rebooted sftware way and hardware way but nothing changed, now I’m on another place and on another router but connecting via cable doesn’t works, via wireless it’s ok, but via cable not. stuck on setting network address

my router is a new one, this: Offerte Telefonia Mobile, Fibra, Smartphone, Energia e Assicurazioni | WINDTRE
the other router is my company router so it is a professional router that works fine on many computers.
I will try the other ipv6 things

Hi
Is the kernel-firmware package installed?

Can you show the output from;


/sbin/lspci -nnk | egrep -A3 "Ethernet|Network"

tried first option and rebooted but didn’ works :expressionless:

yes:

pla@pla4-TW:~> /sbin/lspci -nnk | egrep -A3 "Ethernet|Network"
39:00.1 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 12)
        Subsystem: CLEVO/KAPOK Computer Device [1558:1325]
        Kernel driver in use: r8169
        Kernel modules: r8169
3a:00.0 Network controller [0280]: Intel Corporation Device [8086:2526] (rev 29)
        Subsystem: Intel Corporation Device [8086:0014]
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi
pla@pla4-TW:~> 



Hi
Can you try the r8168 (since your output indicates this device) driver from Forum user Sauerland’s 15.0 Update repository;

You can add the repository, or grab these two files
https://download.opensuse.org/repositories/home:/Sauerland/openSUSE_Leap_15.0_Update/x86_64/r8168-blacklist-r8169-8.047.02-lp150.57.4.x86_64.rpm
https://download.opensuse.org/repositories/home:/Sauerland/openSUSE_Leap_15.0_Update/x86_64/r8168-kmp-default-8.047.02_k4.12.14_lp150.12.67-lp150.57.4.x86_64.rpm

Not sure, but may need to run mkinitrd after installing just to be sure the blacklist of the r8169 driver occurs.

Assuming your system is up to date and running the latest kernel?

manythanks, yes my system is update and run this kernel:

pla@pla4-TW:~> uname -r
4.12.14-lp151.28.10-default
pla@pla4-TW:~> 

I found the packages that you suggested me in the packman repo


Essentials / openSUSE_Leap_15.1
http://packman.links2linux.de

r8168-kmp-default 8.047.01_k4.12.14_lp151.28.10-lp151.3.1
r8168-blacklist-r8169 8.047.01-lp151.3.1
and I installed them and it seems to solve the problem, yesterday I tried to change among networks connecting by cable and it worked fine.
I was surprised that r8169 (with highest number) was older than r8168 (with lower number) as the description in yast says On many Realtek Ethernet controllers the old device driver r8169 does not work reliably. To solve this the r8169 kernel module has to be blacklisted to enable the system to load the new device driver r8168.

Can anyone advise me on how to accomplish installing the r8168 driver from the Rescue portion of the Leap 15.1 install disk?
It went through the entire upgrade successfully, but when rebooted into the installed Leap 15.1.1 it cannot configure the network and shows all the same issues described for the previous poster. i.e. 8168 network device built into the motherboard, no ip connection at all. When I rebooted into tbe install disk and selected Rescue, I then had the network connected, but I am not a good CLI person.
Thanks
ken