No network services after installation

After a fresh install on a system with new SSDs, I get no network.
journalctl -xe output shows wicked complaining “org.freedesktop.DBus.Error.ServiceUnknown: The name was not provided…”

See this page (since I cannot copy and paste from the console session to here):

My hunch is that this is associated with my partitioning/setup, though I can see nothing wrong with what I’ve done.

  • I have two disks (SSDs)
  • Each has a RAID partition. The two then make a RAID-1 device
  • LVM volume group uses the above RAID-1
  • Then LVM logical volumes for root, home etc are created.
  • There is a separate /boot partition on one disk (i couldn’t get raid-ed booting to work, but that’s not interesting to this thread).
  • Once booted (with no networking!), the system appears ok - I can create stuff, see all the right LVM filesystems etc.

If I install into a single regular partition on one of the disks it works fine. Hence my hunch. However I did want RAID-1 (for presumed reliability).

I have tried to restart the network service from the command line but get the same errors.
I have also tried to go through yast to configure the networking, but get the same errors.

Any ideas how to resolve this installation issue?


OK, solved it. As I was using SSDs I’ve used yast to set tmpfs for everything offered by the gui - including /var/run/.

With this removed from /etc/fstab, then networking starts ok.