No network in connection Opensuse 11.1 after Installation

I’m a window XP user and I’m attempting to cross over to OpenSuse 11.1 and I wondered if you guys could help. I reset my D-Link ERB-2310 rougher and installed OpenSuse 11.1 on a new ST380811AS Seagate hard drive but, I got no internet connection. I attempted to deploy NetworkManager but, I got an error that said that there is no network. The router relays the old DNS protocol, IPv4 so, I disabled IPv6 in FireFox and any where else I saw IPv6. A lot of software installations will detect and use an DHCP automatically. It would be great if you guys could get me connected with OpenSuse 11.1.

imbob adjusted his/her AFDB on Wednesday 05 Aug 2009 12:46 to write:

>
> I’m a window XP user and I’m attempting to cross over to OpenSuse 11.1
> and I wondered if you guys could help. I reset my D-Link ERB-2310
> rougher and installed OpenSuse 11.1 on a new ST380811AS Seagate hard
> drive but, I got no internet connection. I attempted to deploy
> NetworkManager but, I got an error that said that there is no network.
> The router relays the old DNS protocol, IPv4 so, I disabled IPv6 in
> FireFox and any where else I saw IPv6. A lot of software installations
> will detect and use an DHCP automatically. It would be great if you guys
> could get me connected with OpenSuse 11.1.
>
>

What hardware are you using to connect?

wireless or ethernet?


Mark
Caveat emptor
Nullus in verba
Nil illegitimi carborundum

Ethernet, I have a D-Link EBR-2310 router connected to a Motorola cable modem it runs a DHCP server in the router to the PC.

When you installed suse, when it got to the network detction part and connected to the internet to get updates and latest release notes, was there a failure?
If not, there’s some sort of problem with the network card.
Go to Yast>network Devices>network settings, use ‘traditional ifup’ settings and tell it to use dhcp.
You can also then set gateway and dns addresses to the router address in case the dhcp isn’t passing the values to the client.
If this doesn’t work, give a fixed ipaddress with the gateway and dns set to the router.

imbob adjusted his/her AFDB on Wednesday 05 Aug 2009 16:36 to write:

>
> Ethernet, I have a D-Link EBR-2310 router connected to a Motorola cable
> modem it runs a DHCP server in the router to the PC.
>
>

If the network card is installed/recognised then you need to go to
Yast>Network Device>Network Settings and configure from there, you need it
set to start on boot (if that is what you want) here you can set wether it
is DHCP or static etc.

Don`t forget the default gateway and DNS.if needed.

HTH


Mark
Caveat emptor
Nullus in verba
Nil illegitimi carborundum

Found a post in this thread which links to this workaround: https://bugzilla.novell.com/show_bug.cgi?id=528083#c3

Credits go to Beineri

I have the same problem, I haven’t tried this workaround yet (will when I get home though). Seems to work for the original poster

My installation came on a DVD I Bought from On-Disk and I’ve had a few error messages when the installation tries to update, now. In network settings it has my network card denoted as 88E8001 GIGABYTE ETHERNET CONTROLLER DHCP. When I went to “Edit” I checked Use Static IP Address and there where three fields to enter. The first field was IP Address I entered the router’s default Static IP address, 192.168.0.1 and under Hostname I entered DLINK EBR-2310. Then, I enter the Subnet Mask: 225.225.225.0 but I got the error message “No Valid Net mask or Prefix length”.

The Ethernet is onboard and Opensuse dose recognize it, I’m sure.
Could you give me an example of the DNS format?

imbob adjusted his/her AFDB on Wednesday 05 Aug 2009 20:26 to write:

>
> My installation came on a DVD I Bought from On-Disk and I’ve had a few
> error messages when the installation tries to update, now. In network
> settings it has my network card denoted as 88E8001 GIGABYTE ETHERNET
> CONTROLLER DHCP. When I went to “Edit” I checked Use Static IP Address
> and there where three fields to enter. The first field was IP Address I
> entered the router’s default Static IP address, 192.168.0.1 and under
> Hostname I entered DLINK EBR-2310. Then, I enter the Subnet Mask:
> 225.225.225.0 but I got the error message “No Valid Net mask or Prefix
> length”.
>
> The Ethernet is onboard and Opensuse dose recognize it, I’m sure.
> Could you give me an example of the DNS format?
>
>

In the Yast config if you want a static address then the first Ip address
will be the address for your machine which should not be 192.168.0.1 ( this
is the address of the router) choose another one like 192.168.0.2

Subnet should be something like 225.255.255.0 and Hostname should be
anything you want to call the machine so it will be recognised by that name
on the LAN.

Under Hostname/dns you can enter the same hostname as before if it has not
already changed and for the DNS you can either use the DNS from your ISP or
you could use the ones from OpenDNS:

http://www.opendns.com/

Which are:

208.67.222.222

208.67.220.220

Have a look at that site it is very good and if you want to register you get
a control panel and can monitor all your machines no matter where they are.

Next is the routing, in here you need to put the IP of your router as
gateway ( if your router is the next in line from your computer to the net )

HTH


Mark
Caveat emptor
Nullus in verba
Nil illegitimi carborundum

I had a problem comparable to this. After installing OpenSUSE 11.1 I could not browse the web with Firefox, all I got was notices that the site could not be found. DNS did not seem to be working. But if I opened a terminal window and tried to ping the site I tried to visit, the ping worked as expected. So the network card and DHCP were working.

To solve the problem, I went to Yast>network Devices>network settings and I removed the checkmark next to Enable IPV6. After that Firefox worked as it should.

This was very irritating, since I had to use another computer to go look for the solution. I wish OpenSUSE did not enable IPV6 by default. When one has an old router, one is left with a computer that won’t browse the web.