No Network Connection

I am totally new to linux and opensuse, so please bear with me. I installed OpenSUSE with the gnome Gui option. all seems well except I can not get an internet connection. I now the connection is good and the network adapter works since I ran a recent live kubuntu disk earlier requiring no configuation changes with no problems. I entered the command (i.e. su -c “ifconfig; iwconfig; hwinfo --network”) I saw on the post about how to install drivers and I would have posted the result if I knew how to cut and paste in openSUSE. Which I figured out after all!

The computer I am trying to get up and running is an old machine that was a dedicated security dvr running embedded xp, but like i mentioned before since it had no problems with kubuntu I am hoping OpenSUSE will also run fine.

Please help.

here are the results:

nobody123@linux-ldjo:~> su -c “ifconfig; iwconfig; hwinfo --network”
Password:
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:48 errors:0 dropped:0 overruns:0 frame:0
TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:5721 (5.5 Kb) TX bytes:5721 (5.5 Kb)

lo no wireless extensions.

eth0 no wireless extensions.

24: None 00.0: 10700 Loopback
[Created at net.124]
Unique ID: ZsBS.GQNx7L4uPNA
SysFS ID: /class/net/lo
Hardware Class: network interface
Model: “Loopback network interface”
Device File: lo
Link detected: yes
Config Status: cfg=no, avail=yes, need=no, active=unknown

25: None 00.0: 10701 Ethernet
[Created at net.124]
Unique ID: usDW.ndpeucax6V1
Parent ID: rBUF.YFpX9nR8ki1
SysFS ID: /class/net/eth0
SysFS Device Link: /devices/pci0000:00/0000:00:1e.0/0000:02:08.0
Hardware Class: network interface
Model: “Ethernet network interface”
Driver: “e100”
Driver Modules: “e100”
Device File: eth0
HW Address: 00:0c:f1:6b:ff:2b
Link detected: no
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #14 (Ethernet controller)
nobody123@linux-ldjo:~>

Looks like the card is being detected as eth0 (e100) but it’s not active (Link detected: no), probably because it need to be configured (Config Status: cfg=no, avail=yes). You can set that in Yast → Network Devices → Network Settings. Locate eth0 there and “edit” it and configure it to get a “Dynamic address”. See how that goes.

[PS: after thought – check under “General” tab that it’s set to start at boot time]

Awesome!!!

And Thanks!!!

Enjoy…