No network after update

I did a zypper dup from 15.0 to 15.1. After it finished, I rebooted and now have no network connection. ping, even on my local network fails.

I tried opening yast->system->network settings but it hangs while trying to "Read Driver Information. I have to Ctrl-Alt-Esc it to get it to close.

I did systemctl ststus wicked and got:

● wicked.service - wicked managed network interfaces
   Loaded: loaded (/usr/lib/systemd/system/wicked.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Mon 2019-06-17 09:15:41 MDT; 5h 15min ago
 Main PID: 1555 (code=exited, status=1/FAILURE)

Jun 17 09:15:41 UNIVAC systemd[1]: Starting wicked managed network interfaces...
Jun 17 09:15:41 UNIVAC wicked[1555]: /org/opensuse/Network/Interface.getManagedObjects failed. Server responds:
Jun 17 09:15:41 UNIVAC wicked[1555]: org.freedesktop.DBus.Error.ServiceUnknown: The name org.opensuse.Network was not provided by any .service files
Jun 17 09:15:41 UNIVAC wicked[1555]: Couldn't refresh list of active network interfaces
Jun 17 09:15:41 UNIVAC systemd[1]: wicked.service: Main process exited, code=exited, status=1/FAILURE
Jun 17 09:15:41 UNIVAC systemd[1]: Failed to start wicked managed network interfaces.
Jun 17 09:15:41 UNIVAC systemd[1]: wicked.service: Unit entered failed state.
Jun 17 09:15:41 UNIVAC systemd[1]: wicked.service: Failed with result 'exit-code'.

/var/log/boot.msg shows one entry for eth0 and recognises the card without problems.

As I have no network connection, I am unable to delete and reinstall wicked.

yast shows that networkmanager is installed, but I can’t get to the place to make the change because it locks up.

I have no idea where to go from here.


Since you upgraded from 15.0, the last kernel from 15.0 should be there. And there should be a grub menu entry to boot it (in the “Advanced …” submenu).

Can you try booting that older kernel and see if it helps.

That makes it work!

Now what?

Can I have the system save more than the defaule kernells?

This MSI board has some weird things. The boot log complains about several things and often I have to force a shutdown with the power button. I’m NOT a gamer, and I don’t fool with overclocking. Is there a board that is solid for openSUSE? (Intel processor and Nvidia video)


The first thing that I would do, is edit “/etc/zypp/zypp.conf”. Look for the line

multiversion.kernels = latest,latest-1,running

and insert “oldest,” just before “latest”. That way, your working kernel won’t be removed until you manually remove it, or until you undo that edit change.

If you upgraded online, then kernel “4.12.14-lp151.28.4-default” was installed. Unfortunately, that kernel is causing problems. The kernel on the DVD installer was “4.12.14-lp151.27-default” which seems to work pretty well. My next suggestion would be to try that kernel, and see if it works. You can use the “Versions” tab in Yast Software Management to install that. But make sure you first change “/etc/zypp/zypp.conf” as suggested, because otherwise you will lose the kernel that you know works.

There is supposedly a new kernel being tested, and soon to be made available.

I will do that ASAP!

Thanks so much.


There’s a new kernel out there, waiting to be installed. It is 4.12.14-lp151.28.7. Maybe give that a try. And if that does not work for you, then the next step would be to open a bug report.

I did the changes to the zypp file as you suggested and then did a zypper up. The network problem seems to be fixed.

As an aside, I got an email message saying you had posted to this thread. I opened firefox to log in and reply, but couldn’t see your message nor the one I had posted. My message should be #8 and your’s #9. The forum is telling me there are only 7 messages in this thread. I tried this on both this machine and my laptop and with two different browsers, Firefox and Falkon. So, I logged off, opened my email client and clicked on the link from your message. It brought me here, where I can see, and reply to your message. Strange!


I’m not sure about those email messages. I have that turned off, so I don’t get them.

In any case, I’m glad to hear that things are now working.