No Mouse on Boot

Sometimes when I boot openSUSE 11.0 my mouse does not work.
The cursor is visible but moving the mouse does not move it.
This has happened three or four times since I installed the new version. (It did it again today.)

Rather than doing a cold reboot like I have been doing, is there a way to open a terminal and reboot “properly”?
I tried all the function keys but nothing worked.



If you are using GNOME and a touchpad : Touchpad troubles on Dell Latitude D520 and OpenSuse 11.0 - openSUSE Forums
Quick fix: If you delete the xml file found in /home/<user>/.gconf/desktop/gnome/peripherals and logout/login your touchpad should work again.

<CTRL> + <ESC> should bring your main menu to life and you can logout/login or reboot from there.

Another option is to ‘tweak’ your powermanagement settings so that your system shutsdown without a prompt when you press the power button.

You could also check to see if you get mouse control back by plugging in another usb mouse (if you have that option).


Thanks, Magic31.
I see that I have not given enough information, sorry.

This is a desktop machine x86_64.
I am using KDE 3.5.
My mouse is a PS/2 type.
Rebooting always “fixes” this problem. (the real “fix” would be for it not to happen at all.)
This is my home machine (single user) so there is no “login” per se on startup.

I tried <ctrl>+<esc>, as you suggested.
It opens the KDE Process Table, not a terminal session.

I have not tried using the power button (duh) because I did not know that the system would do a controlled shutdown using that method.

Any other suggestions?

Ahh… the <CTRL><ESC> is for GNOME. Thus I misinformed you:D

Not sure which key combination pop’s up the menu in KDE, could well be the windows key. Can’t check here.

On a positive note: At least we know the keyboard doesn’t cut out too. :slight_smile:

I’m getting from your first post that this is only an issue starting openSUSE 11? One thing you could check is if, when the mouse doesn’t work, dmesg reports anything about the error.

I’m not too savvy in hardware troubleshooting but often you get good messages from dmesg (console command).
Also run through the /var/log/ and /var/log/messages to see if there are specific errors about ps2 not initializing.

If you have a USB mouse handy it might make things easier as I suspect it will keep working when the ps2 one cuts out.

I’m having the same problem with a generic desktop machine using a USB mouse and the live cd. There is no mouse capabilities on boot. I’ve tried a PS2 mouse to no avail as well as another USB mouse.

The live cd works fine with three other machines that I’ve tried.

Have you checked the BIOS setup (legacy mouse support and all that) and also it you have the latest BIOS flash version?

In my case, yes.