no more sound

after a update killed my OpenSuse!! I had to completely reinstall. Now I’ve no more sound in Firefox etc. Only some kde sounds.
What excatly should I change where? Thanks

More likely the audio ouptut device
System Settings > Multimedia > Device Preferences
or the preferred backend.
System Settings > Multimedia > Backend

test works but still no sound in firefox etc.

Did you check your volume levels??

sure unchanged

works now after installation of pulseaudio and pulse-alsa plugin. Probably because I used nautilus?

Hopefully this lasts now…i already did two complete reinstallations :frowning: because the updater killed the system

Did you find out which update killed it? Then maybe you’ll know a bit more about what went wrong and can provide a bug report if needed…

no update killed all of my system!! ldconfig was messed in a way not to repair…i suspect a gstreamer update?

Again no more sound. Alsaconfig loses its settings?

It seems suse is getting worse and not better with each version. Never had to do 2 reinstallations and im using this sind 1998!

So what do i do now with this f* sound?

Try removing Pulseaudio if you haven’t already… I find it causes trouble on my install… Then again I have a non-standard card (Creative X-fi) so I am lucky to have sound at all :slight_smile:

Remove everything in Yast that has pulse in it. You might find you’re unable to remove libpulse since it seem to have a lot of dependencies on my system. If you’re using KDE make sure you have the right sound card selected under multimedia and select xine as the backend if you can. I find that to work well…

Make sure you’ve followed the multimedia guide… this way you are sure to have all requirements to have sound. Maybe OldCPU might be of some assistance if he reads this… He always seems to know how to fix someone’s sound problems…

You should not have to reinstall the OS if the sound breaks… also the fact that you had to do it twice would also suggest that whatever is going wrong is software related… So it can be corrected… Please don’t reinstall… have patience…

i don’t reinstall the os because of no sound. I told because it was completely crashed.- Never seen such before since 1998 >:(

So sound works if i delete the card in yast and let it configure auto again.
But at every reboot its gone.

After the first lost of sound i removed all pulseaudio but without change. pulseaudio was installed as i need nautilus(fileroller)?

This SUCKS folks…i wonder if other distros are that bad…>:( is ubuntu any better?

Ok i try tomorrow removing pulsecrap again as im not sure to have removed the card the first time

What are your system specs? What version of Opensuse and what desktop (KDE, Gnome, etc)?

default 11.2 kde and some gnome apps nothing else.

I removed pulseaudio again but still the same. after every reboot in yast i’ve to delete the audiocard and auto configure to have sound.
Settings are lost somehow…>:(

mik334 wrote:
> default 11.2 kde and some gnome apps nothing else.
> I removed pulseaudio again but still the same. after every reboot in
> yast i’ve to delete the audiocard and auto configure to have sound.
> Settings are lost somehow…>:(

personally, i do not think you have a sound problem…instead the lack
of sound is a direct result of (and a symptom) of the actual
problem…which is a faulty install, or improper setup, or ‘updates’
which introduce problems…

so, lets start there:

you say you have using openSUSE since '98, so tell me how did you get
to 11.2, did you do a fresh format and install of the system while
saving /home and data? (if not, how did you get to 11.2?)

did you download the 11.2 image from and md5sum check it
prior to burning, and then did you do this first, before actual

did your sound work fine (in Firefox also) after the initial install?
which update ‘broke’ your sound?

are you running 32 or 64 bit?
what is the make and model of your machine?
what graphics adapter and sound system is in use?

run the following at a terminal command line and copy paste the
results back to this forum thread:

zypper lr -d
cat /etc/fstab
df --print-type
df -h

and, please wrap a quote tag around the output you paste back
in…makes it easier to read…thx


not only the os is getting crappy also the people…i dont repeat all again and again.

mik334 wrote:
> not only the os is getting crappy also the people…i dont repeat all
> again and again.

i’ve tried to help you twice and won’t again…so, help yourself…

you should cease multi-posting the same problem into different
threads and fora–see, giving part of your problem in one place and
some bits of information in another, then complaining in a third
doesn’t lead to any of the potential helpers knowing what your real
problem is…or anything about your setup or situation…

i direct your attention to the extensive troubleshooting help and
guidance i pointed you to in this thread (which is another where you
gave NO information…just where did you hide the info you now
complain would be a repeat? perhaps in a third or fourth seemingly
unrelated thread):

and ask, did it help? where you able to work your way through the
directions there and not find a solution to your problem?

no offense intended friend, but if you don’t have the patience to
either lay out the whole of the facts needed for help, and then cah’t
find or follow the help given then “trash opensuse 11.2” (as you
threatened in the above referenced post) may be your best
option…that is, i’m am absolutely convinced that openSUSE is not the
very best system for all people on earth…and often recommend that
folks should keep searching until they find the solution best for
themselves…even if that means running Red Hat/etc, Mac OS/X,
Redmond or PlayStation…

of course, you should recognize when and if you move along that
thousands and thousands of folks did not have the seemingly
insurmountable sound problems that you had, so there is no real basis
for you to trash talk any distro you don’t have the skill or
patience to install and set up properly…

you may need an easier ride than openSUSE can give you…suggest
you demand your money back and move to what can provide what you want…


of course i google and try before posting the s* So this is not of any help as I know those.
Very simple…correct settings are lost at the next reboot. Version 11.2…still sound broken >:( it worked in 1998!

94-pool:/home/michael/Dokumente # dmesg | grep sound
6.220157] ALSA /usr/src/packages/BUILD/kernel-default- autoconfig: line_outs=4 (0x14/0x15/0x16/0x17/0x0)
6.220160] ALSA /usr/src/packages/BUILD/kernel-default- speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
6.220163] ALSA /usr/src/packages/BUILD/kernel-default- hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
6.220166] ALSA /usr/src/packages/BUILD/kernel-default- mono: mono_out=0x0
6.220168] ALSA /usr/src/packages/BUILD/kernel-default- dig-out=0x1e/0x0
6.220171] ALSA /usr/src/packages/BUILD/kernel-default- inputs: mic=0x18, fmic=0x19, line=0x1a, fline=0x0, cd=0x0, aux=0x0
6.221478] ALSA /usr/src/packages/BUILD/kernel-default- realtek: No valid SSID, checking pincfg 0x4015e601 for NID 0x1d
6.221481] ALSA /usr/src/packages/BUILD/kernel-default- realtek: Enabling init ASM_ID=0xe601 CODEC_ID=10ec0883
194-pool:/home/michael/Dokumente # ^C

alsaconf says to not find any pnp card but yast makes it work until the next reboot

on my first opensuse install ( yes i had to install twice so far >:( ) it worked!

ok i got it working the other way round. Most people remove pulseaudio but i expressly turned on pulseaudio as alsa don’t seem to recognize my audiocard.
Any quick way to report an alsa bug?

It’s not that alsa doesn’t recognize your audio card. It’s that it won’t run if the pulse server isn’t running.
You can try to kill pulseaudio, than run alsamixer: It should not work, than start pulse again, rerun alsamixer : it should work. In alsamixer, press F6 to select your physical audio device (not pulse) and adjust master and others volume.
Also if you have mplayer, you can try to output sound to oss. (mplayer -ao oss … ). It should work whether pulse is running or not (but alsa won’t).
In Kde, if you display advanced sound devices and select another one (if any), it sometimes help.

anyway now i only miss the kde system sound.
Im using cairo-dock with kde and cant even start kicker (kde panel) or kcontrol. Those cmds are not working in 11.2 anymore?