No more sound after new install (openSUSE 12.2)

Hello :wink:

recently i had some problems with my machine which forced me to reinstall openSUSE 12.2 (i kept /home though). Now after 1st boot the pc was very very slow (mouse not even moving or only very slow), i upgraded kde , kernel … and now the machine behaves ok. But i have no more sound.
I installed codecs for kde from 1 click install codec pack and also the softs told about here , plus moving them all to packman repo versions .
i 've been looking at yast/sound , alsamixer, kmix but so far i don’t know how to have a good setting for sound. Usually a reboot corrects it.
Can you please help ?

Thanks :wink:

i have this :

 inxi -F
System:    Host: linux-3n5s Kernel: 3.7.3-1-desktop i686 (32 bit) 
           Desktop KDE 4.9.5 Distro: openSUSE 12.2 (i586) VERSION = 12.2 CODENAME = Mantis
Machine:   Mobo: N/A model: P43Twins1600 Bios: American Megatrends version: P1.80 date: 09/03/2008
CPU:       Dual core Intel Core2 Duo CPU E8400 (-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) 
           Clock Speeds: 1: 2003.00 MHz 2: 2003.00 MHz
Graphics:  Card: Advanced Micro Devices [AMD] nee ATI RV770 [Radeon HD 4850] 
           X.Org: 1.12.3 driver: fglrx Resolution: 1680x1050@60.0hz 
           GLX Renderer: N/A GLX Version: N/A
Audio:     Card-1: Advanced Micro Devices [AMD] nee ATI RV770 HDMI Audio [Radeon HD 4850/4870] driver: snd_hda_intel
           Card-2: Intel 82801JI (ICH10 Family) HD Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture ver: k3.7.3-1-desktop
Network:   Card: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver: r8169 
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:19:66:a0:a6:a4
Drives:    HDD Total Size: 1480.3GB (26.9% used) 1: /dev/sda WDC_WD1600PD 160.0GB 
           2: /dev/sdb ST3320620AS 320.1GB 3: /dev/sdc SAMSUNG_HD103UJ 1000.2GB 
Partition: ID: / size: 30G used: 6.8G (25%) fs: rootfs ID: / size: 30G used: 6.8G (25%) fs: ext4 
           ID: /home size: 113G used: 27G (25%) fs: ext4 ID: swap-1 size: 3.23GB used: 0.00GB (0%) fs: swap 
Sensors:   Error: You do not have the sensors app installed.
Info:      Processes: 145 Uptime: 0:18 Memory: 1167.6/3990.4MB Client: Shell inxi: 1.7.24 

I note 3.7.3-1-desktop kernel. My understanding is that is NOT a nominal 12.2 kernel. Are you running Tumbleweed ?

no, i’m running openSUSE 12.2 as follows :

> uname -a
Linux linux-3n5s 3.7.3-1-desktop #1 SMP PREEMPT Thu Jan 17 22:03:20 UTC 2013 (8eb6368) i686 i686 i386 GNU/Linux

i used this repository :

zypper lr -d | grep KERNEL

  KERNEL_STABLE                 | KERNEL_STABLE                       | Oui    | Oui        |   99     | rpm-md |                        |  

Kernel 3.7 is up to 3.7.4 now, so a new update will be heading downstream I would guess. As for sound, the three places I look are here:

What is the YaST Default Sound Device and is it the one you use?

Is the Sound Profile for the device you don’t want to use set to off?

Is the Sound Profile for the device you do use set correctly?

The three things I check First when there is more than one sound device.

Thank You,

Make sure, that your user is in audio group. I’ve had problems with it when upgrading from 12.1 to 12.2. Previous versions didn’t require that.

hello :wink:

  • the default card is : 82801JI (ICH10 Family) HD Audio Controller

shall i erase the 2d one in yast / sound ?

  • the profile of
    Sapphire HD 4850 512MB GDDR3 PCI-E Dual Slot Fansink is indeed turned to off in system settings

  • about setting of the profile correctly , this i 'm not sure yet
    for example the profile is set to duplex stereo and i don’t know the difference with this and stereo

audio device playbkack is set, and then i’m not sure if i need to set the connection to Output or Headphones

it 's set to the 1st option , i’m trying the 2d option to check if it helps or not.

i added the user to the audio group, it does not help.

Let me say that you should NOT delete any sound devices. As long as they are all shown, you can select the default sound device while removing them can produce unreliable results. I suggest now that if the right sound device is **default **and the sound device you do not wish to use has a PulseAudio profile of Off, I request that you load the alsa mixer application called gmixer (@version 1.3) from YaST Software Management. Start the application, Select Devices and select the default sound card where it says (Alsa Mixer) at the end. Next Select **Edit **and put a check next to every sound control and press close. Expand out the main window to see all controls. Start something making sound, like a MP3 player. Go though all devices shown so that nothing is muted and all settings are at max. Make sure to turn down and mute the mic input when done as the max position can introduce noise when nothing is connected. Normally, if the sound device ever worked, one of these will start sound going. If nothing works, I would have a look at my bash script **start **you can find here:, there is an alsa script run option that produces a document that many here can use to see if some other action is required to get sound to work.

Thank You,

Note that ‘just’ adding the user is inadequate. You also need to log out of GNU/Linux (not just KDE, GNU/Linux) and then log backin, for permission changes to be applied. Often the easiest/quickest way to do this is a simple reboot.

I assume you have kept the /home from your previous install. One thing you could also do is create a NEW user (for a temporary test). Log out of the current user. Log in to the new user. Test their sound. Does that work ? If sound works for them but not for you, that will point the finger to a KDE configuration problem for your current user (possibly an incompatibility with the previous settings from /home).

Don’t forget to go into YaST > Hardware > Sound and configure your audio, setup your volume levels there.

And you could also provide us more information on your hardware/software audio configuration, by running with your PC connected to the Internet, the following diagnostic script for audio, copying the URL/web-address that points to where your hardware/software audio configuration information has been uploaded, and post that address here so users trying to support you can check the audio configuration of your PC.

hello ,

are you speaking of the script told about in message #8 ?

So far all other things are not working, gmix installed and applied related tips. I’m testing results with amarok and youtube (u2 songs).

I still need to use the script James told us about. i’ll give you the results asap.

i ran the script untill step 4 here are the results :

                    130124  Testing audio, Results of the start script :  

test 1 : alsa-firmware was missing, i installed it from multimedia/libs repo, then moved it to the opensuse version

test 2 :
1 – error : peripheral or ressource is busy (after reboot test is done but no sound)
2- tells me that if i can’t hear anything (which is the case, i’m using headphones and can’t hear anything) maybe the default card is wrong, or that i shall add me to the audio group.
I just did before but said yes to be sure .

Test 3 :

none of the sound files that i can hear

test 4 : same files with pacat : no sound can be heard.

then i wondered about the headphones , where they the problem ? I changed for another pair of headphones and then heard something in youtube … i thought it was ok, but after a while i tried amarok and could not here anyhting (!)

i then ran steps 12, 14 and 15 of the script .

i then rebooted the pc and found out that the cabled (Y cable for jack plug in) at the front of the pc was disturbing : when plug off i could hear the sound, when plugged in i could not …

So it seems that without this Y cable i can have sound. Which is strange for this cable always was plugged in before (when sound was ok).
Is this due to some settings in profile ? ( i mentioned it above :
in Phonon : audio device playbkack is set, and then i’m not sure if i need to set the connection to Output or Headphones)

Can i have more than 1 jack cable plugged in ? for example so that i have :
1 - at the back of the pc the sound going to the hifi system and to the headphones (using the Y cable)
2- an headphone connected at the front of the pc jack

I actually had this script in mind:


… but its a mute idea now as you appear to have solved your audio problem.

Typically when a headset/mic is plugged in, speaker volume is supposed to be muted.

There are some sound devices that did not have that behaviour, bug reports were written on them by various users, and the alsa developers have been fixing/addressing the written bugs one by one.

i understand about speakers and headphones_mic being related, but i usually use headphones to listen to the sound wihtout disturbing those around (which was also the case here) and (if my memory does me no trick) i do not remember any inconvenience.

So i was wondering if it’d be possible to have headphones at the back and the front of the pc at the same time (i guess it shoud be ok).

Normally, audio output goes through out the back, but is available in the front, if you have a front panel jack actually plugged into the sound card. In the old days, the audio signal was switched by mechanical means in the front panel jack, but later, dual outputs exist and can sense when a low impedance device, like a speaker or headphone is connected. When headphone detection is enabled, the norm is to mute the main speakers going out the back. If headphone detection is disabled, you may be able to have both connections live and you mute the speakers at the amp or receiver. Its doubtful that having both connected at the same time creates any problems, but features such as headphone detection and main speaker muting may or may not work properly in openSUSE and you may or may not be able to change its default operation.

Thank You,

My desktop PC has jack’s for audio out (and microphone) in the front. As soon as I plug a headphone in the front, the surround sound connections in the back (of the desktop) are disabled. I am able if I wish thou, to listen to audio via headphone AND have it out through speakers, via 3rd party hardware. My Logitech surround sound speakers, have an audio control device (with power, bass, matrix and volume control) that has a headphone jack. IF I plug my headphone into the logitech control device, it does not mute my speakers.

I know of no other method, although its possible a lower level config file (.asoundrc) in one’s /home directory might offer the functionality manchette_fr looks for. If it does, it is beyond my expertise to suggest what the content of such a file might be.