No more sound after installing Virtualbox

Until yesterday I was living the Linux dream. I had my computer working like a charm but I wanted more and I installed Virtualbox. It asked for some drivers and the kernel source for compiling them. After a reboot VB was working ok but sound was gone.

I’ve done some tests for solving the problem with no luck:

  1. reinstalled all ALSA packages
  2. reinstalled all pulseaudio packages
  3. reisntalled all phonon packages
  4. regenerated /etc/alsa-conf
  5. rechecked all sound settings under YAST (volume), everything looks good but there is no sound
  6. rechecked all sound settings under System preferences > Multimedia > phonon (gstreamer and xine are installed, gstreamer is the default engine)
  7. executed /usr/sbin/
  8. tried $speaker-test -Dplug:front -c2 -l5 -twav and other commands from SDB:Audio troubleshooting - openSUSE with this output

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 16384
Period size range from 32 to 8192
Using max buffer size 16384
Periods = 4
was set period_size = 4096
was set buffer_size = 16384
 0 - Front Left
 1 - Front Right
Time per period = 2,731825
 0 - Front Left
 1 - Front Right
Time per period = 2,987049
 0 - Front Left
 1 - Front Right
Time per period = 2,987001
 0 - Front Left
 1 - Front Right
Time per period = 3,157335
 0 - Front Left
 1 - Front Right
Time per period = 2,901735

And still no audio.

Any idea would be much appreciated,


Sorry to read your sound is not working. Looking at that diagnostic script output I note:

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 33 **52%**] -31.00dB] [on]

I concede that puzzles me. I don’t understand why you wish to demonstrate no sound with a low volume setting of 52% ?

Another question - Since you note you visited SDB:Audio troubleshooting - openSUSE , then I assume you saw the section that explains how to determine which application is using the audio device. What did you see when you ran that command line check after freshly booting and then again after running virtual box ? Do you have sound in either case?

If you restart your sound driver with (root permissions) with ‘rcalsasound restart’ and then restart your mixer, did you check to see if that restores sound ?

But in truth , with volume down at 52% no other suggestions are likely to help.

Thanks for your help oldcpu. No need to get mad at me.
I’ve made so many things to get sound on again that I unintentionally passed the 52% volumen setting.
I’d just corrected it and set it to 100%

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 64 [100%] [0.00dB] [on]

As for the output of the command using the audio device (after a fresh start up):

lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*
lsof: WARNING: can't stat() rpc_pipefs file system /var/lib/nfs/rpc_pipefs
      Output information may be incomplete.
pulseaudi 4605 pancho   28u   CHR  116,7      0t0 5238 /dev/snd/controlC0
pulseaudi 4605 pancho   35u   CHR  116,7      0t0 5238 /dev/snd/controlC0

VB is no longer installed but there was no sound even if I didn’t open the application.

rcalsasound restart did nothing at all. Although it shows no problem starting

#rcalsasound restart
Shutting down sound driver                                                                                                                                                          done
Starting sound driver:  hda-intel hda-intel                                                                                                                                         done

Still no sound at all. What is really interesting is that the mic is working and if I tap on it I get the tapping sound through the speakers.

Thanks a lot for your help,


This might be of some help: #cat /var/log/messages | grep ALSA shows this

Apr 27 19:49:48 fgil kernel:   374.766848] ALSA patch_realtek.c:1524: SKU: Nid=0x1d sku_cfg=0x4005e601
Apr 27 19:49:48 fgil kernel:   374.766858] ALSA patch_realtek.c:1526: SKU: port_connectivity=0x1
Apr 27 19:49:48 fgil kernel:   374.766866] ALSA patch_realtek.c:1527: SKU: enable_pcbeep=0x0
Apr 27 19:49:48 fgil kernel:   374.766872] ALSA patch_realtek.c:1528: SKU: check_sum=0x00000005
Apr 27 19:49:48 fgil kernel:   374.766878] ALSA patch_realtek.c:1529: SKU: customization=0x000000e6
Apr 27 19:49:48 fgil kernel:   374.766884] ALSA patch_realtek.c:1530: SKU: external_amp=0x0
Apr 27 19:49:48 fgil kernel:   374.766890] ALSA patch_realtek.c:1531: SKU: platform_type=0x0
Apr 27 19:49:48 fgil kernel:   374.766896] ALSA patch_realtek.c:1532: SKU: swap=0x0
Apr 27 19:49:48 fgil kernel:   374.766901] ALSA patch_realtek.c:1533: SKU: override=0x1
Apr 27 19:49:48 fgil kernel:   374.767108] ALSA hda_codec.c:4633: autoconfig: line_outs=4 (0x14/0x15/0x16/0x17/0x0)
Apr 27 19:49:48 fgil kernel:   374.767117] ALSA hda_codec.c:4637:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
Apr 27 19:49:48 fgil kernel:   374.767125] ALSA hda_codec.c:4641:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
Apr 27 19:49:48 fgil kernel:   374.767132] ALSA hda_codec.c:4642:    mono: mono_out=0x0
Apr 27 19:49:48 fgil kernel:   374.767137] ALSA hda_codec.c:4645:    dig-out=0x11/0x1e
Apr 27 19:49:48 fgil kernel:   374.767143] ALSA hda_codec.c:4646:    inputs:
Apr 27 19:49:48 fgil kernel:   374.767148] ALSA hda_codec.c:4652: 
Apr 27 19:49:48 fgil kernel:   374.769304] ALSA patch_realtek.c:1581: realtek: No valid SSID, checking pincfg 0x4005e601 for NID 0x1d
Apr 27 19:49:48 fgil kernel:   374.769316] ALSA patch_realtek.c:1597: realtek: Enabling init ASM_ID=0xe601 CODEC_ID=10ec0892

I decided to take extreme measures and uninstalled all ALSA and pulseaudio packages using YAST, restarted and reinstalled only alsa and pulseaudio without any plugins. After reboot sound came back.

Now I’m willing to see if I can reinstall Virtualbox.

I just can’t get enough :slight_smile:

Glad to read sound is working again for you. If by removing alsa and pulse, and re-installing alsa and pulse you managed to get sound working again, then that suggests to me there was possibly a configuration issue that by re-installing those apps you managed to have corrected. What I don’t understand is what you mean by “without any plugins” ? What apps did you exclude?

Also if sound is a ‘configuration’ issue, then one’s desktop selection comes into play (ie xfce ? lxde ? gnome ? kde ? ) . In the case of KDE, in addition to tuning sound under YasT > Hardware > Sound, one also has kmenu > configure desktop > multimedia > phonon where one can control the order of sound devices. Its nominally important in KDE to be consistent between YaST and the phonon selection but given different nomenclature is used, that can be puzzling at times (IMHO). My view is by also installing the application pavucontrol and running pavucontrol (and tuning in that app) to configure one’s sound setup, one has better control over the sound and its configuration.

Good luck.

Reference this quote - there are about 1/2 dozen different permuations of the speaker test, and my experience is it is not uncommon for a few of them NOT to give sound and a few to give sound, so this test by itself is likely not a valid test to see if sound is working. I can provide some additional sound tests if you like. I think the troubleshooting guide you quoted suggests at least 3 different tests.

This suggest a configuration issue with pulse or with the alsa sound driver auto detection.

Note that is not adequate by itself. One must restart their mixer and then try to tune the sound with the desktop selections.

Then you have sound, and had sound all along in terms of the alsa sound driver. What this suggests to me is pulse audio (which a previous lsof command showed running) was not configured properly. The application ‘pavucontrol’ would have helped you configure that (since you noted you failed doing same with phonon).

oldcpu, thakyou for your time and effort.

I agree my problem was, most probably, a pulseaudio missconfiguration.

I installed VB again and this time it worked like a charm.

Thank you, thank you, thank you,