No more display after nvidia driver update

Hello everyone,

This morning, I authorized an update as almost every day.
I saw that the nvidia driver was on the list but in recent years, I no longer fear these driver updates since everything usually works well…

Except that this time, no!
I turn on my pc this afternoon and more 3d effects. I run “Nvidia X Server Settings” which tells me I do not use the nvidia driver and must run as root the command “nvidia-xconfig,” what I do. I restart X and no display at all, only the prompt in text mode!

Before I break everything, I wonder if any of you could get me out of this mess.

Thank you very much in advance…

Go to Yast and try reinstalling the NVIDIA driver. Or install it the hardway

Done, uninstalled and reinstalled nvidia stuff with yast in text mode (not that easy). And back to the begining: no 3d effects.

Without attempting a hardway installation (if you mean via the nvidia download driver page, I’m not sure I’m able to do it), is there a way to resolve the problem with yast?

DO you know what driver is actually loaded? Easy way go to my computer icon should show driver name

We now call ‘the hardway (which is not hard)’ the manual method, as it is not hard. It is more manual. It does require one know some basic bash commands, such as ‘cd’ (for change directory) and ‘ls’ (list directory contents).

I described to a user in post#13 here how to install using this manual method: No video after 11.4 installation (in their case they needed an older nvidia driver because the new one was predicted not work for them due to their hardware). But whether new or old , the method is the same.

What typically bites new users is a failure to install: gcc, make, kernel-source, and kernel-syms. In particular, new users will install the wrong version of kernel-source and kernel-syms. Those two packages MUST have the same version as one’s kernel version (where typically one has kernel-desktop or kernel-default installed). Another new user mistake is to have both kernel-desktop and kernel-default (imho having only one is best for new users) installed and they will build the graphic driver against the wrong kernel version.

Its not hard. Its just manual. :slight_smile:

Hello, take this step by step:

  1. uninstall the nvidia driver either from Yast or text mode depending on your instalation type
  2. open a console, go to /etc/X11/ and use the ls command, do you see an xorg.conf and an xorg.conf.install ? if you seen them both, delete **just xorg.conf ** keep xorg.conf.install
    warning: if you had nvidia installed using the nvidia repo you will not find an xorg.conf (at least i did not found it…)
  3. make sure that nomodeset option** is active** as a bootloader option to disable nouveau from loading
  4. make sure that nouveau is blacklisted inside the file 50-blacklist.conf from /etc/modprobe.d, if not, you add the following line at the end of the file backlist nouveau
  5. after the clean up and adjusting of settings you install the driver again THE RIGHT DRIVER FOR YOUR VIDEO CARD, DON`T MIX UP DRIVERS, using repo or manual install(is not that hard, you accept license, if using 64 bit system you are asked about installing 32 bit libs too and at the end you accept or not to run nvidia-xconfig…is this really hard? :slight_smile: )

Steps 1 done.
Step 2 done. I have a quick look at /etc/X11 and I see that a new xorg.conf is created. I open it and see a line with: Driver “nv” :open_mouth:

  1. make sure that nomodeset option** is active** as a bootloader option to disable nouveau from loading
  2. make sure that nouveau is blacklisted inside the file 50-blacklist.conf from /etc/modprobe.d, if not, you add the following line at the end of the file backlist nouveau

Step 3 done, “NO_KMS_IN_INITRD” is already set to “yes”.
Step 4 done, I add this line to the 50-blacklist.conf file…

  1. after the clean up and adjusting of settings you install the driver again THE RIGHT DRIVER FOR YOUR VIDEO CARD, DON`T MIX UP DRIVERS, using repo or manual install(is not that hard, you accept license, if using 64 bit system you are asked about installing 32 bit libs too and at the end you accept or not to run nvidia-xconfig…is this really hard? :slight_smile: )

Then I reinstall the driver via yast (a new xorg.conf was created) and when I reboot, still the same issue: no 3D effects!
I try to edit xorg.conf and write: Driver “nvidia”
I reboot: no gui display, only text mode (init3)! I do not understand why the “nvidia” driver cannot be loaded…

I cancel this install, back to step 1 to uninstall, step 2 to delete xorg.conf and then reboot in init3 mode. I manually (hard way!) install the nvidia driver. When I reboot, everything works fine!!! I have a look at the xorg.conf created and I see: Driver “nvidia” rotfl!

Many thanks for your help but I still do not understand why the nvidia driver fails via the yast install and why the xorg.conf has the “nv” driver enabled instead of the “nvidia” one wich is enabled with the hard way install.

Strange. I have no problems with it. A word of warning though, since you installed manually you will have to reinstall any time there is a change to thee kernel or the X system. So keep the install file handy.

gogalthorp: you have a point there.
unbonpetit you keep the *.run file untill you decide to use a new version of the driver when is released.

IMHO thats good advice. I keep all the *.run files for a proprietary driver for each of my installed releases of openSUSE. One never knows when a roll back may be useful.

If you’re installing from repo you can keep all versions too by using the option -k or –keep-packages while installing or modifying the repo:

  • install:
zypper ar **-k** ftp://download.nvidia.com/opensuse/11.4/ *nvidia*
  • modify:
zypper mr **-k** *nvidia*

In this example, I gave the repo the name nvidia. But you can give it the name you like.
You’ll find the rpm packages in the directory /var/cache/zypp/packages/nvidia/x86_64 (or i586 for the 32bit version).

If you decide not to keep the packages anymore, you can apply the option -K or –no-keep-packages to this repo:

zypper mr **-K** *nvidia*

You can do the same with any repo.

Yes, we may never know what bugs may appear when using new drivers. (just look at nvidia and kde )